[APP][PRO] KEBA app

@Domotica-blog.nl
Now I have published a new test version that may help you, I will update the production version in a couple of days,

Oh nice - fingers crossed :slight_smile: :slight_smile:

Tnx!
Tested it. Adding device failed autodiscover and fell back to manual IP. But that failed as well:
image

Hi @aste
Please install test version again, it is now version 1.0.6 and see if it helps.
I could reproduce the error above and it was missing handling the port as number when save the device.
Hope this helps and you can continue.

1 Like

Boom!
Now it was found during the discovery process. Tnx!

Will try charging coming days.

Hi,
I’ve tested the app a few times now. I cannot get the app to update the values. I can activate/deactivate and set the charge current. But values never update in the app.
My home built node red integration works alongside the Keba mobile app for Android. First I thought it was a multicast to unicast issue, but I tried to turn it off, allowing multicast in my network. But it didn’t have any effect on the the Homey Keba app.

Hi @aste
You mean “actions” work, but not the reporting back to the app?
Please Send me a diagnostic report from within the app and I wil try to see what is happening. Also what Keba box/version/etc are you using (you can enter that in the message when you send the report) - thinking that maybe I am expecting a value that not other types of boxes send ( but I thought I was careful about that :slight_smile: )

FYI the app send message to get info every 15 seconds so it should update - I listen to the Report 2 and Report 3…

Diag sent ebd2474f-0a57-445e-96b6-acb8e65aef13.
P30 on v1.12

On my home built node red app I actually actively send “report 3” every second during operation to get an update. I also hade make a button to manually send “report 3” for it to “wake up” sometimes.

The phone app seems to behave the same. No auto update during use. I need to “pull to refresh” for it to update. But that might be by design. I haven’t used the phone app before.

Both of these led me to believe it was a multicast to unicast issue. But turning that off in my network didn’t change anything. And it should only affect wireless applications (homey and phone) and not wired applications (node red) anyway.

So there still is a possibility this is an issue related to my network as I have no experience running any of the products on any other network gear than I’m currently running.

@aste thanks, I will try to follow upp this afternoon or in the weekend.
(It looks that the device is not initialized correct, staring things in the (my) wanted order)

Could you try to restart app if you not have done that, and after a couple of minutes send a new report?

Thanks!

Sure, d9264f8a-c656-4781-9dc9-c33d385cb4a1.

@aste - and I am pretty sure it is working now, I see calls as expected - have you plugged in and seen if app show you data?
I think I know what the problem is - in device “added” I do some bad thing so when adding device I actually stop the polling. When restarting the “added” event is not run and all ok… I will check code and do a fix.

Oh hey woow!
I got mine working with v 1.0.7! I entered my IP and it worked!
My Mac is 00:60:B5:37:3D:0A, so it should have been found. It’s on the same LAN and IP-range as the Homey. But I’m very happy to be able to enter it manually! Thanks again Jonathan!

It seems to be working now. Thank you for your commitment!

Hi, is it possible to add a few items?
My Wishlist:

  1. Power per phase in Watts
  2. Energy usage increasing in kWh
  3. Insights for both above
  4. Current selector in app as a slider with 0,1 resolution 6-16A
  5. Current selector in Then Flowcard to set current as a slider or tag. Allow input value 6-16 in 0,1 increments.

@Jonathan_Cohen
I got a second, used, P30 and trying to add it to Homey. But I have no luck. After 1-2 seconds I’m informed there are no more chargers. I’m on the Test build of the Keba app.

The charger communicates just fine over UDP with my phone and computer.

I tried rebooting the charger and Homey.

What can I do to add my second charger to Homey?

What version number do you have?
Did you install the first before or after the version you are on now?

You could try to do a pair - then send me a diagnostic report and I can see what I can find.
(it should show, more chargers if the serial numbers are different…)

I’m on v1.0.9.
Probably this one. I confirmed first one being added in post 54.

Diag sent: e501e489-a138-4f95-b33e-ff092bb3536b
Serial and MAC are different

I tried to change the IP on the Homey Keba objekt from charge box1 IP to charge box2 IP. I can now control charge box2 from homey.

When I search for a new Keba, there still is none.

I believe manual add via IP would work around the find by broadcast issue.

@Jonathan_Cohen, did you manage to find the time to have a look at the discover issue?