Hi Jonathan.
So today - out of the blue - the app has again lost connectivity to my Keba.
Rebooted Homey, Keba, Homey, but still no connection.

Any idea as to why this happens?

UPDATE: Worked again next morning.


lør. 24. sep. 2022 11.37 skrev Joergen Seemann <jorgen@seecom.dk>:

When you say lost connection… does the device show with red icon and when click into it - a red alert saying “This device does not …” ?

Yes. That’s exactly the situation.
(But its working at the moment)

This is very strange. In this “state” the app is still working in the background - it still get info from Keba every 10 seconds by the UDP calls and updates - but the device cannot run.
I forced to use the IP (not mac discovery now on mine) and just get stuck here - I think I need to rework the structure somehow - I try to find why this happens - now I am out of ideas :frowning:

That is really very strange. I’m running the newest firmware versions on Homey Pro and Keba .
Wonder if there could be some sort of blacklist/lockout on the Keba - you could try resetting it completely (as long as it’s not tied to a provider - mine is so this limiteds a bit as to what I can do ;))
I’ll be more than happy to provide config dump / run some tests if it could be of any help to you. Just let me know :slight_smile:
(Thou as long as it’s working then I’ll prefer not to disconnect/break it :wink: )

Hi Jonathan and others,
I got my Keba hooked up via Wifi today, but I can’t get the App to find it. “No new devices” is all I get. They are on the same LAN, so no firewall opening should be necessary I guess.
I have made sure that dipswitch 1.3 is on.
Updated the Keba to FW 1.14.
Any ideas?

Hi @Jonathan_Cohen,

Installed the Keba app today and ran into the same discovery issues as described above.

Mine is connected both to Wifi and Wired and on the same broadcast domain as the Homey. An option to add by IP as a fallback would be nice when you can find the time.

I also noted that my wireless mac differs from the one on the second post. Mine starts with 88:6B.0F. Wired is the same.

I’ve built an interface in Node red using UDP and it works all the time. But in the beginning I was using the built in wifi interface and it had the same intermittent connectivity issues @Zigme described above. After moving to wired ethernet I have no connectivity issues at all.

\ Andreas

Hi @Magnus_Von_Rosen - I will add the IP fallback (when I have time and get it to work). I had IP connection from start - but was forced to move to discovery and that does not work perfect as I see it now. Also tried different types of discovery but cannot get it to work :frowning:
Can you access the UI/admin on IP, can you see your mac address on lan/WIFI when you are on the Keba admin?

@aste - thanks for info - I will try to add when I have the time - still have not got it to work on my installation - something seem to get stuck in Homey - and do not release …
I will also add the Mac to the discovery.
I can reach my KEBA from all interfaces, and also from my APP (all the time, but the do not recognize it…)

1 Like

no sure what you are asking, “When I’m on the Keba admin”…
I can access the Keba via its https interface via IP if that’s wheat you’re asking…

Hi Jonathan
My Keba seems to be unavailable again. Did you do something the other times that made it come back?
(Or do I just have to try to be patience :wink:)

tir. 4. okt. 2022 07.19 skrev Joergen Seemann <jorgen@seecom.dk>:

Hi @Zigme - No changes done - and myself cannot use the app still what ever I do. When I had problems and could get it to work - A broke the power to the charger for a minut or 2 and after that it worked again. But my homey installation seem strange and I must find the issue before I post a new version.

Ok. Info if it helps: At the moment my keba has the red sign saying its unavailable. However - the status still changes when I moce the box from being suspended into charging. So its kind of still gets the status even thou it appears as not being connected. Its really strange.
Fingers crossed for a breakthrough- let me know if I can assist in any way :grinning:

lør. 29. okt. 2022 13.54 skrev Jonathan Cohen via Homey Community Forum <notifications@athom.discoursemail.com>:

@Zigme - yes that is the problem I cannot get past, it works nicely in the background, even active in flows etc. - but only get the red sign… I have reached out in the developer slack channel and trying to solve this.
As soon as this is solved, I have a ready function to fallback to enter IP manually if discovery fails and setting page to handle the IP…

But for now I am completely stuck :frowning:

Hi all, I have a new version on the way, for now it exits in a test version; Keba | Homey

I have added fallback if MAC address discovery fails and also setting for device to set IP/port if changed and discovery do not update. Also some addition to try to solve the “device unavailable” problem (that somehow also was related to discovery).

I will let it be on test for a while and test it myself, if ok I will publish new version (and if Homey is ok with the changes).

Hi Jonathan.

Just FYI: I managed to get rid of the rid sign (after 3days) by turning the KEBA off AND restarting the app (in homey, apps, settings for your app - restart app).
It just wouldn’t go away after restarting Homey itself or power cycle the KEBA.


@Zigme - what I suspect and the new version that now is on test (will release prod version in a couple of days) is that when discovery fails the app is set to unavailable and I found a fix for it and incorporated it - now the app works for me perfectly (touch wood) for 2 days - and has fallback to if no discovery is found - you can manually enter the IP to the box and run manual mode.

Now I have published a new test version that may help you, I will update the production version in a couple of days,

Now I have published a new test version that may help you, I will update the production version in a couple of days (it has IP fallback, and also the MAC yo mention)

Now I have published a new test version that may help you, I will update the production version in a couple of days,

I also posted to my GITHUB repo (private, but can share if interested).