[APP][Pro] Insight Trends Reloaded

sorry accedently replied on a other post but.
yes it did, my origional settings where a trend calc. every 30 sec. for humidity over a timespan of 3 min. and these settings worked uptill the problems occurred 9 days ago accoring to my logging

Thanks Peter!

Cleared cache, tried three different browsers, same problem unfortunately. :cry:


Hmm, strange.

I’ve got version 1.2.0 from Sharkys, and it works! :thinking:


Hi spkesDE,
yes it did (at least i think so). Had some trends for a 5 min average and my PV meters are polled every 10 sec.

Hi SpkesDE

Tried the new version 1.4.0, but got errors.


Can you see what the problem is?

I have same problem. Only one data point in 5 minutes. Also after latest update.

Same problem here, percentile over a sensor’s brightness value results in a ‘Network request failed’ error.

@Fred_de_Goede @RoelofO , diag, Homey version and firmware ?

FYI, seems I get the datapoints fine on HP2023 - 10min interval (Voltage example)


Report a81c1860-35d9-461d-9b9e-ea7756a2699f. If you need more information I’d be happy to test things.

[err] 2023-05-18 12:00:00 [InsightTrendsReloaded] Failed to get log entries! Most likely Timeout after 5000ms. Try again later. homey:device:ea0d49f6-8855-42ea-aa34-7ec8ce1b3f22 - measure_power
[err] 2023-05-18 12:00:00 [InsightTrendsReloaded] [HomeyAPIError: Could not find that Log] {
  statusCode: 404,
  description: 'Could not find that Log'

It’s the same issue as @Sharkys had. It’s old Insights ID’s. You have to reselect all insights in the flows to make it work again.


I’m still encounter problems with the amount of data. I look at the configuration setup. Fill in a 10 minutes interval and don’t get a result. When I try it with the old insight trends I get 10 data points used. So homey gives data every minute but it’s not used in insight trend reloaded. What can be the problem?

1 Like

Without a diagnostic report I can’t really help you since I don’t know if there is any error accuring.
Also the old Insights trends is using a older API version. I use the newest api version. May Athom changed something that is causing this issue.

Thanks for your reply.
I don’t know how to give you a diagnostic report. But what I can show you is that I’m receiving an error when I make a flow to set a variable to the number of used data points. When I set 5 minutes I receive an error. When I set 20 minutes I only get 3 data points used. Can you do something with this info?

Homey Smartphone App (v7.x) → More → Apps → Insight Trends Reloaded → :gear: → Create diagnostic report

Still it would be missing for everyone, or ? Eg. on HP23 all datapoints are available, all is working fine…so I wonder where is the specificity in those cases where it doesn’t work (because for the majority seems to be fine, unless I would expect more messages here)

OK, strange. I’m getting the error straight from the GUI homey site. On my phone a Galaxy S22 I don’t get an error but there is no change in the variable
Diagnostic report is 050f48ed-f3f8-433c-8ac1-f7402d924cf9

Maybe you should clear the cache and reload the Homey web app, or open it in a private tab to see if it makes a difference.

I tried private tab and delete cash. I deleted and added insight reloaded app again. Also no result.
I’m running on the latest firmware from homey as well as on my phone. I’m having a 2019 homey version. Strange that until now nobody reported the same issue. It could be that other users work with a larger time setting. That is not resulting in an error but using only a few data points. Somebody having an idea? I’m now forced to go to the old insight version but want to use the insight reloaded because of updates.


you are not alone. Same isser here. HP19 and since update to the new API i get only 1 Datapoint every 5mins but my Sensors/Devices have 20sec polling rates


@Florian_Schmidbauer and @Fred_de_Goede could you install in the latest test version and reproduce this error and send me a diagnostics report? I added more logging to find the issue.

Edit: Somehow I can’t reproduce your errors on the HP2023.


2023-05-27T13:34:48.367Z [log] [InsightTrendsReloaded] Got 720 entries from homey with timespan(5min) of lastHour for homey:manager:system - homey:manager:system:loadavg
2023-05-27T13:34:48.368Z [log] [InsightTrendsReloaded] After FilterNullValues(false) the length is 720
2023-05-27T13:34:48.368Z [log] [InsightTrendsReloaded] After Date Filter(1685194188367) the length is 59
2023-05-27T13:34:48.376Z [log] [InsightTrendsReloaded] Got 59 from getLogs. The tokens are: {
  min: 1,
  max: 10,
  mean: 6.6271186,
  median: 8,
  standardDeviation: 3.1239822,
  trend: -0.0072238,
  firstvalue: 2,
  firstvalue_timestamp: 1685194190000,
  firstvalue_time: '27/05/2023, 15:29:50',
  lastvalue: 1,
  lastvalue_timestamp: 1685194480000,
  lastvalue_time: '27/05/2023, 15:34:40',
  size: 59