[APP][Pro] Homewizard

v2.1.36 (beta /test)

  • Energy-socket changed from “sensor” type to socket type, so you can flag what type of unit is plugged in the socket (heater, tv, solar, etc…)

Hello @Jeroen_Tebbens
i am running homewizard energy app (v0.0.7) in homey for the Homewizard P1 but since a few days it keeps restarting down causing the homey to respond slow to http requests…

i dont have a homewizard anymore so i am not able to use the homewizard app for homey
can you help me with this ?

attached is the error from the homewizard energy app

You are using an old app which I dont support anymore. Please use the Homewizard app as it has the P1 included and improved http handling.

thanks @Jeroen_Tebbens .
i have installed it but it doesnt find the p1 dongle , and i have no way to add it manually

Is your p1 in the same network as your Homey?
Local API is also enabled?

yes in same network and yes Local API is enabled in the energy app

Ok please unplug/plug your p1 (not sure where it gets its power from but remove the p1 from your meter and usb power cord (ie. it reboots). This should reinit the mDNS broadcast. When the light turns green again try to pair it again during discovery. Please note that during discovery you do NOT press the pair button on the p1 it should stay green as it is.

1 Like

okay will try this when i get home…
i will let you know .
thanks for your help :slight_smile:

I wonder if anyone have tried to power WaterMeter by power bank or have anyone measured power consumption ? Also any experience with having WaterMater in 2m water shaft ?

This did the trick for me !
meter is now added to homey using the new app .
many thanks

Good to hear, thanks for confirming this is a solution for not finding the p1.

Hi @Jeroen_Tebbens
I ame using your HW app happy for years.
And i know it work well.

Recently i cant connect localy by web browser to my homewizzard any more and also not by Homey.
This is not a problem of the app, but maybe you know a sollution?
Connecting localy by my iphone on wifi works wel…
Stange, using the same credentials.

Would be graet u can sent me in the richt direction.
THX!!!

Sounds if you having Homewizard unit on a different AccessPoint or different SSID? So potentially different subnet compared to your Homey or PC/Laptop.

What you can try also on your browser is this:

http://192.168.1.221/password-goes-here/get-status

Hello @Jeroen_Tebbens

I got this responce.
Looks i can raed out the Homewizard, it if from the same network homey is in.
Homey can’t connect to Homewizard.

Anny idea?

THX!!!

{"status": "ok", "version": "3.403", "request": {"route": "/get-status" }, "response": {"preset":0,"time":"2022-09-29 10:25","switches":[],"uvmeters":[],"windmeters":[],"rainmeters":[],"thermometers":[],"weatherdisplays":[], "energymeters": [], "energylinks": [{"id":0,"tariff":2,"s1":{"po":2323,"dayTotal":13.81,"po+":2944,"po+t":"11:03","po-":0,"po-t":"00:01"},"s2":null,"aggregate":{"po":-2120,"dayTotal":-0.82,"po+":4000,"po+t":"07:30","po-":-2760,"po-t":"11:56"},"used":{"po":200,"dayTotal":9.15,"po+":4000,"po+t":"07:30","po-":0,"po-t":"08:24"},"gas":{"lastHour":0.00,"dayTotal":0.53},"kwhindex":4.70}], "heatlinks": [], "kakusensors": [{"id":0,"status":null,"timestamp":"00:00"},{"id":1,"status":null,"timestamp":"00:00"}]}}

Logging in by the browser seems not to work:

Did you change your wifi / accesspoint recently? To me it sounds like if Wifi Clients are not allowed to talk/communicate to each other over the same wifi.

Further send me a diagnostic report from the Homewizard/Homey app/settings.
Assuming you have the Homewizard unit added and your other sub components.

Hi Jeroen,

I have set you the diagnostic.
Can you please also sent it to me?

Thx!

Problem is fixed by remove/add the Energylink again. Somehow in rare cases the Energylink can lose its relationship with the mainunit in Homey itself.

1 Like

Hello,

Yesterday my meter changed from a Fas1 to a fase 3. When I had the fase 1 I had 4 meters
Totaal T1 Gebruik
Totaal T1 Teruglevering
Totaal T2 Gebruik
Totaal T2 Teruglevering

A day later I only have
Totaal T1 Gebruik
Totaal T2 Gebruik

3 meters have been added: For all 3 fases a Huidige Verbruik…

But I have Solarpanels, how can I get de T1 and T2 teruglevering in Homey…?

Jacob

Did you remove/add your p1 on your smart meter? Also could you restart the Homey/Homewizard app. If no change than we need to check what the p1 shows in its API and I can then verify it with my code. This type of cases are not easy to troubleshoot. Changing from a Fase1 to Fase3 with keeping the same device in Homey is not a daily task.

I’ve got a new meter, so yes… I have removed and added it, I also deleted the P1 from my Homey and added it to Homey, but still the same result.

I didn’t removed it from the Homewizard app: Energy… But I don’t think that will help because I can see alle 4 meters there.
In My.homey.app at Inzichten I see this:

But the graphics of Teruglevering are empty…