[APP][Pro] HomeKit Controller - for a better Homey

Bonjour Nicolas,
Oui j’ai réussi a l’intégrer ( même 2).
J’ai pris la version test, ensuite j’ai intégré le fp2 sur homey, qui ne voulait pas. J’ai donc supprimé le fp2 dans l’App aqara et je l’ai de nouveau remis sur l’App, et j’ai pu ensuite l’intégrer dans homekit.
C’est laborieux quand même


Merci pour la reponse rapide !
J’avais compris que je devais le supprimer uniquement de Home assistant mais pas de l’app Aqara !

Je vais essayer :slight_smile:

@The_cure_Bob @Nicolas_Coquet

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:

Français (French)

1 Like

I have an iDevices wall switch, which I’ve removed from the Home App but I’m getting this error (photo attached).

Please advise

Can you start a new fresh browser session with homay and try pair again your device (or did you already refried). Please enter ok once after pin and wait…

If fails again please pm me the log. Goto app settings and copy

Hi Martin,

I am brand new to this community, I don’t see how to PM.

I did do what you suggested I try, and still got the same results, where should i send you the log?

Click on my name and message

I’m suspecting that I still need permission to PM other members, because I don’t have such an option.

Sorry for the extra trouble, if you can email me i’d reply with the log, or if there is no private network info in the log, I can post it here as well.

Hi all,

I never worked with Homekit and I don’t know anything about. That brings me to the question. Can I install an Aqara FP2 with this app without actually owning a Homekit? Or is a Homekit not a separate device, but more a way of integration in the Apple system?

EDIT: apparently no need for a Homekit controller.

1 Like

Hello, Perhaps strange question… but were to find the pincode.

(first time installing FP2)

Simple on your device😀

Hello Martin

The last couple of updates fixed the problem with my Velux blinds/windows. The percentage is now correct.

If I may come with a small request. I would like to be able to press the blinds/window button and it then toggles the blinds on/off or 0/100%

Thank you

Hi Martin,

I figured out I can add a Roku streamer (4800X) to Homey using your Homekit Controller app. After I add it, I can see commands (Rewind, FastForward, Next, Previous, Up, Down, Left, Right, Select, Back, Exit, Pause and Info) and if I scroll to select one of these, it does that function on the Roku, which is great.

When I try to create a flow, I get these:

WHEN - Capabilities (Device State, State media) which are on/off and play, paused, etc.

AND - Capabilities, Capability options or Capability number.I have a question I hope you can help with

THEN - Device Properties, Properties options, Property numbers.

I played around with the THEN card and don’t have the correct Properties options or Property numbers

I’m hoping you have more developer knowledge to give me a mapping of the Capabilities, options, numbers and the Device Properties, options and numbers that will allow me to “control” the Roku

Thanks in advance.

Can you click the Device Properties in the THEN card and post screenshot?

If there is an option Remote key select that and click Properties options, post a screen shot as well, Property Number can be used for capabilities that have no options but use a number, like dim or so.

If still issue, can you install test version 1.2.4

then goto device settings and scroll to below field and select all/copy the contents of JSON and PM it to me, this way i can create a virtual device like yours and check its behaviour/definitions.




I played around with this and selected Remote key for Device Properties and Down for the Property options and then tried 0, 1, 2, 3 for the Property number, but it always reported: Value X is not valid X=value I tried.

I also tried selecting Down for the Property options and null for Property number since the card says Properties option or value Property number and got error: Value 5 is not valid

If I can figure out what the valid Property numbers are, I might be able to get it to work.

Back in Oct, I submitted a request to Roku to develop a Homey App for Roku, but they seemed to think I was requesting an app on their platform which they call channel even though I tried to explain it and said they could work with the Homey developers.

I had what I thought was a great idea to use this controller to connect Hubitat to homey

Hubitat can publish its devices to HomeKit so using this app I connected a few simple devices that Hubitat happily controls (a motion sensor and and a couple of power switches that have lights attached to them in remote places hence wanting to keep Hubitat as the aggregator of connections) but whilst the devices are added to homey they are not identified correctly and do not work.

I have an fp2 presence sensor and that works fine so the controller app is Running ok.

In the attached picture the hallway and the two lights are devices connected to the Hubitat

Install the latest test version. Then go to the habitat device settings. Scroll to the field JSON and select all and PM me the contents of that field.

So i can reproduce whats going on in my environment.

Hi Martin,

Loving this app, I have it working on the FP2 no problems at all. I’ve also added my LightWaveRF gateway, however when I try to use any of the devices that have been added from the gateway I get an error, I also don’t seem to be able to add all the devices in the LightWaveRF app. I suspect that as the devices have either two sockets or multiple switches it only shows part of the device, so one of the two sockets, or one of the 3 or 4 switches. I’ve attached a screenshot of the error I get, I’ve looked in the logs and don’t see anything happening I also don’t see where I can specify the Listener

Happy to supply any information or try any suggestions

Edit: each of the LightWaveRF devices have the ability to recognise multiple presses and within the LightWaveRF app perform tasks, under the advanced section for each device I see 30 labels however putting a name to a label does nothing to resolve the above screenshot error.

If you do not already, can you check with latest test version?