[APP][Pro] HomeKit Controller - for a better Homey

Sounds like a bug in Homey.

I got an FP2 sensor and added it to Homey fairly easily. Lots more testing to do, but works great as far as I can tell to this point! Thanks!

2 Likes

I tried using the HomeKit controller to install my MyQ garage door opener. The Controller found my hub and set it up. I was then able to add the garage door opener successfully. I have tried to open the garage door that was installed, but nothing is happening. I am on version 1.3.10. Thanks in advance for any insights you can provide.

Can you turn on debug for the door device using its settings. Execute command and pm me the log. Also pm me the JSON field of the settings of the hub if you can.

I am trying to connect aquara fp 2 to Homey pro 2023 via HomeKit controller, but i get this error when i have entered the parring code.

192.168.3.106undefinedx Socket close 192.168.3.106 51308
2024-06-12T13:55:50.771Z [err] [ManagerDrivers] [Driver:hapIP] pairing not successful connect EHOSTUNREACH 192.168.3.106:51308
x Socket error 192.168.3.106 51308 Error: connect EHOSTUNREACH 192.168.3.106:51308

Any advice?

Unplug the power from the fp2 and back on.

Try again after a minute or so.

Thanks for reply. I have tried a lot of times, I have also deleted device from aqara app, and started over. Homey and fp 2, have been restarted a lot of times. FP works in aqara app. I cant figure out what is wrong

Your FP2 isn’t added to a HomeKit installation already? Also, are Homey and the FP2 in the same network/VLAN?

No unfortunately. Yes it is on same subnet/ VLAN as homey

Can you a clean setup again and send me the complete log?

undefinedx Socket close 192.168.3.106 52494
2024-06-15T17:26:21.046Z [err] [ManagerDrivers] [Driver:hapIP] pairing not successful connect EHOSTUNREACH 192.168.3.106:52494
x Socket error 192.168.3.106 52494 Error: connect EHOSTUNREACH 192.168.3.106:52494
at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1555:16) {
errno: -113,
code: ‘EHOSTUNREACH’,
syscall: ‘connect’,
address: ‘192.168.3.106’,
port: 52494
}
2024-06-15T17:26:17.981Z [log] [ManagerDrivers] [Driver:hapIP] pairSetup
2024-06-15T17:26:09.233Z [log] [ManagerDrivers] [Driver:hapIP] {
name: ‘Presence-Sensor-FP2-5DBD’,
host: ‘Presence-Sensor-FP2-5DBD.local’,
address: ‘192.168.3.106’,
port: 52494,
‘c#’: 1,
ff: 2,
id: ‘08:18:B6:1D:CA:4B’,
md: ‘PS-S02E’,
pv: ‘1.1’,
‘s#’: 1,
sf: 1,
ci: 10,
class: ‘sensor’,
sh: ‘4GmCOQ==’,
availableToPair: true,
pairMethod: 0
}
2024-06-15T17:25:51.247Z [log] [ManagerDrivers] [Driver:hapIP] Bonjour Up Presence-Sensor-FP2-5DBD._hap._tcp.local {“addresses”:[“192.168.3.106”,“fe80::56ef:44ff:fe56:5dbd”],“subtypes”:,“name”:“Presence-Sensor-FP2-5DBD”,“fqdn”:“Presence-Sensor-FP2-5DBD._hap._tcp.local”,“host”:“Presence-Sensor-FP2-5DBD.local”,“referer”:{“address”:“192.168.3.106”,“family”:“IPv4”,“port”:5353,“size”:526},“port”:52494,“type”:“hap”,“protocol”:“tcp”,“txt”:{“sh”:“4GmCOQ==”,“ci”:“10”,“sf”:“1”,“s#”:“1”,“pv”:“1.1”,“md”:“PS-S02E”,“id”:“08:18:B6:1D:CA:4B”,“ff”:“2”,“c#”:“1”}}

Are you using VLANs and if so, what brand router are you using?

Yes. Ubiquiti unifi

What’s the IP address of your Homey?

192.168.3.35

Given that Homey and the FP2 are on the same network segment, the EHOSTUNREACH error seems to point to a router or firewall that is blocking Homey’s connection to the FP2 for whatever reason. That would ultimately be a local networking issue.

Can you check the mDNS setting in the router

image