[APP][Pro] FACE++ Face Recognition for Homey

Maybe I am missing something haha.

But I have added 2 faces and made 2 flows

I have to put something in the search faces field. so I typed wesley(but I want to search for more names)

Then indeed the second flow I can add the token

But I don’t find how I can just let hem search for faces without typing something in the search field?

Ah, ok. So the ‘origin’ token in the search_faces card is intended to give a name of the camera that provided the snapshot. This makes sense if you have multiple camera’s. It does not search for that name. The card actually searches all faces it can find in the image, and will trigger the when-card for each found face.

In the ‘when card’ you will have the origin tag, so you know from which camera the detection came. To do a specific action for Wesley only, you can put an ‘and card’ where you check for label=wesly, or face_token=xxxxx (the face token from Wesley as found in the app settings).

aah oke than my flows are oke i indeed taught you needed the search in the 1ste flow to search for a specific face

Thnk u

Version 1.0.4 is available for testing. Get it here: https://homey.app/a/com.gruijter.facepp/test/

  • Added test image
  • Fixed unhandledRejection errors
  • Added API check
  • Improved app logs
  • Removed INVALID_OUTER_ID log

The test image is available as global app token. It has 5 faces in it with which you can test your flows without having to run around in front of your camera all the time :slight_smile:


Version 1.1.0 is available for testing. Get it here: https://homey.app/a/com.gruijter.facepp/test/

  • Added cloud queueing and rate limiting. (fixes CONCURRENCY_LIMIT_EXCEEDED)

Version 1.1.1 is available for testing.

  • Added clickable registration link
  • Added log filters
  • Fixed flowtoken_already_exists
  • Fixed ENOENT: no such file or directory

Version 1.1.3. Get it here: https://homey.app/a/com.gruijter.facepp/test/

  • Fix not able to add faces
  • Add warning that each Homey needs own API key

Version 1.1.4 has been released in the Homey app store as stable version. Many stability improvements have been implemented.

In just a few days the app has been installed by a good number of people. I hope it works well for you all :slight_smile:

Please share how you use it, and what you think of the app.

As a spin-off project I have made a second app for ANPR (License Plate Recognition). I hope this gets certified for the app store within a few days. Get a sneak preview here:


I’ve installed face ++ and registered, but I get an error "AUTHENTICATION_ERROR at FacePP_makeRequest (/facepp.js:206:34) at at process_tickCallback (internal / next_tick.js: 189: 7)

Looking forward to making it work. :slight_smile:

That means you have not entered the correct API key and secret in the app settings. Make sure to correctly copy and paste (and not copy the ***** for instance)

Ok i try again, think i did it right. :grinning:

When i copied it there was a lot of spaces in front of the key so best double check!

1 Like

Typed them in, still doesn’t work. Made a new key.
Can’t get it to work.

I will make a new version where you can toggle-view the password field so it is easier to see what you paste/type in.

I just double checked myself on a fresh app install version 1.1.4, and I have no problem getting the right API key and Secret working.

Hi. I have tried your app but i couldn’t fix it. I have made a account on face ++ and i install your app and i filled in settings the Api Key from Face ++ account and the Api Secret key. Then i have to made “Faces” with a face token. Where i can made this. Have i to do this in Face ++ account or have you a manual how to fix this.

Like the instructions say: After saving the API Key and Secret, go to the faces tab and upload a photo of a face. The face token will be generated automatically. What exactly isn’t working?

By the way: I found out that on Android the Homey app doesn’t display errors and feedback (a bug in Homey itself). As alternative to using a smartphone you can go to the app settings via a PC webbrowser: http://developer.athom.com/tools/app-settings

This will give you the feedback and might also make it easier to select and upload a photo-file.

When i select file (photo) i got the message AUTHENTICATION_ERROR

1 Like

Hi. Now it’s working. Thanks. Now i needed a sample of a simple flow with a camera.

1 Like

You are great. Thanks

1 Like