[APP][Pro] FACE++ Face Recognition for Homey

I get lots of unclosed server errors? Any idea?

See this issue: https://github.com/gruijter/com.gruijter.facepp/issues/6

Version 1.1.5 is pending stable release. Available now already as test version: https://homey.app/a/com.gruijter.facepp/test/

  • Stability improvements
  • Added toggle API Secret view in app settings
  • Fix threshold settings

When copy/pasting the API secret, you can now see what you have entered by clicking on the :eye:

1 Like

Hi Gruijter,
I think this is much fun to use. Got it to work just now for the first time. setup was straight forward.
Now i have the ring pro and let it make a snapshot. I see in several flows that you let the camera search for faces after o sec,1sec,2sec,3sec. This way i am getting 4 times a recognation message. Why is this nessesary?

gr,
Frans

1 Like

Im not capturing the ring camera image, because that indeed doesnt change that often. :wink:
So Im only using the ring motion detection to trigger the snapshot capture of another camera (50 euro Aldi maginon).
Making multiple snapshots with some seconds delay significantly increases the chance to get a snapshot in which a face is captured good enough to do recognition.

Hi Frans

To avoid duplicate hits, try disabling the flow for 5 seconds after getting a recognised face.

1 Like

It actually recognize through windows too, I`m getting “caught” when in my kitchen from the outdoor entrance cam, 5 meters away, and in a different angel.

1 Like

Awesome App! Working fine! Is there any support link? :money_with_wings:

Go to the app store, and in the bottom you will find links how to support yourself, and to support me :wink::heart::beers:

3 Likes

I received a donation from a number of app users. Many thanks! :hugs: It is always nice to see that people appreciate my work in one way or another :kissing_heart:

4 Likes

Version 1.1.6 is available from the test link:

  • Fix not able to send to Telegram on NO_MATCH.
  • Fix app settings pop-up messages.
2 Likes

This app gives some nice new posibilities for Homey. But it’s a bit creepy too. There was nobody in the garage at this moment: :scream: :scream: :joy:

Nobody there? Or so you think…

And to keep this from happening again:

  1. Make sure that the reference photo’s you upload are of excellent quality (90 or higher)
  2. Put a check in your flow that the quality of the image is higher than e.g. 50
1 Like

Hi,

In case there is no face found I am getting the message:
[log] no faces found in image XXXXXX

However when a face is detected in the image I am getting the message:
[err] Error: INVALID_OUTER_ID at FacePP._makeRequest (/facepp.js:206:34) at processTicksAndRejections (internal/process/task_queues.js:97:5)

So not having success with the app yet.

Actions done so far:

  • Checked and double-checked API + Secret
  • Re-typed API + Secret: Did not solve the issue!
  • Restarted the Face++ app: Did not solve the issue!
  • Re-installed the Face++ app: Did not solve the issue!
  • Disabled the Pushover app: Did not solve the issue!
  • Restarted Homey: Did not solve the issue!

One thing I discovered is that using Face++ action card and Pushover action card in the same flow will crash the Pushover app so perhaps the issue is with the combination of these two apps?

Any ideas?

Tx
Robert.

Outer_id issue can be related to using another api key after adding faces. Or it could be caused by making a Homey backup and restoring it on another Homey. But in both cases removing and re-installing the app should have solved it. Did you remove the app fully before installingbit again?

Hi, thanks for your response. I went into Face++ settings and chose ‘Uninstall’, I assume this is a full remove. Please let me know if I’ll need to do anything else (e.g. also remove flows in which Face++ cards are being used etc.).

Update:

  • Deleted original created API and created a new (free) API: Did not solve the issue
  • Uninstalled Face++ app, created new faceplusplus.com account including new API, restarted Homey and re-installed Face++ app: Now I get [err] TypeError: Cannot read property ‘threshold’ of null at /app.js:212:65 at processTicksandRejections (internal/process/task_queues.js:97:5) at async Promise.all (index 0) at async FaceApp.searchFaces (/app.js:225:4) when testing with the test image

Not sure if it helps but with my ‘old’ facepluplus.com account I got lots of errors:

With my ‘new’ facepluplus.com account I almost have no errors, so although it does still not work, it seems creating a new account at faceplusplus.com did make some change:

Note: I have to admit that at my first try (old facepluplus.com account) I did not upload Faces yet, with new facepluplus.com account I did upload a test Face, not sure if that is related to the issues I am facing!

After changing the ‘Confidence Threshold’ to ‘40’ (the Face I uploaded was not of the greatest quality (Detection Quality = 43,75)) and restarted the Face++ app, it seems to work.

Although not sure what exactly fixed the issue (I think it is the combination of the new faceplusplus.com account and the fact I uploaded at least a single Face) it is working. Hopefully this helps others facing similar problems.

Robert.

Ah, that makes sense. I will add it to the app roadmap to fix these errors after a clean install with no faces added.

It might be that Pushover is not able to handle certain flow tokens. E.g. for Telegram at first the boolean (true/false) cards didn’t work. And also weird characters like the underscore in NO_MATCH caused issues. Please take that up with the developer of Pushover @PandaNL

New version 1.1.7 is pending approval in the app store.

  • Fix INVALID_OUTER_ID when no face added.
  • Fix THRESHOLD error after clean install.

Available now as test version: https://homey.app/a/com.gruijter.facepp/test/