[APP][Pro] Eufy Security

Hey @Sharkys
I had just the same thing. That’s why I placed it in Eufy :smiley:

But can you elaborate on this?

1 Like

Because I can send it to Chromecast but not to Homey, for that I would still require Soundboard, right?

But it’s not big deal :slight_smile:

Hmm yeah. Don’t think it’s possible. Without having to duplicate the soundboard code

1 Like

@Sharkys you can use soundboard with Google Chromecast too: [HOWTO][PRO] Use SoundBoard with Google Chromecast

1 Like

my region is Singapore and selecting EU or US both don’t work when trying to log in. Will you be adding support for other regions?

Hey @Elinu
Can you check here :

https://extend.eufylife.com/domain/NL

Change NL to your countrycode. And return me the result

{“code”:0,“msg”:“OK”,“data”:{“domain”:“security-app-eu.eufylife.com”}}

I’ve just created a diagnostic report:
fc748d6b-a75c-4f96-9c37-8a1730134af4

Have 2 pan & tilts. Could only turn 1 on and off, the other would time out. Until I went through FAQ again and shared the devices instead of home.
So far so good.

Now got a Solo S40 for outside, but again I cannot control anything. Not on/off not the floodlight.
Removed it, added and shared it again, filled in the local IP manually and synced the device data again.
The battery and temperature are reported.

If I set the mode to away manually, the thumbnail of alarm shows in homey. If I use homey to set away, it does set it but I get an invalid response popup. Setting home again also works.

Hey @Floppus
As dat as I see the LOCAL_STATION_IP is empty. Can you verify the IP adress?

Yeah, it was empty after installation too. Had added it manually and is saved.
I updated the first post with some additional troubleshooting info.

Yes but the logs show a empty LOCAL IP
Maybe try restart the Eufy Homey app?

eec89020-ae54-45b9-af49-a945b86f4f43

Restarted app, reset notification service, restarted app. Reset the camera. IP verified. No banana.

In the logs it looks like Its connected.
Also no errors.

log] [P2P] - T8124P2022100F73 - Found IP address { host: '192.168.1.145', port: 29042 }
[log] [P2P] - T8124P2022100F73 - Connected Front Camera
[log] [P2P] - T8124P2022100F73 - Connected to P2P service

Odd… Changing the mode is logged as event in the Eufy app, so that works. Thumbnail is available in Homey after an alarm event, so that cones through. Battery status is also shown.

Eufy events are shown in homey. Homey on/off is not shown in Eufy and it is not switching.

Both camera on/off and light on/off give a popup after 30s with time out. Is that a generic homey error or app specific?

@Floppus please keep this thread in English. Or move the question to the dutch subtopic

Events are not the same as sending commands so that makes sense.

The timeout is Homey related but also to this app.

Can you toggle a few commands and send a new report?

Whups! Hadn’t even noticed - I turned the previous post English. We mix some languages at home based on who you speak to and your name triggered my brain :wink:

I’m cooking now but I’ll try a bunch of stuff and generate reports for diferent things tried. Shall I post here or send a DM so we keep troubleshooting out of the thread?

Yeah DM is fine!

Ah, I cannot start a DM conversation yet - newby status haunting me.

I tried turning on off and lights on off a lot, switched from geo to home setting - geo is not supported on S40 (It’s not even a camera function, so no idea why…)

Report
3b572575-38ad-4db3-bc95-70b8d6d492cc

The Security modes.are all the same for every camera. I didn’t make any differences.

Also didn’t know that the S40 has no GEO option

Is your camera in the same network and same endpoint as your Homey?
It seems like Homey cant find the camera

Yeah, it’s all the same as the 2 pan and tilts. The 2nd pan&tilt on off only started working when I gave device based access to a 2nd admin account.

No such luck with this one. I can remove it all and start again? … It still nags me that initially it did not fill in the IP address by itself. I added it manually after the camera was already added to homey.