[APP][PRO] ControlMySpa

New app update (test: 1.4.7):

  • NEW: add multiple pumps and blowers
  • NEW: add manual update button (flowcard)
  • FIX: desiredTemperature when heater mode changes
  • NEW: add temperature range
  • NEW: add sensor values to sensor tab
  • NEW: add setting to round the temperature values without decimals
  • FIX: flowcard listener missing + language changes
  • FIX: add/remove pumps & blowers dynamically
  • FIX: translation + LOW/HIGH setting
  • FIX: setting pump and blower HIGH/OFF
  • FIX: light button state

@OH2TH done

Wow you are fast. Seems that all above is working good now. Did find something when change Temp Range High / Low, but need to identify what is happening.

  • Setting to Low, status is updated, but Online status becomes No, until change the target temp from CMS App.
  • Setting to High, status is updated, but target temperature becomes current temperature.

Need to test a bit more on this one later in the evening or over the weekend. Isnät a blocker anyway to do some magic.

@OH2TH

Yes so current desired temp is set like this:

if heater is on → take targetDesiredTemp
if heater is off → take desiredTemp

But have to check what that does.
But we’ll keep in touch about that.

For the coming week i’m limited in development work. Can answers questions and fix bugs though

1 Like

There is energy_value_constant, but then again it isn’t constant on devices like a Spa. Now I happen to measure power consumption with a 3-phase Shelly, I would love evaluate from those the total consumption and update measure_power on this device. Would this be possible?

Maybe an advanced setting to choose from constant or measured.

2 Likes

Wishlist for And cards:

  • Temperature is equal to number.
  • Temperature is greater than number.
  • Temperature is less than number.
  • Target temperature is equal to number.
  • Target temperature is greater than number.
  • Target temperature is less than number.
  • Temperature range is (high|low).
  • Panel lock is (on|off). (already exists)
  • Online status is (true|false).
  • Heater is in (ready|rest) mode.
  • Pump (1|2|3) is (on|off).
  • Blower (1|2|3) is (on|off).
  • Light is (on|off).

Temperature range issues:

When range is set to Low from Homey App:

  • range is update correctly on CMS
  • Device online status in homey goes No
  • And if I update target temperature once, device becomes online and then CMS and homey device are in sync

When range is set to Low from CMS App:

  • range is update correctly in Homey
  • Device online status in homey goes No unless target temperature is also changed then device online status stays Yes
  • And if I update target temperature once in CMS App, device becomes online and then CMS and homey device are in sync

When range is set to High from Homey App:

  • range in CMS stays Low and target temperature goes to 10 and online status stays Yes until an update happens and the device online status updates to No.
  • Now I set High from CMS mobile app, homey device is updated, however target temperature in homey becomes 40 while in mobile app it is 35. Change target in mobile app to 37 and now device in homey says also 37.

When range is set to High from CMS App:

  • range is updated correctly in Homey
  • device online status stays Yes
  • target temperature gets set to 40, but in CMS App it is 38.5, unless before update the target in CMS is first changed.
  • change target to 38 in CMS App, then device in homey updates to 38 also.

Some level of issues maybe in the target temperature handling.

These could be handled with logic cards.
All IF cards have tokens which can be hard

These I’ll add

The other part i have to look at.
But from what I Saw is that the API is quite buggy when you send commands.
Theres a wait for result method maybe that would help here.
I’ll check that

1 Like

Yeah, just realized this my self also, silly of me.

1 Like

New app update (live: 1.4.8):

  • NEW: add multiple pumps and blowers
  • NEW: add manual update button (flowcard)
  • FIX: desiredTemperature when heater mode changes
  • NEW: add temperature range
  • NEW: add sensor values to sensor tab
  • NEW: add setting to round the temperature values without decimals
  • FIX: flowcard listener missing + language changes
  • FIX: add/remove pumps & blowers dynamically
  • FIX: translation + LOW/HIGH setting
  • FIX: setting pump and blower HIGH/OFF
  • FIX: light button state
  • FIX: auth token refresh when failing
1 Like

Hi Martijn,

My vendor switched my spa for a brand new one. The old one had balboa inside but all new spa’s from this vendor (Fonteyn) will use Joyonway control boxes from now on. Do you think that this brand/ type will also be available in the controlmyspa app anytime? The type i have is the BP555 and all products looks a lot like balboa but that is just the fysical part.

The wifi module is on its way after a 8 months delay so i can use it with there app shortly.

Thanks for your time/ response.

Hey @Robbie_van_moerkerk
It only would work if the system is the same as Balboa and users the ControlmySpa app.

But as far as I can see this is not the case and it uses a different app+protocol.

Once you have it we can check :wink:

New app update (test: 1.5.0):

1. NEW: add condition flowcards

Online status is (true|false) .
Heater is in (ready|rest) mode.
Pump (1|2|3) is (on|off) .
Blower (1|2|3) is (on|off) .
Light is (on|off) .

@OH2TH Sorry that it took some time for this update. Had some holidays and some breaking stuff on other apps.
Added the flowcards. Will look into your findings tomorrow and also check for the measure_energy request

You can install the testversion by clicking above link and hit install

1 Like

Installed this version and will test it this weekend.

1 Like

New app update (test: 1.5.1):

1. NEW: add condition flowcards
2. FIX: temperature ranges

@OH2TH was quite some search but managed to change the temperature ranges.

The measure_energy is unfortunately not possible as the API is not reporting any energy values.

1 Like

Hello. Is the CMS servers Down ? I cant add the plug-in ….

Hey @Michael_Bernhard
Not that I see.
Just tried to add a spa and it worked.

Edit: does the mobile iOS / android app work?

Seems like the issue is in your spa which doesn’t have a connection to the internet

But I cant load the app in Homey either

That would make sense as your SPA is not available.