[APP][Pro&Cloud] Shelly

Never heard of that. If you post a screenshot here I can ask Allterco Robotics (the company behind Shelly).

I had the same issue than @Homeuse described with 3.16.1. Tried to explain that in the earlier post. I also made a complete restart “power down → power up from the mains” and the issue persisted.

"I have two Shelly 3EM devices. The other one is installed with “depregated” driver and other is never. They update the values for couple of seconds after app restarts and after that the actual Shelly 3EM device in the electrical cabinet is stuck in a boot loop and loses connection.

After the Homey Shelly app crashes the actual Shelly device in the electriacl cabinet get’s out of the bootloop and the measurements work in the shelly android app."

I will try a factory reset. maybe that works

Let me know.

I just published version 3.17.0 to the test channel. I’m looking for some people that can verify that the previous issues with the app crashing do not occur on this version. If there are issues you can easily go back to the public version without problems.


My first guess would be that this issue is related to your network configuration.

If your Shelly received it’s IP configuration from DHCP, check if it properly shares a gateway address. In case you configured a static IP address, make sure that you provide the gateway address as well.

@Phuturist I could not access the web gui as the faulty version was active, also not as it crashed i had to remove power and switch on again but had to make sure, that the app was disabled.

I get little bit confused now with the version

for me
3.16.0 worked
3.16.1 crashed
3.16.2 crashed
3.16.3 crashed
3.16.4 crashed
3.16.5 worked
3.17.0 seems to be ok

1 Like

3.17.0 working ok for couple of minutes.

And thank you @Phuturist for the superfast fix!

1 Like

Thank you for helping me. Just diabled “Static IP” , conected to the cloud, rebooted and installed the new Firmware! Finally no Problems with the Reconnection of my Devices to Homey.
All my other Devices had the Static IP disabled. Only God know why these two had it enabled…
Thank you a lot @elborro !!!

1 Like

@Phuturist …17 works, thanks.

1 Like

3.17 works stable

3.17.0 is working fine.


Currently having troubles with 3.17.0 with all Shelly I4’s. The Dimmer 2 module work fine. Restart of the app or the Homey had no effect.

With Kind Regards,

Define troubles, what is the error under the device. Nothing has changed regarding functionality so I’m guessing it’s a networking issue but I need more info.

Flows with the Shelly I4’s don’t work. I have flows with action trigger cards that turn on Philips hue lights and the don’t turn on. The input shows fine in the Shelly webinterface.

Try re-pairing, that should fix it.

I missed your message, just tried It with one I4, but sadly it doesn’t work. Even built a new flow to test, but still no luck.

Thank you for all your effort today!

1 Like

I’ll test it some time this week, is this on Homey Pro or Cloud?

@Phuturist, busy day for you. Awesome support, keep it up👍

1 Like