[APP][Pro&Cloud] Shelly

Homey Pro early 2019

3.17.0 works fine

only one questen got this message at one of the shelly’s
“Dit type apparaat wordt wellicht niet meer ondersteund in de toekomst.”

This was communicated a while back. Drivers have been replaced by a generic driver and all previous device specific drivers are deprecated. The devices will continue to keep functioning but it’s better to re-pair them at some point, just to be sure you don’t miss out on possible new functionality.

Hmm repair them.
How repair it?
I have the latest firmware

Hello

Did some more testing, repaired again but no luck. Then I tried updating the Shelly I4 (was on firmware 0.10.3 now 0.12.0) and one Shelly I4 is working after repairing (this one uses normal flow). Tried the same with another which is using advanced flows and this one doesn’t work. Hope this helps?

With Kind Regards,
Daan

Delete the device from Homey. Re-add it with the new driver and fix your flows afterwards.

1 Like

Well, it isn’t an app problem then so most likely not something I can fix. Check for advanced flow or test that device with a normal flow (and make sure the device is set as button and not as switch because action events don’t work on switch configured i4 devices).

I just tested it with a new normal flow and this works. So it has something to do with advanced flow. I’m gonna check If I can find a solution. Will let you know if I find any.

Edit,
In another room it doesn’t work, the advanced flow is still active maybe it has something to do with that. I’ll try again tomorrow.

Hello,

Is anyone having troubles with action cards in combination with advanced flows since the latest update. Still haven’t got it working yet.

With Kind Regards,
Daan

I have the problem that the Shelly Plus i4 does not work anymore. Any action in is no recognized in the App - worked before.
How can I go back to a previous version?

You are suggesting this will fix your issue, probably because you are assuming it’s a bug. I just tested this functionality recently myself and it works fine so it’s more likely to be something in your configuration. There is another user that is having issues with the advanced flow editor and action events from the i4. If you are using this as well try the basic editor. If that works it’s something to further investigate (maybe even by Athom).

Hi, @Phuturist

just playing around with colours in the house and noticed that the rgbw bulb dont have the effect card available . they seem to be only on the led dimmer

it would also be awesome if there was a card to go from 1 colour to another wihin a set time

Will fix that in the next release.

You can set the default transition to the max of 5 seconds. Create a flow that sets a random color color and trigger this flow every 30 seconds or something. No need for an extra card. You are limited to the max transition time of the light though which is 5 seconds.

I am only using the basic editor - actually I didn’t change anything. It just happened after the App automatically got updated about 2 weeks ago.

Some Shelly I4 stopped working with standard flows today. Tried restarting the app but this doesn’t work. I have updated my Shelly I4’s to the latest firmware and readded them. This fixed some of the issus but not all of them. Would a diagnostic report help?

I cannot add my new Shelly H&T (Humidity & Temperature) WiFi Sensor.
On both the Android app and the web (homey.app) I get a black screen with “Selecteer Icoon” after selecting “Gebruik standaard”

You can try and send me a report but I doubt it would be useful. Just give it a go.

Read the pairing instructions in the first post and follow them to the letter.


I’ve updated the new device (and other Shelly devices).
It finds the new device fine. But after selecting “Gebruik standaard” or even picking my own SVG-file, I cannot get past the next screen. It is blank with “Selecteer icoon”

Hello phuturist,

Yesterday evening I restarted my router around 22:30. It could be that there are some connection issues around that time.
Thanks for your work and looking in to this.

ba82121d-515f-4fc0-b794-895bdbab07cf

{Edit} I accidentally send it as a reply to someone else

What firmware is your Shelly Plus HT on?