[APP][Pro&Cloud] Shelly

There is nothing useful in the log. Since it works at some point my guess is you are have networking issues.

Please also let me know if you pushed the button behind the back cover and the device is in SET modus (awake for three minutes).

Okay, thanks for looking in to it. I only find it strange because everything worked perfect for months, then since the last updates, 16,0-16,5 I believe, I have problems. On the other hand If very few people have issues it is more likely to be my setup. Or very few people are using the I4?

If I find anything I will let you know!

Thanks! That worked! I got the same blank screen. But after closing the window the device was added anyway.

You do know that this means that you didn’t follow the instructions to the letter right. This information is already in there. :smirk:

If the pairing wizard didn’t end normally you should make sure it connected correctly. Wake it up again use the Web UI to check if the outbound websocket options are enable and it contains the IP of your Homey. If it doesn’t you need to re-add or you won’t get status updates.

Just some obvious questions / checks to follow to get you on your way

  1. Are all devices on firmware 0.12
  2. If you paired the device before upgrading to firmware 0.12 you need to re-add the device.
  3. If you did both and it’s not working, did you follow step from from the troubleshooting guide?


Light connected to Shelly 1 Plus. It has a physical switch connected to the shelly as well. It is set to detached mode as i want it the light to go off 1 minute after they press the switch.

I created a flow that trigger on inlut switch 1 being turned off, but it doesn’t trigger.

Any suggestions?


Yes, dont post the same question twice and use the Shelly support topic on the forum to get an answer.

But to give you a suggestion right here. Inputs dont change in detached mode. This is rather obvious as the actual input has been detached from this switch by this setting. You probably want to use the turned off trigger card and not the input turned off trigger card. Or if your physical switch is a momentary switch you can use the action event trigger card available under the app and do cool stuff based on single, double or long press events.

I just tried setting the if to ‘input 1 has changed’ and that triggered (in the and i check the actual state). Weird behavior, but it’ll do for now!

Can’t delete the topic. I’ll post it in the shelly topic next time. Thanks for answering!

Nevermind, false alert. The relay was not set to detached.

So question remains: how can i trigger a flow when the switch attached to shelly goes to ON or OFF? Without doing anything with the bulb hooked up to the shelly 1 plus.

According to the docs, detached mode should do it (and it does indeed), but i can’t seem to trigger a flow when somebody toggles the switch hooked up to the shelly.

Use case: when the switch goes to the OFF position, i want the bulb to stay on for 2 minutes and then shut off.

Did you try any of the methods that @Phuturist suggested here?

After deleting the device and adding it again it worked thanks

No difference. The flow doesn’t get triggered. I must be missing something…

I do see the input switched to ‘Yes’ when i flip the switch, but the flow isn’t triggered.

I have to apologize, I didn’t read the troubleshooting well enough. It had indeed to do with the outbound socket option. After checking this everything is working again.

Thanks again for your help!

1 Like

Can you show your flows?

Hello @Phuturist, can you please check this?
I have TRV set for under floor heating mode - meaning pushing measure_temperature via flow. It works perfectly for shelly devices,
however this change of measure temperature is not visible in homey device.
Attaching screensots:


Classic disclaimer - I have restarted shelly app. TRV has great WiFi signal (and it reacts to changes in target_temperature valuse). TRV on recent firmware. Shelly app v3.17

Seems this specific TRV has some communications problems with Homey


I know exclusion and re-inclusion will probably solve the issue, but not sure this is solution as I’d like to have ~10 TRVs and this will force me to recreate all flows every time device get to this state…

The flow is:
Input 1 ON - Send push

I tried changing the IF to ‘Input 1 has changed’

And lastly by setting it through the actions

None of them trigger the ‘Then’ part. While the status of Input 1 does update correctly on the device page in homey.