[APP][Pro] Chronograph - Adds precise timer, stopwatch and transition functionality to Homey

Most likely is that the transition value is not in the proper range for dimming. The UI speaks of percentages but the actual value is 0 to 1 and not 0 to 100.

Thanks for that, it’s working perfectly now!

1 Like

I’m having issues with creating a new timer. What am I doing wrong?

Looks like you are creating a device. You can create devices for timers, but this is not the way that you “create” a timer. You can just invent a timer name in a flow and the timer will be there. No need to create one in advance.

Once you used a timer in a flow you can create a device for it if you please, but not before. But it is usually not needed to create such a device.

I think I’ve found a bug, but I’m not sure!
If I “hook” a timer or stopwatch to a tag (I planned to do this to have a overview of all timers/stopwatches, even if they are not running), the function “has reached a duration” will not work.
In this example I use a stopwatch, but it’s the same for both timers and stopwatches.

Hi all,

is there any chance that this, obviously very useful, app will be made available for the Homey Bridge (cloud) as well? Thanks in advance!

In the meantime, there’s a few timer-ish possibilities on the Cloud version.
You can start flows, or start / stop devices with a delay.

If a sensor’s alarm gets inactive again, the zone it sits in, gets inactive too.
You can trigger a flow with a delay on that event

1 Like

My app stops several times a day. To get it working I need to restart it. I am wondering if this is a problem than can be fixed or if inners to download a another timer app

Thanks. I created this flow to know if our dry-cleaner has finished it’s program. Am I thinking right?


No, if the plug has a powermetering function, you could do what the screenshot shows, but instead use logics card “power is lower than 1 (Watt)”.

link to source

But we’re very offtopic now :upside_down_face:

1 Like

Thanks. I used that, but the power consumption of my dryer or washingmachine changes quite a lot when in use. I therefore get loads of “false” alerts that the machines are finished, when they’re not. That’s why I needed a timer option, to make sure that I only get an alert when the machines use less power than 2 watts for a certain amount of time.

That doesn’t seem to be possible at the moment with the Cloud Homey.

Are You sure, the less than 2W is the exact switched off zone? :wink: There may-be little bit different idle power consumption.

But, what’s about false alerts - i currently use for washing machine the schema, where there is an additional variable - “running” plus two flows(triggers). One, setting the “running” to “yes”, when power consumption raises above something very big and another one, if consumption goes below the 2W and the “running” is set to “yes”.

To stay in Cronograph toppic - actually, i think, the Cronograph’s timer is also usable as the “running” switch. When first time a peak consumption, then set it to last of longest cycle, when below the “2W”, then to … hmm, how long there is a wait in low consumption?.. and if the timer goes to zero, then the cycle is over. Yeah, one additional flow/trigger must watch, if the timer is low but power becomes back high.

I have installed the chronograph app on both of my recent Homey Pro’s. The app works well, I can start and stop the stopwatch, but I cannot write the time into a log, notificatie or time line message.
I don’t get a tag ‘looptijd’ or ‘duration’ in the tag list. What is going wrong?

Only if you trigger a flow with
IF timer/stopwatch/transition stopped

I’m having the same problem with a timer “reached a duration” trigger. But even without using a tag. (First thing i tried, I also use tags for my timer names normally)

The flow also doesn’t run when using the “test” button so i suspect the function running the trigger throws an exception or something. If i find time, I’ll try running the app in debug mode.

I did not use any tag. Only a typed name.
Only the tag NAME after finished the timer.



If you pause the timer then you get these tags.

I’m experiencing the same issue. I’m still testing it out. My older flows using this card do work, some new ones aswell, but it seems to randomly work or not.

As an addition, I got it working with a transition. It’s a workaround but it d be great if it got fixed

I have just created a couple of very simple flow where I am using a stopwatch. One flow starting a Stopwatch when a sensor is triggered by using the start or replace stopwatch card and another flow that is suppose to trigger while the stopwatch reaches a duration. Unfortunately the app crash after some time (or when using the test button) and to get the app to run again I have to deactivate the flow where the stopwatch is used.
Using a timers makes no trouble.

Anyone else who experience this issue?.
App Version 1.1.1

You mean Chronograph timers?

I’ve (had) no issues with Chronograph, but I have no flows using “And stopwatch running time is less then [[variable-value]]”

  1. Is your variable [[lgFyrSPDriftPauseTid]] a value with decimals? Maybe rounding it to 0 decimals lets the app not “choke” on it?
  2. What happens when you replace the variable [lgFyrSPDriftPauseTid]] by a number?