[APP][PRO] BeeClear P1 Energy Manager, Dutch and Belgian smart meter

I just finished a major app upgrade to version 2.0.0. It involves a complete rewrite to Homey SDK3. This increases overall stability, reduces memory usage, and ensures future compatibility with Homey once Athom disables SDK2 support. The app now only works on Homey firmware 5 or higher.

Change log:

  • Rewrite to SDK3 and Compose.
  • Ledring code updated.
  • Fixed offPeak state after app restart.
  • Fixed several 0-value bugs.
  • Http timeout depending on poll time.

If some of you want to test it, you can download from here. Please let me know if it works good for you or not. BeeClear | Homey

I just released version 2.1.0 as test:

  • Fix tariff change flow trigger.
  • Added filter unrealistic values option.

Some smart meters give erratic meter values, resulting in weird spikes in Homey insights. You now have the option to ignore unrealistic meter values from the advanced device settings.

Can someone please test this version and let us know if it works ok?

Hi All,
i have a message Socket hangup, i had it before but i remove the app in homey and reinstall it.
Today i have reset all my equipment (router, wifi, homey and the beeclear) nothing helped.

What can i do with this, reinstall it ?
when i go to the page bij ip it work .

gr Rini

  1. Homey and the beeclear must be in the same network, no firewall restrictions to each other. Is wifi reception of Homey and Beeclear good?
  2. Check if Beeclear has latest firmware
  3. Make sure beeclear has a fixed IP address in your router
  4. Remove the Homey device.
  5. Power cycle the beeclear (power off, 30seconds wait, power on)
  6. Add the device in Homey

Should be good!

v2.2.1 was just released in the app store

  • Fix flow start before capabilities update.
  • Log tarrif change.

Hi,

i have this problem several times, and have to reset the beeclear to obtain a connection. weird…

grx Rini

I suspect this might be happen when you do not have a fixed IP address for your Beeclear. If the lease ends the beeclear gets a new IP address from your router and Homey is unable to find it.

Did you set up a fixed IP for your Beeclear? If not, you can set this up in your router.

Hi,

All my IOT have a fixed ip

I suggest that you check if that IP address is setup in the advanced device settings in Homey. And you can take a look at the Homey logs (in beeclear app settings) to see if that gives any clues.

Hi,
This afternoon I moved my Homey-Pro to the IoT VLAN (where the BeeClear also lives) but for some reason the connection did not reconnect itself.

I’ve done some troubleshooting + rebooting/PTP but could not find anything, so ultimately I deleted the device and the app but at re-install I got the following error message (both with and without ip adress)

with this in the logfile:
[err] 2022-01-16 16:56:25[p1] Pair error Error: connect EHOSTUNREACH 192.168.100.26:80 at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1137:16) { errno: ‘EHOSTUNREACH’, code: ‘EHOSTUNREACH’, syscall: ‘connect’, address: ‘192.168.100.26’, port: 80 }
[log] 2022-01-16 16:56:22[p1] save button pressed in frontend

The Beeclear interface is reachable on 192.168.100.26 with no issue.

Looks like a simple connection error but since both devices live in the same VLAN and the beecear site is ping’able and reachable, I do not know what could be causing this.

Any suggestions/ideas?

UPDATE: I am one step futher… Apparently the Ubiquiti setting" “Block LAN to WLAN Multicast and Broadcast Data” prevents wifi client from different AP’s to talk to eachother. And Homey and Beeclear are both on wifi and on different AP’s… :face_with_raised_eyebrow:

Disabling this setting changed the error message of a fresh Beeclear install to:

*" err] 2022-01-16 17:51:14[p1] Pair error TypeError: Cannot read property ‘mac’ of undefined at /drivers/p1/driver.js:59:38 at processTicksAndRejections (internal/process/task_queues.js:97:5) *
[log] 2022-01-16 17:51:14[p1] save button pressed in frontend "

Again: Any suggestions/ideas? :grinning:

It seems your beeclear is not able to resolve its own ethernet information. Can you browse to your beeclear, login, and then browse to 192.168.100.26/bc_getNetwork/?type=eth and post the result here?

All I got was this: {“info”:“command not found”}

Guess this was not what you were looking for?

The MAC address of the Ethernet port is used by Homey during pairing. Cannot read property ‘mac’ of undefined means Homey is not receiving this info from the beeclear. When you browse through the beeclear.

Can you post a screenshot of the following screen in beeclear: Netwerk- LAN

It should show the MAC address.

Yes it does show the address.

Do you realy want me to share the Mac address on the forum or do you just need to know it is there?

you can blur it out. I need to know it is there…

And what firmware level are you running on the beeclear?

Settings:
Networksettings

Version:
Version

that all looks good. No clue why homey cannot pair with it. And it worked before you configured the vlan?

Yes, Homey was in my main VLAN and Beeclear was already in the IoT VLAN and that was working fine.
The only thing I did was change Homey to connect to the IoT (wifi) VLAN (tidying up my network a bit :sunglasses:).

To be honest I think it has something to do with Wifi client isolation or some other fancy network setting.

I’ll try connecting Beeclear with a good old cable. See if that makes a difference.

1 Like

No luck… :neutral_face:

Wired settings:
Netwerk wired

but same error:
*err] 2022-01-16 19:30:33[p1] Pair error TypeError: Cannot read property ‘mac’ of undefined at /drivers/p1/driver.js:59:38 at processTicksAndRejections (internal/process/task_queues.js:97:5) *
[log] 2022-01-16 19:30:33[p1] save button pressed in frontend

Need to do some more troubleshooting…

Guess this is part of a larger issue I am having.

See: Homey app stops working correctly after moving Homey to IoT VLAN

Will keep you updated here.

*** UPDATE*** : I figured it out.
I was using my dedicated read-only homey user to setup the Beeclear but apperently that doesn’t work. :flushed:

So I used the standard beeclear user to reinstall the whole app+device and later used the app to change the user back to the readonly Homey user.
@Gruijter : All running ok again! :+1:

1 Like