[APP] idinio

This app makes Homey support idinio Z-wave and Zigbee devices!

Live version (firmware 4x): Live
Test version (firmware 5x): Test

Supported devices in current version of the app:

  • Zigbee Rotary Dimmer Switch

  • Zigbee Module Dimmer Switch

  • Zigbee Cord Dimmer Switch

  • Zigbee Foot Dimmer Switch

  • Z-wave Rotary Dimmer Switch, with metering

  • Z-wave Module Dimmer Switch, with metering

  • Z-wave Cord Dimmer Switch, with metering

  • Z-wave Foot Dimmer Switch, with metering

4 Likes

@johan_bendz i have bough Zigbee Rotary Dimmer Switches, but the app can’t find the dimmers.
If i use an app from an other brand, the they will connect, but as unknown device.

Is there a solution, or is it that i’m missing somthing?

Hi @Rens, can you please post what data you get from the device when it is added as a generic device?
(device settings on the device)
When trying to add the device using the idino app, are you asked to enter a code?

Hi Johan,
When connecting no question for a password.
It just keep searching when using the Idinio app.
This is info of the device when added as an universal device:

Thanks, I found what the issue is and will fix it asap.

1 Like

Thanks for the support!!

Hi @johan_bendz, I have two Z-wave Foot dimmers. On both I regularly experience the connection between Homey and the dimmers are lost. Could it be app related as it happens to both devices?

An observation from when I added the devices, a code is requested. I haven’t found a code on the device or box. So I just entered all zero’s. The device is added and works for some time.

After a while (hours or 2-3 days max), the device doesn’t respond to Homey and returns a timeout. A PtP on the Idinio’s makes them responding again (for a while).

What I’ve tried so far (without luck):

  • moved the devices further and closer to Homey
  • re-included the devices
  • a PtP on Homey

I haven’t found a pattern yet.
I do see the received and transmit data is very large compared to other Z-wave devices I have. Also the Tx-errors is 31% for the one that is reachable. One device I reset last night, is now again unreachable and is showing 86% Tx errors.

  • Node 48 was removed and re-included last night
  • I would expect the nodes to have a direct route as both are in line-of-sight and approximately 2-3m from Homey

Is this something that could be app related? Is it something you could help troubleshout?
In parallel I’m sending an email to Idinio. It still may be hardware.

Hi @molensky, thanks for the information. I was not aware of this issue, will have a look at it.
Can you please send a crash report from the app after restarting Homey or the app and then using the units a few times.

1 Like

Hi again @molensky.
From what I can see in the log it’s not an app issue, rather an communication issue.

i can’t see why this happens, it could be that the devices have lost “connection” to Homey (did Homey receive an firmware update?). If so you might need to pair the device again.

I’m sorry for the trouble but if you are able to re-pair one unit we would get a better understanding of the problem.

Hello @johan_bendz, Is there any change the app will be available for the normal Homey too? I have a few Idinio Z-Wave dimmers I would like to use.

Hi there. Support for Homey using the Bridge to connect to idinio devices is under development. Can’t promise a release date but I’m working on it :slight_smile:

Cool! Is the bridge the same as the Homey 2019 ? If you need any help with testing the app I would be happy to do that :slight_smile:

No, the Bridge is a new device with limited functionality compared to Homey 20xx/Homey Pro.

Thanks for the interest in testing, I will make some nice when I have a test version available. :slight_smile:

Hi Johan,

When you change the 0 by ‘Setting the delay time when load is turned off’ then you can’t get it back to 0. The minimum input is 1 but the real minimum input is 0. And I hate the delay.

You can get it back with raw inputs but it won’t change in de app. Only with a hard reset it’s back to 0.

Do you get it? :wink:

I’m using the idinio z-wave modules. See image.

Thanks!