[APP][CommunityStore] App Version Checker 4.0.1

Thanks. I was able to updat the app.

1 Like

Hi @Adrian_Rockall, I’ve installed v3.0.5 recently and it works now.

Thx for you’re support! :+1:t3:

1 Like

While installing the new HCS Store app (which works great so far!), I noticed that the App Version Updater crashed on my HP23 (which I previously installed by CLI).
After installing it once again bij the HCS installer (:+1:t2::wink:) it works again.
Perhaps a simple glitch, but thought It might be good to mention to you, @Adrian_Rockall

It would be missing the env.json file if installed via the CLI so wouldn’t have had the tokens to required to access the HCS API.

Ok, I was just able to use the app after CLI install before. Isn’t that strange then?
Anyway, we’ll see how it works from now, now that I have installed it by the HCS installer.
Tbanks for the quick reply!

Hi @Adrian_Rockall, after updating the Homey beta app to v7.0.0.1175 (iOS/iPadOS version) and Homey firmware v10.0.0-rc.62, on my iPad and the iPhone the “App Settings” entry is missing:

View on Homey Pro 2019 (firmware version 8.1.3) and beta iOS smartphone app (version

View on Homey Pro 2023 (firmware version 10.0.0-rc.62) and beta iOS smartphone app (version

I will it also report to Athom. But I don’t know which update cause the problem, sorry.

Everything written in italic and bold font has been edited.

The entry is there on my Android

and in the web app.

@DirkG’ screenshot if from the v7 beta app, yours is probably from v6.x.x?
I have the same problem. After a while the settings button seems to disappear.

By the way: most of my HCS apps seem to get problems after some time. When I try to restart the app, I get the following error:

I had the same message with the WebOS app from the community store.
The installation of the app looks good, but after a while it goes wrong.

I have fixed the App Origin issue in v3.3.1 of the HCS app.
After installing the new version, you will need to install the HCS installed apps again.

1 Like

This is how the “Start screen” looks on an iPhone:

To get into the app settings, you have to tap the gear. This is followed by the screen posted above #66 where the menu for the “App Settings” is missing in the Beta App v7.0.0.1175 (iOS/iPadOS version).
But I made a mistake, on both, the iPhone and the iPad, the menu for the “App Settings” is missing.

Btw, this is how the “Start screen” looks in the web app:

The menu for the “App Settings” is also missing.


This is how it looks in the web app of the HP 2019:

So I guess it’s HP23 (firmware) related.

Great, thx @Adrian_Rockall!

I just don’t get this version installed. Not by clicking the “update to version” button on

And not by running the (newly downloaded) installer once again.
It stays on v3.3.0.

After that I uninstalled HCS from my Homey and did a new install by running the installer, but that did not upgrade if from v3.3.0 as well. :frowning:
Logout / Login from the Community Store and re-authorize Homey didn’t help too.

(by the way: The page above says it still handles about v 2.2.1 and the installer still has v1.0.0. Isn’t that a bit confusing too? :slight_smile: )

Ah, sorry I just fixed it in GitHub. How did you get 3.0.0?

I am not sure, anymore, sorry. I think by installer from the HCS site.
Am on v3.3.0 by the way.

Can do a CLI install as well, but where to find the correct Github? Everything I find by using Google seems older…?

Max will publish it to the store tomorrow.

1 Like

Great, thanks @Adrian_Rockall and @MaxvandeLaar!

The 3.3.2 is released, also added support for auto update for next versions. Please use the desktop installer

And thanks to you too, @DominicVonk!

Unfortunately, I keep having problems with the HCS.
I was able to install v3.3.2 bij the installer on both my HP19 and HP23, but I can not get to install or update apps after. Tried the following on Chrome on 2 different (windows) pc’s and doesn’t work on both my HP19 and HP23:

  • Updating a (any) app from the HCS site by installing it over the current app on HP19/HP23
  • Uninstalling the App Version Checker (on my HP23 only since that app and HP hold no devices; easier) and installing it again from the HCS site
  • Tried if logout/login from the HCS site would help, but when I press logout and refresh the page, I am still logged in. Closing the browser doesn’t log me out as well.
  • Clearing the cache for the HCS site did get me logged out. Then logged in again (pasting code, etc), but still no luck I am afraid… :frowning:

Can it be that there is something wrong with the HCS app?

Still using this app for checking for updates of my apps.
Nowadays just checking with the Homey App Store of course.

Unfortunately the app generates an error when I have the “Dashboards” app installed and this app is checked for updates:

@skogsaas did not list the app in the Homey App Store publically (yet).

Could that be the reason for this error, @Adrian_Rockall?
When I uninstall “Dashboards”, there’s no problem at all.

Any change for updating the app to check apps from the new HCS(pace) as well (and disable the old HCS(tore))?
And for listing this mega usefull app to the Homey App Store (or new HCS(pace))?
Perhaps it would be great as well if this functionality could be integrated in the new HCS(pace) app as well…

1 Like

I will get the app out of mothballs to see if I can track down the error and remove the old HCS bits.
Not sure about adding the new HCS as I’m not sure if that is planned for the HCS app.

1 Like