[APP][CommunityStore] App Version Checker 4.0.1

Hi @Adrian_Rockall,
i also updated the app to version 3.0.1 (without the step in between to v3.0.0) and for me the check doesn’t work. The “Available updates” list is not updated.
I have already:
– restarted the app
– unchecked “Notify when update available” and set it again → Save
– changed the time → Save / changed the time again → Save

Any ideas?

If you check for updates manually, do you see any progress or errors?

If I check for updates manually, I see the progress and it works, but not automatically.

Ok, so possibly the timer is not working.
I will check that.

1 Like

@Adrian_Rockall Same issue here regarding updating App Version Checker. I use v1.0.3 and would like to update to v3.0.2. In the HCS app Auto Update is on but it doesn’t update itself. Tried a manual update via ‘View’ but in the Community App Store the ‘install’ button is greyed out. Already restarted the HCS app.

Any suggestions?


I see you pushed a new update to the Community App Store, @Adrian_Rockall. Thanks again!

Just a very (very) minor flaw: the time untill the next update is not displayed correctly in some cases.

1 Like

I can confirm this bug.
However, the main problem is still that the automatic check still doesn’t work. I still have to start the check manually.

Hmm, it was working for me.

I couldn’t check the auto update functionality, yet. It is scheduled for 6.00 AM.
What I did notice, is that the excellent script of @Peter_Kawa (see here) still recognizes the app as SDKv2…?

I’m not sure why as it is definitely now setup as SDK3:

    "id": "com.community.store",
    "version": "3.0.2",
    "compatibility": ">=5.0.0",
    "sdk": 3,
    "brandColor": "#FF7D4B",
    "name": {
        "en": "App Version Checker"

Do you restart your Homey regularly?
I have just noticed the timer was not being started when the app starts.

No, I do not start Homey regularly.

This morning I started a manual check. During the check the following error message appeared and the check got stuck:

Hmm, that’s a new one. I will look this evening.

Hi @Adrian_Rockall, I updated the app to v3.0.3, but still the same problem. The automatic check doesn’t work.

If you set the update time to 5 minutes away and wait in there Configure App screen, do you see the update start then?
How are you determining the update is not working?

That worked. I had already tried this procedure with the previous versions and that had not worked. However, I had not yet tried this with v3.0.3, sorry.

Yesterday one or two of my apps were updated. I have the automatic check set to 7:30 a.m. But today I didn’t get a notification (notification is enabled), nor was the new version listed in the app.

But I will be check this for the next few days.

A bit of progress.
One thing to keep in mind is that once an app update is detected it is added to a list to prevent multiple notifications every day. The list records the app id and version, so if the version changes again you should be notified.
Not sure if that is having any affect on what you are seeing.

Ah, this explains why you are not getting the notifications. I missed one of the SDK3 changes.
The new (3.0.5) version in the HCS should fix that.

@Adrian_Rockall Hello Adrian, any suggestion?

If the install button is greyed out then the store is not able to connect to your Homey.
If you look at other apps, are those install buttons also greyed out?
Can you make sure the store is connected to your Homey account?

Also try waiting on the store home page for a few minutes as sometimes it takes a while to connect.