[APP] Aqara & Xiaomi Smart Home - A different kind of Smart Home solution (Zigbee App)

@Doekse is giving a perfectly valid reason why having this workaround available on HP2023 doesn’t automatically mean a new release is nearby. If I were the app developer, I would wait for the same changes to be implemented for the older Homey Pro’s and the Bridge before doing a release (for the simple fact that it’s not possible to push a release for a specific hardware platform).

You’re just going to have to wait.

2 Likes

Could you add support for the Aqara Light Sensor ( lumi.sen_ill.agl01)?

image

2 Likes

A couple of weeks back I bought 4 Aqara Smart Plugs (shows up as “lumi.plug.maeu01” on Product-ID). Connected two of them with no isues and energy monitoring has worked as it should with 1000W panel owens. Today I installed the remaining two, but not able to make monitoring report (stands on 0W with no update). I expected the two remaining plugs to be broken, but as a last test I resetted one of the plugs that have worked fine with reporting until now, connected it again and now this plug also wont report. All plugs has on/off functionality, just energy monitoring that wont work.
The Aqara app is version 1.7.1, Homey Pro 2023 was updated yesterday to V10.1.4
Any ideas what can cause the lack of reporting ?

Please report to Athom, so they can get / have a look on changes they introduced in the most recent firmware (I believe the cause is there). Maybe if we will be lucky, TED will comment but I doubt.

I have reported the issue to Athom - they just replied that it’s not possible that this issue is due to the recent update, and that I need to adress the Aqara-forum

I have the exact same issue, bought 2 of them (also show up as lumi.plug.maeu01) last week, neither of them has energy monitoring working, both stay put on 0w regardless what i plug in.
Also tried to connect them as Zigbee devices directly to homey without the aqara app, didn’t work either.

1 Like

@Stefan_Jakobsson @Dag_Gulbrandsrud Just by any chance, on which FW are you ? Latest v10.1.4 ?

Correct, Homey Pro (Early 2023) on 10.1.4

Same/similar problem here. I have 3 aqara smart plugs and they have been working fine for a long time on my HP19. Yesterday I upgraded to HP23 (FW 10.1.4), now they are not reporting power anymore. LMK if I can help with providing more info/experiments.

Ah yes, the standard “the app developer did it” reply. Even though the app hasn’t changed, and the firmware has… :man_shrugging:t3:

2 Likes

Yeah, I told them that but so far no reply. Maybe they changed something in the way that exactly those are impacted…

I think it’s this change…

Zigbee

  • Adds a workaround for certain Aqara devices that will only report to Aqara Zigbee controllers.
1 Like

Yes, it’s likely related to it, especially since it seems to be happening for devices that don’t even need that change.

2 Likes

I’ve forwarded this problem to the development team, thanks for flagging! :wink: :+1:

2 Likes

Yes, as stated in my post I’m on V10.1.4

  • Adds a workaround for certain Aqara devices that will only report to Aqara Zigbee controllers.

To respond to the different questions / responses on this topic.
Yes, this workaround resolves the blocking issue to have the Aqara T1 sensors reporting data; it actually works.

BUT this work around only has been released on the v10 software version that is released to HP2023 and NOT to the v10 software release for the older Homey systems.
AND Homey apps SDK only allows a numeric software dependency (e.g. “>10.1.4”) on app level to be introduced with an update, where you can’t do this on driver level.

I could release the T1 sensor update with this dependency, which means that is would only become available on the HP2023. Any future app updates, even though they would be compatible with Homey Pro (2016—2019) will then be limited to the HP2023 only.

Since I did not receive a planned release date from Athom on the Homey Pro (2016—2019), I can’t release the T1 sensor update yet, because it will block any further updates.

So I will first finalize the E1 thermostat driver (almost ready, having to resolve the automatic thermostat schedule setting) and release this one on short term.
This update is compatible with all Homey’s and would be blocked by the T1 sensor SW dependency.

I am trying to work utilizing the available options and work around…

22 Likes

13 posts were split to a new topic: Rastislav Hubočan (hubo) - Discussing Aqara App - Test Releases for T1 devices

This is off-topic and leading no-where,…

Please keep it on-topic for the Brand/App and supported devices.

Repeating questions about the missing devices are now also off-topic as the Developer has clarified the Issue and that he is waiting for Athom and only releases when the combined Quality is OK for release.

In my opinion @TedTolboom and @robertklep are right en even if it was possible it has big implications, so the Developer decides.

If you have problems with that contact Athom Support or the support of the Brand Aqara /Xiaomi.

Therefore off-topic will be split to a separate topic. here: Rastislav Hubočan (hubo) - Discussing Aqara App - Test Releases for T1 devices

2 Likes

Hi,

I just bought a new Wireless Mini Switch T1, - and unfortunately it seems that it is not supported. (visible in Homey as an Unknown on/off switch after instalaltion, but it is a push-button)

I think the Aquara ID is WB-R02D

Probably relies on the same change as the T1 sensors. Scroll a few posts back.

If you guys have time to add this here is some additional info from the sensor.
Right now it’s added as a switch with 1 relais instead of 2, altough the power is shown.

Many thanks