All zigbee devices not working after ip change


All zigbee devices not working after ip change. I use dhcp in my network, so occasionally this can happen.

As zigbee is not wifi dependant, why is this happening?

Did you already try the search? Besides that it is wise to give some more detailed information about the problem… “All zigbee devices” is not very helpful for troubleshooting.
Which brands? How many? Did you try a PtP already?

What is the relation between the “All zigbee devices not working” and “after ip change” ?

I can’t Imagine, imho it would be the same as:

  • All zigbee devices not working my Mother in law visited…
  • A IP Change occured after my Mother in law visited…

I don’t say both Facts happened,
but My Mother in Law would not be happy putting a relation between the facts without further evidence

Searched and readed a lot :+1: Can find a lot about How to assign a fixed ip address (by dhcp) but found nothing about this weird problem.

I have:
2 aqara temp and humidity sensors
1 aqara door open sensor
5 tradfri bulbs

(New user, still learning :wink:

Not necessary, but if you want you could create a reservation for the MAC address in the DHCP server.
Search in the manual of your router if you want to know how that works.

But if there was a relation between the two facts this forum would be full of topics about that…
Stating about a relation between two completely unrelated facts does not make my Mother in Law Happy. And I am afraid for her or anyone else stating she/he got the same issue within a year on this topic keeping it alive as a mystery relation between these two.

What does “not working” mean, specifically?

That was exactly what I did. I wanted to assign a fixed ip address. After that sensor states were not received anymore and lights couldn’t turned on anymore also.

I did revert the ip address to it’s original ip address and everything started working again…

Could you (Your App) still communicate with Homey?

Yep, Homey app on my smartphone was functioning but …

If I opened the door: no new value/status was read for the open-door sensor (and so my light did not turn on)
If I clicked a temp/humidity sensor: last value was > 10 hours old
If I clicked on a Tradfri tile: tile was changed from off to on but the bulb did not share any light with me :wink:
If a flow triggered a device to turn on or off: nothing happens also.

I still do want to change the IP address but magically everything started working again after I did change it back to the old (and unwanted) IP address.

Sounds to me that the battery sensors are meshing via the bulbs. Then the bulbs stop responding and the values don’t reach Homey anymore. But that’s speculation.
Can you post a screenshot from your Zigbee mesh (

Oh, btw, do you switch your bulbs off through Homey or remote or physically with a wall switch? In the latter case, they lose power and will be not responding anymore. They will also stop forwarding any signals…

Btw 2: are the bulbs connected directly to Homey or via a Tradfri hub?

One of them does. That one is located in the bathroom. The other I don’t know. It’s just 1 meter distance from the sensor to Homey, but Tradfri bulbs are around, so maybe meshing, maybe not …

The bulbs are switched on and off by Homey only.

I do not own a Tradfri bridge. I have them connected to Homey directly

That clarifies and rules out some things. But still, a screenshot might be handy for evaluation. Could still be that the problem lies with the bulbs and not with the sensors.

Just curious, Did you also test restarting. Homey after the IP change?
Or was a restart part of the IP change processes?

The exact proces I did was:

  • check in router (Asus AC68U) what current IP address of Homey is
  • add static assignment for Homey in router DHCP (based on the MAC address of Homey)
  • save router settings (which triggers a disconnect of all internet connected devices, so I waited till everything was up again)
  • Open Homey app and start a reboot
  • Wait till reboot completed
  • check in router if Homey uses new IP address (it did)
  • Opening Homey app again was not working so I closed the app completely (I think I didn’t closed it, so I guess the IP address change was not recognized yet).
  • Re-opening Homey app (worked this time!)
  • Check if devices still work (none of them did :thinking:)

And then? You waited, checked the Apps page that all apps where started?
How many apps do you have installed an how long does it usually take before all apps are started after a restart?
Where there apps crashed?
Did you try restarting the affected apps?
Is the screenshot with the IP reservation?

I rebooted Homey again. Waited 10 minutes and tested again.
I rebooted my smartphone (just to be sure) and tested again.
I restarted the Tradfri app and the aqara app and tested again
I tried to remove a bulb and a sensor but both not succesfull
I tried to reset a bulb (turned 6x very short on) but nothing happened

Then a brainwave occured and I was happy I did know the previous IP-address, so I changed the IP-address back to the situation before …

Almost everything magically started to work again :sunglasses:
One exception: the bulb I did reset. I tried to add the bulb. I got a messsage about a duplicate but after that message, this bulb was working again also!

The screenshot is from the current situation. I’ll try to change the IP-address again and will make a new screenshot

Just set a DHCP Reservation for my Production Homey,
The one with the most Zigbee devices that I use daily.

I have to admit, the (soft) Restart of Homey did not correctly pick up the new IP address and the Old IP wasn’t working either.

After a PtP and Restart Tested Z-Wave (Neo and Fibaro) Zigbee (Tradfri and Xiaomi /Aquara) and 433 (Home Easy, KAKU and Screenline) and everything works here just after the start.

Very strange it doesn’t work for you…

almost always the solution for “strange” problems is Pull The Plug for min. 10 minutes.