All my deltaco smartplugs stopped responding! (but still online)

I have several smartplugs that is wifi conneted.
[deltaco smartplug]
They are connected to some heaters in my summerhouse.
I first used the tuya smart app, but them connected them to my Homey.
They worked fine for about 2 month.
I went to my summerhouse the other week and put on the heaters. Or so I thought.
None of the plugs was on. They was online all of the time.
I tried several times to switch them on and off. The app said that the plug responded but nothing happened.

As a last resort I went into the tuya app and sure enough, they worked fine from there.
I still could not get the plugs to respond from Homey app.

It’s not uncommon that Homey has issues with network connections, at some point it seems to just give up and not work anymore until a) you restart the app for the broken devices or b) reboot Homey.


I need some help here. I have conneted my Deltaco Wifi plug to the app Tuya Smart, but I cant find in either of the Tuya Apps in Homey.

What am I doing wrong?