Aeotec Door / Window Sensor 7 Polarität drehen

Hallo zusammen

Ich stell mich gerade mal wieder doof an wie es mir scheint. Ich habe einen Aeotec Door / Window 7 gekauft. Ich habe die Absicht, den Türkontakt so zu verwenden, dass der Kontaktalarm an ist, wenn der Magnet in der Nähe ist und nicht wie im Standard, dass der Kontakt an ist, wenn der Magnet nicht in der Nähe ist.

Ich sehe, in den erweiterten Einstellungen genau diesen Parameter und wähle diesen auch aus. Ich habe den Sensor vor dem Ändern und Testweise auch nach dem Ändern des Parameters aufgeweckt. Leider ohne Effekt: Noch immer wird beim entfernen des Magnes Kontaktalarm ausgelöst, statt umgekehrt.

Kann mir jemand einen heissen Tipp was ich da falsch mache oder wie ich vorgehen könnte? Wie bringe ich diese Einstellung auf meinen Aeotec?

Vielen Dank für eure Hilfe

Meiner Meinung nach schaltet man laut dem angezeigten Text so den internen Sensor aus oder ein (für die Verwendung eines zusätzlichen externen Kontakts) und es ist nicht als Umkehrung des Zustands selbst gedacht. Laut Handbuch müssen Sie Parameter 2 anpassen.

Scheint erstmal alles korrekt gewesen zu sein, dennoch ein paar Fragen:

  • Was wurde nach dem Bestätigen der Änderung mittels :ballot_box_with_check: in dem grünen „Popup“ angezeigt?
    — Einstellungen wurden gespeichert
    — Einstellungen werden beim nächsten WakeUp-Intervall übermittelt (oder so ähnlich)
  • Hast Du die Änderung in direkter Nähe zum Homey (< 10 cm) durchgeführt?
  • Hast Du die App mal neu gestartet?

Edit
@PetervdK, laut Handbuch ist es Parameter 3 und dafür vorgesehen den Status umzukehren. Der Parameter 3 (Screenshot von @rh_rh) hat nichts mit einem zusätzlichen externen Kontakt zutun:

Laut diesem Aeotec Online-Handbuch ist es Parameter 2:

image

@fantross Ich habe deine Fragen durchgeackert:

  • Wenn ich die Einstellungen sichere, sagt das grüne Pop-up, dass die Einstellungen beim nächsten Wake-up übertragen werden. Ein direktes “Einstellungen gesichert” habe ich bislang nie erreicht.
  • Die Änderungen wurden unmittelbar neben Homey durchgeführt.
  • Ich habe sowohl die App, als auch dazwischen mal Homey neugestartet.

Ich habe auch schon den Sensor abgemeldet und wieder angemeldet, sowie resetted vor dem wiedereinbinden.

Ist auch ein simples Kontaktalarm auslösen mit dem Magneten schon aufwachen genug zum übertragen der Einstellungen? Ich habe auch schon den Deckel entfernt und den Tamper-Knopf kurz gedrückt als Alternative. Mach ich da einen Fehler?

Zur Diskussion zwischen @PetervdK und @fantross Also gemäss Beschreibungstext in der App bin ich schon am richtigen Ort am konfigurieren hätte ich mal gesagt oder? Alle anderen Parameter lesen sich jedenfalls falscher…

Können denn diese Parameter auch ohne App Maske wie ich sie im Printscreen gezeigt habe direkt konfiguriert werden? Wenn ja: wo macht man das?

Grüsschen

Habe in den Developer Tools folgende Werte gefunden:

Polarity ist auf “0” müsste aber auf “1” sein oder? Somit scheint es die Einstellung tatsächlich nicht zu übernehmen oder liege ich falsch? Hilft das weiter?

Sensorwerte

und nochmals ich: hatte vor dem Mittag den Wert zeitweise bewusst wieder auf 0 gesetzt… Habe ihn nun nochmals angepasst. jetzt steht bei polarity “1” drin. Aber es wird immer noch bei angenähertem Magnet der Kontaktalarm abgeschaltet und bei entferntem Magnet Kontaktalarm ausgelöst.

Nachdem ich nochmals nachgeschaut habe, gibt es einen Aeotec Door/Window Sensor 7 Gen 5 (ZWA008, Link von @PetervdK) und einen Aeotec Door/Window Sensor 7 Basic Gen 7 (ZWA011, Screenshot von mir → Link).

Nein

Ja, der Tamper-Knopf muss 3x gedrückt werden:

Ja

Ja, per Rohkonfiguration (Raw configuration). Macht aber keinen wirklichen Sinn, weil es nichts Anderes ist als die Änderung in den erweiterten Geräteeinstellungen vorzunehmen.

In Developer wird der Wert auch dann geändert, wenn der Sensor nicht aufgeweckt wurde. Eigentlich sollte der Wert dann beim nächsten turnusmäßigen WakeUp (falls aktiviert) auf den Sensor übertragen werden. Aber auch das geschieht nicht immer, wenn die Zeitspanne zwischen Änderung des Parameters und WakeUp des Sensors zu lange auseinander liegen. Homey schmeißt die Aktion “Übertrage geänderten Wert zum Sensor” irgendwann aus seiner Warteschleife raus und der Wert in Developer bleibt trotzdem als “geändert” stehen.
Hier mal ein paar weiterführende Infos zu dem Thema:

Bitte also den Sensor korrekt aufwecken und dann die Änderung speichern.

Edit

Hier mal ein paar Infos zu “Raw Configuration”.

1 Like

@fantross: Yes, jetzt funktionierts. Das korrekt Aufwachen hat den Erfolg gebracht. Vielen Dank für die Hilfe!