Advanced flow "alarm inschakelen" werkt half

Goededag!

Ik ben sinds een week ongeveer in het bezit van een Homey pro en ben er flink mee aan het spelen.
ik probeer nu een alarm flow te maken en loop tegen hoopjes problemen aan.

Het eerste probleem gebeurt al bij de flow van het alarm inschakelen.
dit is de flow die ik heb gemaakt:

Als ik de flow test dan werkt alles. Maarrr…

Ik wil de flow starten via een “hey google…” routine/scene die ik heb aangemaakt in google home.
als ik die uitvoer dan gebeurt het volgende:
Het Heimdall gedeelte van de flow werkt. het alarm wordt daadwerkelijk ingeschakeld.
Het onderste deel werkt dan weer helemaal niet. ik krijg niks via de sonos te horen, geen pushbericht, de camera gaat niet aan.

ik heb de lijn van start naar sonos gehad zoals op het plaatje en heb het ook geprobeert om de start van sonos te plakken achter “toezicht modus ingeschakeld”. beide werken niet.

weet iemand hoe dit kan of hoe ik dit anders kan doen?

Je zou de “wacht 2 minuten” ook direct aan de start kunnen koppelen en niet aan de sonos.
Als dat deel dan wel wordt uitgevoerd dan zal het aan de sonos app of card liggen.

Of
Trek de rode lijn vanaf de Sonos kaart (midden onder) naar de 2min delay. Mocht de Sonos kaart fout gaan, dan wordt alsnog de flow voortgezet.
Je kunt ook de foutmelding laten weergeven:

bedankt voor de tips!

ik heb het nu als volgt gedaan:

nu werkt alles behalve de sonos.
iemand enig idee waarom dit misschien niet werkt ?

Als je op de error-uitgang van het sonos kaartje (verbinding midden-onderin het kaartje) een notificatie zet dan zou je de error moeten kunnen afvangen.
Ik las de laatste tijd wel wat issues met de Sonos app, dus wellicht heeft het daar mee te maken. Misschien een keer de app herstarten?

Je kunt het eens met een url test ipv spraak (Sonos):