Adding fibero roller shutter 3 fails in homey

hi ,

I purchased two new roller shutter 3 modules from fibero, and have trouble adding them to homey

at first it just gave a time out when adding the device in the app, then i tried moving homey close to the module, then the app said “een ogenblik geduld, je apparaat wordt toegevoegd…” wait a moment your device is being added , and there it stays there for more than 10 minutes now.
also rebooted homey and check if i have the latest fibaro app. and now also the latest homey firmware 2.1.0.

i tried again with moving homey to a cm from the antenna which gives the same result.

if i look at the log in developer.athom z-wave , it says

2019-04-03T19:03:09.671Z Command[6] start: addNode
2019-04-03T19:03:09.693Z Command[6] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2019-04-03T19:03:39.749Z Command[6] status: addNode, status: ADD_NODE_STATUS_DONE
2019-04-03T19:03:39.749Z ProcessAddNode[6]: Error: timeout
2019-04-03T19:03:39.753Z Command[6] end: addNode

while the app still is “trying”

i tried the switching it with the other module but gave no different result.

the logging now says

019-04-03T19:11:19.540Z Command[8] start: getNetworkTopology
2019-04-03T19:11:19.640Z Command[8] end: getNetworkTopology
2019-04-03T19:11:19.699Z Command[9] start: getFailedNodes
2019-04-03T19:11:19.705Z Command[10] start: isFailedNode
2019-04-03T19:11:19.707Z Command[11] start: isFailedNode
2019-04-03T19:11:19.708Z Command[12] start: isFailedNode
2019-04-03T19:11:19.712Z Command[10] end: isFailedNode
2019-04-03T19:11:19.714Z Command[11] end: isFailedNode
2019-04-03T19:11:19.717Z Command[12] end: isFailedNode
2019-04-03T19:11:19.718Z Command[9] end: getFailedNodes

i also have three z wave outlets em6550 from eminent which still work. and thought maybe i have to remove them? to get this to work?

the roller shutter itself works if i try the s1 switch, it first goes down and if switch it again it goes up.

has anybody a clue how to fix this or what to try?

Looks like a bug and it’s fixed in the next version:

Homey v2.1.1-rc.1 experimental

  • [Z-Wave] Fixed a bug that did not show an error during ‘Add a device’

I had also trouble adding a Fibaro motion sensor yesterday.
The app was stuk on “Adding device”.

And if you used the experimental firmware the adding “succeeded”? because i’m now running on the stable…

I’m also on the stable version , so i don’t know.
I got the changelog from:

Maybe it’s also a bug in the Fibaro app, the app was also updated yesterday on my Homey.
After 3 times trying to add the device it worked for me.
Between the attemps i also rebooted Homey.

Ok, well I already tried five times , but still no luck. will try it again… but i’m not expecting a different result…
I also submitted a support request to Athom now, but that usually takes a while before you get a response

I use a roller shutter 3 here without any problem

Fibaro app V 2.1.31
Homey Firmware 2.1.0

good to hear it works when included, unfortunately the inclusion fails… So i have to wait for Athom to respond

So Athom suggested to do a remove node first and then try again. Bit strange to try on a brand new device but okay

That also failed .

But when I tried again when I started the inclusion mode on honey I pressed the b button three times , and when screen said adding the device I pressed the button again multiple times in rapid succession and a green pulsating light came on on the fibaro module. Tried the remove node that worked and I Tried the adding procedure a few times until the green light went of after a few seconds and it then was added!

I did that while the homey was Eithin 30 cm of the module … not sure if it is necessary , because a full power inclusion should be possible … bit of a pain in the ass to do but it finally worked!

Good to hear that it finaly works Fabien!

Just want to confirm that I also had the same problems including. Whenever I added the roller shutter 3, it never showed up as a device, so seems like it failed silently.
When i triple pressed to add the device, and then clicked the button once per second while Homey was adding the device, it finally worked, and the device was added successfully.

I have recently added a couple of Roller Shutter 2 to Homey. And I have a smiliar experience that 3 presses of the button don’t really work. I pressed three times and then a couple of times more randomly until Homey said it started to include it. Then I stopped pressing and it just went along fine.

So something seems to be a bit strange with the roller shutters (also the previous version).

Hello everyone,

I have the same issue with the roller shutter 3 and was happy to read about your solutions.
However none of them work for me…
On my phone screen „adding a device“ never appears. Just „press the button 3 times…“ then after about 20 seconds „timeout…“.

I tried with the S1 button as well as with the B button. Pressing 3 times as well as pressing once per second etc…

The device seems to be connected ok: With the S2 button the shutter opens and closes, seems to be the default config. And when I hold the B button long I also get into the LED-Color menu and can e.g. reset the device.

Homey was about 1.5 meters away from the shutter.

Fibaro app V 2.1.31
Homey Firmware 2.1.1

I believe the firmware on the RS3 is 5.0, according to Amazon, and some people reported problems with it.
But I have no Fibaro Home Center or anything to upgrade the firmware.
Is this mandatory? Then I guess I send the shutter back…

How can I access logs to see if they are communicating at all?
Do you have other ideas?

Thanks a lot and cheers,

Hi PatrickR,

You can access the zwave logs from , sign in --> (pick the right homey if you have multiple) and go to tools --> Z-Wave .

There you should probably have to toggle in the in the log tile ,the logging switch , it then logs all the zwave actions in the log.
Maybe it gives a clue of what’s going on with your pairing… I’m saying this from top of mind so maybe the actual namings/labels may differ at

About the distance, I’m not sure I ended up to pair 30 cm from homey but that seems unlikely close to be necessary . Other devices paired fine from + 3m .
Have you got /already paired other zwave devices ?

Hi Fabien,

thanks for your quick reply! It seems there is no communication at all?

2019-05-07T09:25:07.180Z Command[5] start: addNode
2019-05-07T09:25:07.223Z Command[5] status: addNode, status: ADD_NODE_STATUS_LEARN_READY
2019-05-07T09:25:37.279Z Command[5] status: addNode, status: ADD_NODE_STATUS_DONE
2019-05-07T09:25:37.280Z ProcessAddNode[2]: Error: timeout
2019-05-07T09:25:37.292Z Command[5] end: addNode
2019-05-07T09:25:42.830Z Command[6] start: addNodeAbort
2019-05-07T09:25:42.832Z Command[6] end: addNodeAbort

I can try even closer using an extension cable from the socket, but that seems weird to me…
Unfortunately I don’t own any other Z-Wave devices yet.

It looks a bit like my message logs the first (trillion) tries… but i did get the adding screen on my homey app… (and you did not?)
But i had too press really quickly on the b button (faster than once a second more like three in a second) and then a few times more until a green led on the device came on.

But i’'m really not an expert on this… maybe someone else has other options?

Wow! After reading a different thread on a similar issue

and trying different stuff mentioned there it finally worked! Unbelievable :scream:.

So roughly what I did (maybe helps others or myself for the next switch :smile:):

  • on developer page → zwave → remove any node. Klicking the B button of my RS3 several times. It felt like it didn’t do anything, but who knows.
  • Plug in Homey with an extension court so that i could hold it in my arm, next to (~15cm) the RS3, while doing the further steps:
  • In Homey App: Add device → Homey (not Fibaro) → Zwave → Install. Then 5-time quick click of B Button, further random clicks. → No device found.
  • repeat the above using Fibaro device → not found.
  • repeat again using Homey → Zwave. 5-time Click, wait, 5-time click, wait almost until timeout, 3-time click → „wait while device is adding“ (or similar). Yupiiie! :tada:
  • Perform calibration using Homey app, worked fine!

I must say those last 3 clicks almost never happened. In my head I was already retouring the RS3s to Amazon…

Really strange/random/frustrating procedure, I hope I will succeed 2 more times…

good to hear you succeeded with adding your rolling shutter!
What i do know is that you can exit the pairing mode, when it is in pairing mode (duh) and you press the b button too many times, they say 3 times somewhere in the manual when it is in pairing mode, but i’m not sure , i did sequences of three presses and i stopped when the green light came on on the module.

still a bit timing luck involved i guess… bit strange , the advertise it as easy to install.

I thought the remove node option did show some results in the log with me though.


with adding the RS3 i have no problems, works perfectly. However, I fail to calibrate. The roller shutter opens and closes. After that, however, I can’t approach any intermediate position, just open or close. What do I have to do so that I can approach intermediate positions?

Hi Enh,

So you triggered the calibration procedure ? which runs( closes and opens again)? and after that you can’t set a middle position with the dim slider?

I assume you set the correct device type setting in your rolling shutter 3?
Does your rolling shutter has end switches built in and direct motor connection? or is there a built in driver, which does it own thing on a trigger? there are several more settings in the rolling shutter 3 which can influence the behavior of your rolling shutter with a rolling shutter 3 (or 2 or 1 :slight_smile: )

Hi Fabien,

So you triggered the calibration procedure ? which runs( closes and opens again)? and after that you can’t set a middle position with the dim slider?
I assume you set the correct device type setting in your rolling shutter 3?
Does your rolling shutter has end switches built in and direct motor connection? or is there a built in driver, which does it own thing on a trigger?
direct motor connection with mechanical end stops

even to the manual inputs, the roller shutter only reacted to I1. There it was either completely open or completely closed.

I ordered a Qubino now, everything works fine. Even the inclusion works automatically as soon as the device is powered up. With the Fibaro you have to toggle 3 times fast.