Adding Aqara mini switch

Bought 3 aqara mini switches, 2 of them worked perfect to add direct to Homey Pro.
The third will not, it starts flashing the blue LED as it should after 3sec. But it should only blink 3 times, this one flashes as long as the button is held and is not detected by homey.
Returned it to the store, but same thing with next one. What to do?

Start by running the Zigbee health script and see if it offers any advice: [Community Survey] Homey v5 ZigBee Health check and statistics collection (HomeyScript)

Done :grinning:
It says I need a zigbee router:

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 5: Devices active Routing ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Please add zigBee Routers to create a mesh network

For more info read
Advice on building a stable Zigbee network – Homey Support

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 6: Zigbee Health Advices ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Well-Known-Key used (CVE-2020-28952)

For more info read

Please add more zigBee Routers to create a better mesh network

You only have 0 routers for 10 end-devices

For more info read
Advice on building a stable Zigbee network – Homey Support

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 7: Zigbee Reporting Data ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

reporting : 8,“00124b001b45bf84”,3,false,“Homey Pro (Early 2019)”,“5.0.4”,0,11,0,2,“2.6.3”,10,0,10,2,3,0,true,"#",0,0,0 , $

I will look into getting one tomorrow and see if that helps.

If adding a router doesn’t help, you may have to consider performing a Zigbee reset.

I tried removing another zigbee device, to “make room” in the Homey but that didn’t help. So I removed one more and then it worked, the Awara mini switch is now included and works fine.
Was hoping that the Homey was more capable of handling many zigbee devices, but maybe in the future?

According to Athom, Homey should be able to handle 15 devices without routers. The actual number is a bit higher, but the limit is hardware-related: the Zigbee chip that Homey uses doesn’t have enough RAM to accommodate more.

If you only have 10 devices, it doesn’t really make sense that you need to remove one before being able to add another, since you haven’t yet reached the limit.