Homey v5 - "Aqara Cube" inclusion/connection problems

Hi, i have just upgraded to Homey v 5.0.0-rc.38.
After the upgrade, i reset the zigbee network.
I could then include/connect my “aqara temp” sensor and “aqara gyro switch” without any problems.

When i wanted to add the “Aqara cube”, it seems to fail.

When i press the button short: short blink(in manual it says range test, and it should send a signal to aqara hub to say something on speaker)
When i longpress it for 15 seconds: the first 3 seconds, the blue led is lit up, and then is off for the rest of period

The manual says that if you hold the button for 5 sec, it will reset the device.

I have tried to reset the device several times, removed the battery, and restart homey, etc…

I don’t have a zigbee repeater, and also havent connected other zigbee devices than the ones mentioned here.

Any idea how i can troubleshoot the issue?

Thanks in advance.

This is something with like push the button untill the led blinks 3 times?
When u succeed (Homey will tell u it’s being added) keep pressing the button every 2 seconds for a short time.
So, press the button untill the led blinks 3 times and let go. Every 2 seconds, push the button 1 time untill ur done (Homey will tell u again) and it’s not easy!
Keep the cube near Homey while ur doing this. And 2 meters is not close, 10cm is!

I have it 20 cm away from the homey.
if you read my post, you can see that the led isn’t blinking…EVER…

When i longpress it for 15 seconds: the first 3 seconds, the blue led is lit up, and then is off for the rest of period

So, no blinking at all…

PS: This is an Aqara cube, and not the MI cube. Not sure what or if there is any difference.
I also talked with the developer of the app, and he told me that Aqara cube also should work with the app.

I did.

Keep trying untill the led blinks 3 times.

Tried for 1 minute, and the led did never blink. It was lit up the first 3 seconds, then off for the rest of the period.

Holding it longer is a reset. I don’t own one, but are you sure you are not pushing it too long? Have you tried releasing the button when it lights up after 3 secs? (and pressing it shortly every 2 secs to keep it alive).

Yup, did that like 20 times.
Doesnt do anything.
Never get it included or make it to blink.
Maybe an hardware error, i dont know.

I went and returned it for a new one.
The led light on the new one seems to act as intended, but i didnt manage to add it still.

Maybe i just have to retry and retry some times.

Tried to remove batteries and restart homey.

Problem resolved, when i just left the cube be for some hours and tried again, it worked on first try. Didn’t do anything special.

(Ps: if you upgrade to homey v5, remember to reset the zigbee network)

I’m having the same issue.
I removed it when I first installed v5 as was having ZigBee issues so wanted to try and re-add something and now can’t connect it

did you measure the voltage of the battery?

No. Battery is fine, it’s brand new and not been used

There is only one good way in telling “battery is fine” and that’s to measure it like Joka says.
Saying the battery is fine because it’s new and not been used is just an assumption!

Right. It was working before I disconnected and it’s not connecting now. It’s not the battery