[zwave] - One device, Two Nodes: How is it even possible


I added (with a LOT of pain and tries and retries) a heavy duty switch from Aeotec.

Now, it is present TWO times in my z-wave node.

How is it possible?

I tried to heal / test both of them, but i still got the two of them.
It was too painful to add the device, i really don’t want to exclude it again. Any idea why there is 2 nodes and how I can remove one and keep the other one ?

thanks in advance.

Did you try to refresh the page (F5 on a PC) ? The ID is the same, so 1 device.

I did refresh.
Close Chrome.
Clear cache and cookie.
Tried with Firefox and Chrome again.

Still got the 2 nodes with the same id…

Does it work?

Ok, I’m a bit ashamed.

No, it was not working :frowning_face:

I removed it. Include again (20 minutes of try, fail, exclusion and retry)… And surprise, it works now.

IMHO, Homey still need to enhance a bit the zwave part…
Thanks for the help :wink:

Is it the Gen5 version you have?

Bought it and mounted it. But cant add it. It seems to be added in to the Z-wave network, Ill follow the guide, press 2 times and then its stuck on adding device then failing.

The switch seems to be happy included since it stop blinking and its behavior on the LED shows its added. But no new device showing up :frowning:

How did you manage to add the device?