Zooz ZEN72 Dimmer - Set Default Value when Switch On Between Hours of Day

What I am trying to achieve is, after 9pm when I flip my zooz wall switch to turn on my closet lights, turn them on to dim level 25% because 100% is way too bright when getting ready for sleep.

I first tried a basic flow of when light switch is on between 9pm-6am dim to 25%. Didn’t work as expected because it first comes on it turns on to it’s normal 100% and then down to 25%. Actually makes sense because the dim isn’t triggered until after the light is switched on.

How do I set the default turn on value of my zooz ZEN72 switch within Homey Pro?

Documentation from Zooz website outlining parameters and values you can set, but I honestly wouldn’t know where to start doing that within a flow, advanced flow, or creating variables etc.

Any help would be much appreciated.

Double Tap and Single Tap Behavior

Parameter 12: Choose what you’d like the dimmer to do when you double-tap the upper paddle.

Values: 0 – the light will turn on to full brightness (default); 1 – the light will turn on to the custom brightness level set in parameter 18; 2 – the light will turn on to the maximum brightness level set in Parameter 11; 3 – double tap disabled.

Size: 1 byte dec

Parameter 25: Choose what you’d like the dimmer to do when you tap the upper paddle once.

Values: 0 – the light will turn on to the last brightness level (default); 1 – the light will turn on to the custom brightness level set in parameter 18; 2 – the light will turn on to the maximum brightness level set in Parameter 11; 3 – the light will turn on to full brightness.

Size: 1 byte dec

Many lights already turn on by just setting the dim level, so disable the ‘turn light on’ card to check if it works.

If that doesn’t work,

you should always turn it off like this:
-dim light X to 1%
-turn light X off after 1s

When turned on, it should always be dimmed to 1% instead of 100%

Seems a bit clumsy, but it works. Maybe you can drop Support a note if a default dimlevel can be set permanently thru device settings.

I’m not sure that would work because where would the trigger to do something come from? The trigger is me flipping the switch on, but I want it to come on yet come on to value 25%. If I removed the turn on, it would just be dim to 25%, but it would still need a trigger to do so right?

But I wouldn’t want it to always be 1% instead. Just always 1% between the hours of 9pm and 6am.

Why not give it a go, it will not break down.

And having it turned off with a 1% dim level, has nothing to do with which dimlevel you want to set it to.
It just prevents the light from dimming to 100% after it’s turned on.

Looks like I can’t do that and still have it work as it requires a WHEN. And setting dim level is not an option in WHEN.


Can you not use the wall switch as trigger?

Yes but that still brings me back to my original question, how to set it’s default dim value instead of just turning it on to 100%, or having it initially turn on to 100% and THEN down to the desired dim value.

Is there a way to set the switch parameters via raw command using power user controls?

Say, set parameter 18 of that particular zen72 device to value 25% during a specific time of day so it uses that value when flipped on every time?


I know the node id of the device, and based on the documentation should I be able to update the custom brightness level?


By using two flows triggered by the wall switch. One flow switches the lamp off in two steps: dim to 1% and then switch off. The other flow dims the lamp to 25 %.

By the way, it is not your case that the smart lamp is hardwired to the switch? Because a smart lamp shall always be connected to the mains and controlled with flows.

Ok I setup this flow but the Turned off → Dim to1% → Turn off is not turning off the light. When I test it there are no failures though…

That is strange. Maybe execute the card “turn off” with a delay?
Or just test with a testflow the turn off. If even switching off does not work, it must be a bad product :grin:

It works without the ending turn off hmmm well off to the rabbit hole

If it works, don’t wonder, it’s software😁

It’s great that on turn off dim to 1% works but I need it to turn off after that and it’s not turning off. Defeats the purpose of the flow.

Then after dimming you start another flow that contains only command “switch off”. If that does not work I am out of idea’s.

I will give this a try. I did reach out to the Zooz dev for a feature request to allow for more advanced settings control within Homey and I’m not the only one requesting it so hopefully in the future it will be less hacky. Thanks for the back and forth.