Zigbee routing and 20 devices (directly connected) hardware limit

Don’t know what type of Fibaro you are using but maybe this is possible with yours.
Manual Fibaro
Parameter 20 en 21 set to 2. If you have an on/off switch.

Just to be clear. I do use momentary switch in combination with fibaro relay. But the issue is, that smart bulb is not powered when relay is off. Thats why I was curious if there is other way how to controll smart bulb without remote with physical switch.

You’re correct, you can ignore my comment. I misunderstood the purpose of a pulse/momentary switch.

You do not have to switch off the powersupply to the bulb, but put voltage on it directly and let the bulb turn on and off again when you press the switch via Homey.
IF: bulb turned on (Fibaro relay, by Homey or switch)
Then: turn on the light

I think this will work.
If not, other users will correct me.

My rules for home automation are the following:

  • everything important should work even when the central unit is down. E.g. heating, lights, etc. Thats why I dont like remote buttons or light controlled only by Homey and do prefer devices/modules that can be controlled by physical switch and Homey as well. Smart bulb was added, just to be able to change light temperature over Homey (not a critical feature).
  • do not significatnly change the way how to control basic devices = keep original switches = WAF not impacted :slight_smile:
1 Like

Have the exact same rules :+1::ok_hand:

My own approach is to loose the manual access to my lights and instead I do everything though Homeyscript and I use KlikAanKlikUit with senders like a AWMT-003 that I connect inside my wall switches. That way I detect a off-on or on-off cycle to turn the light to the opposite state and I can use motion detectors from Aqara to turn them on independently together with which time it is and with a light meter outside estimate to what level.

if a wifi is an important component of your home then you may consider looking at the url callback option. especially if you are using Shelly, this also works without homey

@Eternity i’m probably moving back to deCONZ :slight_smile:

the load on my homey has increased so much I can’t do anything with it anymore. My homey reboots at 6.15 am. But with a load of ~15 - 20 it constantly tells me it’s offline. Motion sensors don’t respond, or very late (~30 / 45 sec delay). And there is no reason it should consume so much load at 5 am. It doesn’t do anything at that moment in time (maybe backup, but that shouldn’t take so long).

And the only thing changed is moving from deCONZ to native zigbee (and thus installing IKEA, Philips and Aqara apps).

I still have not made the transition. Have a deCONZ stick and a RPi, but am a bit hesitant to ‘step over’. Good luck!

Please do keep us posted and informed about this migration. It might inspire me to do the same!

I remember that I was beheaded for heresy when I said something similar :stuck_out_tongue:

I also add them when they’re at their final destination (pun intended), works perfectly.

1 Like

Hi,

Ik have also an issue with a lot of (aqara) zigbee devices directly connected to my Homey.
I had 18 aqara (batt.) zigbee devices paired with my Homey, wanted to add 2 more but cannot get it to pair at all.

So i removed 2 aqara devices and add 2 Osram zigbee wall sockets to Homey, both are reqonized as ‘router’ in developers.athom.com.

But still the route is at all devices 0-nodeID
I rebooted Homey, moved Homey to an other location but nothing changes the routes.

How can i get the nodes to use the plugs as router instead of Homey so i can add new zigbee devices?

Start by waiting a few days to see if the devices “move” to the router. However, my experience with Aqara devices is that they tend to stick with the router that they initially paired with, which is Homey in your case.

You could try removing the battery from a device, wait a bit (say 30 minutes), and reinsert the battery to see if that makes it pick up a different route. Otherwise, you may have to remove the device(s) from Homey and re-pair them close to the router. But also, like I said elsewhere, 2 routers on 20 devices isn’t much.

To “force” some of your devices to find new routes: PtP

Pull the plug of your Homey for 15 minutes. Then turn it on again, wait 5 minutes and see if new routes have been created.

ps. 18 end devices and just 2 routers is not a good start for a healthy mesh.
Ps2: I have the Osram plugs as well and they are not the best zigbee routers. All end devices like to connect to other brands (Tradfri, Aqara plug)

tried that allready (PTP), but thet all pair to Homey.

Even tried to add new devices near the ‘router’ but they do not pair, when i go to homey and try it again beside Homey it works.

More routers in really an option, i have no router devices left to pair, and homestly i do not need any.
I use Hue for lighting with Hue bridge, so all my lighting in Homey are Hue bulbs, the bridge is paired to Homey.

I almost nowhere use any wall plugs, then onces i use are all wifi (pure for power monitoring/consumption of the washing, dryer, aircon etc, they need to be high wattage).

Other devices are wifi, zwave… no more zigbee and no wall plugs or devices with a power cord.

I want to upgrade to Homey Pro (not for this reason), maybe the routing will be updated when my currenct Homey (2016) is migrated (using backup) to the Pro?

Unless you want a working Zigbee mesh :stuck_out_tongue:

1 Like

Bert, which FW version do you use?

I noticed, that its quite a difficult to pair battery end devices (aqara), when there is not enough routers available. In my case, router is able to connect 7 devices, then Im not able to add other aqara device, even when there is only 5 devices connected to Homey directly. As soon as I add another router (ikea bulb), Im able to add additional aqara device.

In my experience, it doesn’t solely depend on the number of devices, but also on the distance and obstacles. And I believe there is another effect in play:

Example:
I have a battery device in my kitchen, Homey is in my living room. The distance is approx. 2-3 meters, but the signal has to pass through 2 walls. In addition, it does not pass the walls straight (90 degree angle), but more like a 35 degree angle. This means the distance the signal has to pass through the wall is longer, making it more difficult. (fun fact: the same technique was used to make tanks more bulletproof without using more steel https://en.wikipedia.org/wiki/Sloped_armour).

To solve this, I added a router in the living room. If the device would choose this route, it still had to pass through 2 walls, but at an angle of 90 degrees, more of less. And it worked!

So not only add a router on every floor of your house. You should also check the route the signal has to pass through. This effect can probably also explain why a route sometimes seems irrational (the direct path would be shorter, but it may pass through walls at an angle).

1 Like

@Igy
Homey?
Last official release. 4.2.0

Aqara is 0.8.0

@Neuron44
My Homey is currently in the ‘meterkast’ at front door, the 2 routers are in the living room, each one on the other side of the room.

Currently the most aqara sensors are 1 to 2~3meters from 1 of the 2 router, the others more to Homey.
So if they woudl indeed route to the nearest and shortest way to the router then both routers would have several nodes connected, but that is not the case.
Almost all devices keep connection to the Homey which is the farrest away of all routers.

Als tried again PTP and wanted to go into recovery mode to change WIFI network, even that does not work. It goes into recovery, when i choose the network on my mobile and start the Homey app it cannot find a network the app reports. My laptop has same problem, i connect to homey recovery wifi network, go to setup.aothm.com and then i get an error that it cannot find the page…

I hope my new homey (pro) will do better when this one arrives (tommorow).