Zigbee routing and 20 devices (directly connected) hardware limit

Okay, that is how I thought it would work but according to other information I have received says that the mesh network is not clever enough to sort out this scenario. In this case, we could remove the entire discussion. :wink: But maybe it is a good reference for other people.

Thanks buddy

Can you be more specific on “other information”?

I never managed to integrate new devices when they are not next to Homey. I have arround 25 Zigbee devices and 80% are connected to homey directly.

I do not want to point anyone or any source out

You could say it, but then you would have to kill me! Regular James Bond stuff.

1 Like

My goal with buying the homey was to get rit of all other bridges / hubs. I used to have both a hue bridge and a ikea gateway. With the thirst of getting more and more devices I bought the homey to solve this issue.

deCONZ served a great purpose but now it seems the homey can do it again. Although, with migrating back the load on the homey has increased a lot. I’m not selling my conbee II stick so maybe in the future i’ll migrate back. It’s pretty easy to do so.

On top of that, my Synology, running the docker, is getting old and slow. So sometimes I had delays which i could not explain and I blame the synology.

1 Like

I’m using IKEA repeaters as my routers. Have a couple of them across the house. They are working fine and I always try and connect my Zigbee devices on the location I want them to be. Aqara devices (which i primarily use for multi sensor and door/window sensor) have a reputation of being bad on rediscovering routes. So my devices are paired through the routers and it works for me. Same goes for the hue motion sensor and the repeaters themself. All paired on the location they are going to work from and those are mostly not direct connected.

1 Like

So, you pair them far away from homey? I can try to do so with some of the aqara devices that are unresponsive for weeks now, nothing to loose there

I used to pair them close to the homey / conbee II stick, but after placing them at the final location they always became unresponsive, sometimes after a few minutes, sometimes after a few hours, but they always did.

2 Likes

For Zigbee, that’s the best way in my experience. Otherwise, like you said, you may get devices that connect to Homey directly and when moving it to its final location in the home it may have issues finding its way through other routers.

6 Likes

Try to add them to Homey without deleting them first.
Add them on the location where they will put.
Even this is at the attic (zolder) or your back yard.
You will get a duplicate device error.
When that doesn’t work, delete the device and then add it again. This may lead to fixing your flows

I never thought about this as all the apps say place them close to homey when adding. Yesterday I reconnected 2 aqara devices who were “lost” by just adding them again on their new location (far away from homey) and they just got added in a second. Old device was automatically removed and new one was added and routed right away. In the developer page they immediately showed their route, I’m impressed :slight_smile:

All the apps are wrong, then :stuck_out_tongue: Certainly for Aqara devices, it works much better to pair them at or near their final location.

2 Likes

I can confirm - I was able to pair one device (48th) not being in close distance, but then for another devices, O had to move to very close proximity of Homey to make another 3 devices successfully paired.

One question how to solve this: I have Ikea bulbs that are connected to Fibaro switch, so they are most of the time without power. However for some reason, some of the battery powered devices do route over those bulbs. When they are powered, everything is OK, however when I do turn the bulb off, device routed over this bulb is unresponsive and cant find alternative route, even when there is plenty other routers. Any hint how to solve this? Is there option not to make other zigbee devices to non stick to specific router or change router to non routing capability?

Hint. A smart bulb is desinged to be always on power.

You cant say to device a your not aloud to route with device b

Key aspect in my case is to keep original physical switch working - hate remotes. Will exclude those bulbs from Homey…
And one remark, if router is nit available, I thought that device will try to find other route. Tested and its not a case of zigbee in Homey. At least not in my case

That’s not an instant operation, it may take (quite) a while before a device finds another route.

Use a pulse switch instead. Then you don’t need a remote, while the smart light remain powered.

Can you be please more specific on pulse switch? Do you mean momentary switch? How to use it with smart bulb to be able to turn it on and of without need of remote connection? Thanx