Z-wave range of only centimeters

I have a strange issue.

When I locate my homey directly against a fibaro double relay switch, all works fine.
When I don’t (now 10cm appart), then Homey can receive commands like current usage (beNext energy switch), double relay switch being switched by hand etc, but I cannot send any signals to anything except for my greenwave powernode 6.
For some reason that thing does respond occasionally.

When located directly against the double relay switch then all works flawlessly.

A few weeks ago everything worked flawlessly when I had my Homey about 4 meters from the fibaro double relay switch, with a toilet in between. Currently I have Homey within 3 meters of all devices (relocated a few, still not placed all devices back) but as mentioned when not directly against another device I cannot reliably send any commands.

Is my homey broken and should I return it for waranty?

The strange thing is that the greenwave responds so much less bad then the rest, while in fact it is furthest away, but still within 2.5 meters. The others are no further then 1.5 meters away.

It also works well when I place homey directly next to the beNext energy switch. So other devices do not have a problem of providing a mesh network to the fibaro switch. For the energy switch, I had to place homey on one side, not the other as only from one side the zwave signals would be strong enough to reach the energy switch.

You are not the only one experiencing problems with the range of Homey’s z-wave: Is my Homey “dead-ish” or is z-wave transmission power very low?

i am experiencing the same problems from the beginning on. However only with the expensive Fibaro multisensors. The cheap neo coolcam pir never gave me any troubles and also the door/window sensors from coolcam work perfectly. The only problem items are the battery powered fibaro’s. The normal fibaro’s such as the binairi sensors works also flawless. In your case i would try a coolcam pir once . Upcoming friday they sell them even cheaper (18 euro’s) at ali.

greetz Frans

the reason why the greenwave node 6 responds so well is that because it is one big f… antenna. At least that is my experience as well. I have two of them and both are working as a hub for other devices before they connect to Homey.

What I do read in your post is:

still not placed all devices back

We know te zwave range of ‘pure’ homey is a bit low (but in fact it also depends on your situation…) and therefore relies heavily on some situations on the mesh network that zwave tries to create. If not all devices are replaced it could be that the devices can’t connect to each other and therefore can’t create a reliable mesh network.

For instance in my house I have a neo door sensor. This doorsensor works great by using one of the node 6 devices in between. But as soon as I disable the node 6 my door sensor is not connected anymore because it is just to weak. The distance is on a linear distance of around 5~6 meters with some thick walls, a dryer etc in between.

Another sensor, a motion sensor to be precice, doesn’t work at all at the same spot so I had to move it a bit closer to the node 6. So it is not only Homey that we can blame for the range issues but also the devices itself. Not every device has the same range.


I have replaced the device that was furthest away with an alternative (not z-wave).
The mesh network works okay, when Homey is directly against another zwave device and oriented in the right direction (turning the Homey so that it can connect).

And as you can read, I already wrote that as soon as Homey can properly connect to one device, then the mesh network builds and I can reliably connect to all other devices through it.

Anyways, I have contacted support, waiting for a reply.

I find it strange that it suddenly stops working after you moved Homey. But I hope support will help you out here :slight_smile:

Even turning Homey it is enough to make it stop working.

Previously Homey was in the middle between two devices, that without the Homey would be too far away from one another to benefit from a mesh network. Homey could connect to both so no problem. Now Homey lost it’s range so it is required to be positioned next to another device pointing in the right direction in order to be able to connect to it.

You can imagine that the device that required Homey to be in the middle had no chance of working anymore, so I replaced it for another device that I had already bought (Shelly 1’s as they are much much cheaper then the z-wave alternatives yet do function properly).

The two z-wave devices that currently can not be used, will find another use when Homey is fixed and gets some decent range again.

I have the same experience. As I wrote here before the thread was locked.

As a beginner in z-wave I don’t know if it it’s the standard that’s this bad, or if it’s the Homey? Should I return the Homey and try a controller from another manufacturer?

At first my Homey was functioning properly (bought it july this year), that is, I had no issues whatsoever and was very enthusiastic about Homey. Then all of a sudden Z-wave stopped working properly a few weeks back, got similar inconsistent results or no results at all.

At that point I had reset the Z-wave network only to be in a lot of trouble to re-include all devices after having to factory reset each device. After having done all that and included devices back the range was as described in this topic.

But now things got even worse, the results are now even inconsistent even while Homey is located directly against another device. Worthless indeed, the only thing I would miss Homey for are my screens, that I won’t use in the winter anyways. All other devices like MiLight and Shelly’s can have their own rules that don’t require Homey at all. So now all Z-wave is so unreliable that it’s not usable anyways.

Previously I have been working with a raspberry pi with domoticz on it, with a z-wave extension board. That has always worked flawlessly. The downside to that was that integrating other protocols would be more of a challenge. Since I wanted a solution that just worked I bought Homey as it would be able to work with everything I could imagine.

Sadly it turns out that the range on about everything on Homey can turn really bad, I’ve read so many topics here about poor range that you’d start crying about it.

My previous raspberry is lost, that is, my kinds went running around with it and I don’t have a clue where it is now, if I did, I would have already found a solution to get it to operate the screen as well. The biggest challenge would be to get my Google Home to talk to it, requiring me to open ports, set up a service to receive messages from api.ai where I’d have to include my own app (that last is sounds complicated but is similar to creating a flow in Homey). It might just mean less trouble then I currently have with Homey, especially since the only reliable connection with Google Home is currently through ifttt and that does not support the Dutch language.

1 Like

i experience a similair issue.
i use the binairy sensor of fibaro.
i need reset the sensor to get connection again with homey.

before all was ok.

any solution?

Thanks Danny

I have a small house with walls of a material that seem to absorb radio waves in high frequencies as used by Z-wave, Zigbee and Wifi.
My Z-wave battery devices cannot reach very far either.
I have had to put Wifi access points in 3 places in the house to get satisfying coverage.
And I had to do the same for my Z-wave network of windows sensors. The battery sensors do not really act like mesh network repeaters. They cannot because that would drain the battery.
You need to have Z-wave devices that are mains powered and has the mesh network software that actually works.
I have place 3 Aeotec Range Extenders in my house - the ZW117 type and make the whole difference.
They are not cheap but they seem to be very reliable.

It takes days before the mesh network rebuilds itself. It may be a good idea to put up the range extenders first and have them connect to the Homey. And then maybe just remove the battery from the battery sensors. It should not be needed to remove them from being paired with the Homey. That is a pain in the butt. The mesh network should rebuild itself - especially if you remove the batteries a minute or so AFTER you have installed the range extenders.

Alarm sireens running Z-wave are usually also connected to mains (with a rechargeable backup battery) and they also act as mesh repeaters. They can be a good solution if you place them strategically.

The idea is to place the range extenders sort of half way between the far ends of your house so that the sensors can reach the extender and the extender can reach the homey

1 Like

Besides of my z-wave switches I have several Zigbee lamps from IKEA. In contrast to the z-wave switches the Zigbee lamps worked perfectly instantly. I even have them working one floor up from the Homey. My only conclusion is that something must be wrong with z-wave, either the hardware (Homey or switches from Telldus) is bad or the code needs fixing.

I also experience bad reception for my NEO Coolcam Z-wave plugs.
In the same living room, about 6 meters away from the Homey, I have a plug which isn’t always repsonding to a on/off-command. I have to keep an extra plug between the two at 3 meters, for the command to always arrive…:roll_eyes:
In that case I could have just stayed with the cheap 433 MHz stuff.

Z-wave seems seriously broken in the last few firmware releases.

With Homey Firmware 1.5.3 it all worked okay.
Then I went to 1.5.12 and my Eurotronic Spirit thermostats do not react on commands more than half of the time. Now on 1.5.13 and this does not improve things.

Also it seems not just the range. I have one other wired device which routers the traffic for 3 of the thermostats and is really close to one of them. Also setting them all together almost never works (Ok Homey set the temperature to 20 degrees), but individual updates to the thermostats by using the app mostly do succeed. Also I did not experience these problems with 1.5.3 and also read in this thread others having the same problems “all of a sudden”. My guess is after an automatic firmware update.

@Athom Aftter 2.0.0 is released, please look into the z-wave issues as soon as possible.

And NO this is not an app issue, please do not blame @caseda for this.

Now Homey 2.0 is there… Could this get some priority please?

I have also problems with the Z-Wave range!
I have also tried to heal those devices but it keeps the same route and 4 devices are still unreachable and do not work :frowning:

I also use homee and an Raspberry Pi with Razberry Z-Wave-Modul -> If I include the same Z-Wave devices at the same position both (homee and Raspi -> same position like homey) work without any problems.

Has anyone an idea to expand the z-wave range without installation of external antennas?

For those interested, since the update to the greenwave powernode no longer being polled I stopped having issues. Since that day all my zwave devices have been working flawlessly.

Can you tell us more about this greenwave powernode? Or point us in te right direction, @Some1?
Since I seem to have the same problems with my Heiman Z-wave smokedetectors, I am very interested! :slight_smile:

For more information about this update:

So this polling was responsible for all of my issues. I checked every 5 seconds for power changes and used it’s output in flows. That I can now no longer do, but the result is that my zwave on all other devices is now stable.

So you mean that some other app was using all the Z-wave resources so the smoke detectors had no change of reporting to Homey?