Homey does not pick up Fibaro devices' signal

I have multiple fibaro devices, mainly the double relay and the door sensor 2. In 2017/2018 with homey 1.5 and lower they were working perfectly fine. Due to circumstances I have been away for 2 years and now back to get my home automation to the next level. I have updated Homey to the newest firmware and all devices were still there. However now when a fibaro device is switched, Homey does not respond.

As i did not know this, and because after 2 years the battery of the door sensor was empty, i replaced the battery, removed the device and added it again. After (trying many times) it was added. I could upload the new settings to the door sensor: I switched off the LED in 2017, but now i wanted to know if it works and switched on the LED again. This works from the settings of the door sensor within the Homey app. However now when I move the magnet next to the device, I see the LED switch on, but homey does not respond.

Also for the double relay, which obviously is build in the wall, when i press the light switch, the light switches on, however Homey does not see this. I can switch the light on and off from the homey app and i can use it in the way when using flows, but when i use the hardware switch, homey does not register this.

So in both cases, the device is seen by Homey and it can be controlled, but the signal that the device should send is not registered by Homey.

When i press the button of either my NodOn or my Everspring devices, i see in Homey the status changes.

Furthermore i have the MQTT hub and client installed. For Fibaro i never see any updates, however for my other z-wave devices like the NodOn or Everspring devices i see the /onoff topic change.

Are there others with this problem? Can i solve this? Or is this a Fibaro-app issue?

Have you tried looking in Homey Developer to check the z-wave mesh? There are test buttons there and you can see the routing. It might be a range problem. Maybe sending and receiving are not equally strong in reception.

I own a Fibaro relay that is particularly sensitive and I had to install several powered router devices for it to work, after it successfully connected in the same spot that it wouldn’t work most times afterward.

I do not own any sensors, but smart Fibaro plugs are reporting status changes when I use the button on the plug to change on/off state, so I’m guessing the app should work as expected for your devices as well.

Another thing worth considering: as the devices are older, maybe the firmware in them is too old? I don’t know if you own a Fibaro hub that can update the firmware or know anyone who can update the devices for you? (Which will be hard for the device that is in the wall :cry:)

I have a Fibaro HomeCenter 2 and could install firmware updates.
But I don’t think that’s the problem. I haven’t updated my Fibaro Door/Window Sensors 2 in the last 2 years (I don’t think there is a newer firmware available) and they still work.

You said you have installed the latest firmware. Do you mean the latest stable firmware? Or a beta?
Did you also update the Fibaro App? Which version?
Did you try PTP (Pull The Plug) after FW update? This means to disconnect Homey from the power for at least 15 minutes.

I have checked the Homey Developer. I see all my devices and also the Fibaro build-in relays. I tried to send signals and that works fine, testing, basic on/off. Also because other brands Z-wave devices work fine, i think it has something to do with the Fibaro app on homey, but i don’t know how to check that.

I don’t know anyone who own a Fibaro home center, so updating is not possible, although it would be nice to check.

Homey version: 4.2.0
Fibaro app on homey: 2.4.6

Door sensor firmware (version.sub version.ID): 3.2.1810
The relays i have do not show a firmware version in Homey.

I did not yet try to unplug Homey completely and leave it off. I will try that tomorrow.

Edit:
I saw that the Homey Developer has a logging feature. I tried to push the hardware button and play around with the door sensor, but nothing appears in the logging. However when i switch on a relay by tapping the icon on the screen in Homey I see the following:
[2020-10-01T19:26:56.036Z] Node[15]: [COMMAND_CLASS_MULTI_CHANNEL] [MULTI_CHANNEL_CMD_ENCAP] {“type”:“Buffer”,“data”:[15,1,37,1,255]}
[2020-10-01T19:26:56.037Z] Node[15]: sendData to COMMAND_CLASS_MULTI_CHANNEL, params 0x0d0f012501ff
[2020-10-01T19:26:56.039Z] Node[15]: [COMMAND_CLASS_SECURITY] [SECURITY_NONCE_GET] {“type”:“Buffer”,“data”:}
[2020-10-01T19:26:56.040Z] Node[15]: sendData to COMMAND_CLASS_SECURITY, params 0x40
[2020-10-01T19:26:56.042Z] Command[9671] start: sendData

(and more)

However, when i press the hardware button on my Everspring ‘wall plug’ I actually see things happening in the logging:
[2020-10-01T19:27:55.885Z] Node[8]: Received application command for COMMAND_CLASS_SWITCH_BINARY, data: 0x0300
[2020-10-01T19:27:55.885Z] Node[8]: [COMMAND_CLASS_SWITCH_BINARY] {“Value (Raw)”:{“type”:“Buffer”,“data”:[0]},“Value”:“off/disable”}

(3 times in a row)

I will still try to switch off Homey for 15 minutes tomorrow, however maybe someone has a link to documentation of the logging so that I can try to understand it better myself.

I have, as I wrote, but it is not necessary because I have the same firmware 3.2.1810 and they work well.

I guess this could solve the problems. So please let us know.

No, sorry. I don’t have any documentation.

Sadly this did not work. I unplugged the USB power for more than 20 minutes and after restarting everything functions the same way, still nothing happens when opening/closing the door sensor or switch the hardware switch on the relay.

If there’s more that i can try or check to figure out why fibaro’s status changes are not picked up, let me know.

Very sad… :worried:

But the devices are marked as “reachable” in Developer?
Maybe give the Z-Wave Mesh some time to reorganize itself.
Or use the “Heal” function to manually reorganize them. Battery-powered sensors must be woken up first.

These are just suggestions now and I’m not sure if it could help:

  • Is the wakeup interval activated for the sensors?
  • Try a stronger power supply for Homey (5 V / minimum 2 A)

And how many Z-wave devices u have and how far is the first non-battery powered device away from Homey?

They are not marked “unreachable”. The battery powered door sensor can be “unreachable” when i don’t open/close the sensor (it’s on my desk for now for testing purposes). The relay is reachable when i select the Test function.

No, it is not, however enabling it does not change the fact that status updates are not send immediately. (like opening the door)

I still use the same power supply as I got originally with Homey. It worked back then on Homey version 1.5, however i can try a different power supply.

I have 19 Z-wave nodes (of which 6 Fibaro, all with the same issue). 16 are grid powered, so i think that the mesh inside my house is good enough. All Z-wave nodes are on the ground floor of a simple house, sized 5 * 11 meters. The door sensor i use for testing purposes is about 1,5 meters away from the first powered node and about the same distance from Homey.

That’s right, but when the sensor wakes up, Homey sends aktiv data to the sensor (Homey -> Sensor).
If Wake-Up is not activated, only sensor values are sent to Homey (Sensor -> Homey). It is just a try.
But of course this would not explain the problem with the actors.

In some cases the power supply has caused problems suddenly. So for me this is the last chance.
Otherwise contact Athom.

For the “older devices” it is a known and reported to Athom, issue that switch status changes are not handled by Homey. They (Athom) say, they are working on it.

I started 2014/2015 with SmartHome. Because of using the Fibaro Home Center 2 I have a lot of Fibaro devices, mostly WallPlugs, Door-/Window and Motion Sensor.
With the WallPlugs I have no problems with the status.

problems are on FGS212 and FGS221, the status change is send to Homey, but not handled.

Ah okay, good to know.

Thanks. This is really helpful, as at least i know what to expect. Sad that it worked in the past and Athom is not fixing the problem.