WOOX R7060 smart garden irrigation control

I tried to add the Woox R7060 as a generic zigbee device in the Homey app (by selecting add device, homey, and than Zigbee). But Homey does not recognize the Woox R7060. Is there a special trick to it. I already put my homey in recovery mode to do a forced update. But still no luck? There a about 10 Zigbee devices (including some signal repeaters/routers) in the system.
Hope somebody can help.

You need to install the tuya test app.

1 Like

Sorry to hear, after 3 attempts it works in my end… Did you reset the Woox several times by pressing the red Button for over 5 seconds?

Thanks for all the help after trying several times -and all most given up- it finally worked with the tuya test app.

I tried to use the app. But if i select the valve it is not reconized and it will install the device as a generic device.

That is no problem… but the woox is losing connection like @Cees_Groenendijk & @Hannes85 described.

My zigbee mesh looks like this

But the strange thing is that the Hanglamp Tuin work while there is now know route.
When I add the R7060 it is also a unknown route.

Ps. Hanglamp Tuin is function as normal for more than a year.

The route shown is the last known route, not THE route… So if your device works well, don’t look at it!!

about the woox: sometimes certain zigbee brands don’t mix very well. Try to disable the IKEA and OSRAM apps and check if the woox stays online. If it does, enable one of the two apps… this way you can discover what’s not compatible with the woox.
Edit: the woox has ofcourse to be in range of Homey or a zigbee router.

1 Like

Thnx, i Will try this

1 Like

I use to woox watercomputer for a year now! I added it as generic zigbee device, and it works fine!

Except when I press the button open or close on the devices itself… it switches the valve, but there is no feedback to Homey.
What can I do to fix this?

It is supported by the Tuya Zigbee | Homey test app now. Maybe then the status keeps in sync.

Thanks for the reply! I am avoiding tuya cloud, so that’s not an option for me. I hope people have a solution when controlling it direct as a generic device

Not so fast hehe, Tuya Zigbee is using the local zigbee protocol on Homey.
Tuya Cloud app is for wifi / cloud.

Woox by the way uses Tuya technology afaik.

1 Like

Alright! Thank you. I always assumed Tuya has to be connected to the cloud (which I don’t like) but if this app uses local zigbee like all other apps makes a big difference :slight_smile:

I’m going to try this

At first Tuya was wifi only, or known for that, but they’re expanding :wink:

It works, thanks!!

1 Like

Hello community,

I just bought a Woox R7060. I find the concept very good to control the watering of the garden. Before buying several of them, I wanted to make some test with one device.
I added the R7060 as a generic Zigbee device.

My problem is that sometimes it works, sometimes it doesn’t (the majority of the time).

On your advice, I looked at the Zigbee network status on developers tools.
It seems that I have only two: Homey and the R7060. I thought the Hue bulbs would be used as relays.

Here is a plan of my house with the position of the Homey and the Woox R7060.

Do you think I need a ZigBee relay?
Any advice?
A big thank you in advance to the Community.


If Hue bulbs are paired with a Hue bridge, they’re on a separate zigbee mesh. That is the case, looking at your zigbee overview.

Homey and woox are too far apart for a stable connection and you need one or two zigbee routers in between. All mains powered zigbee devices have a router function.

Thank you very much, Peter!
I will add my hue bulbs to the same zigbee mesh and run some tests.

1 Like

You’re welcome, Christian.

I added my 2 Hue bulbs directly to the mesh network of my homey.
It seems that the Woox R7060 is picky with the Zigbee routers.
I have two Hue Bulbs between Homey and the Zoox but the signal tries to go directly from Homey to the Zoox, without using the hue bulbs as router.

What is my option? Buy a Woox gateway?

Did you removed the Woox and add it again? Then it will search for the shorter route trough the bulbs.