Use soundboard file to cast to Google Home

Well, maybe. Maybe I can whip up a small app

1 Like

Kind of like the SoundBoard App? Could it be integrated into this App?
Oh, see that this was the topic start question, a cirkel is always round.

More like simple file store ot use for such rare cases when you want homey to simply serve a resource. I guess it would also be possible to add an ability to the soundboard app to offer the stored sounds to the outer world. But that’s something to ask Athom, as they are the developers.

just looked at the implementation of this soundboard app. They are doing quite the funky stuff to store the sounds. But does not look impossible at all.

Could you make an extention to it, so that it can be loaded in Homy via CLI

not sure. I never tried to return file content through the api endpoints. It might be required to add an actual webservice or maybe not. I cannot tell, sorry.

1 Like

Well, I implemented an app which would work with chromecast. I think I will try publish it on the appstore. It will solve your problem too. But it won’t involve the soundboard though

Wow, that’ s great, is it downloadable from github?

haha, no. It is not on github sorry.
But I have tested it with my own chromecast whether it works with your usecase. Looks good.
I need to write up some docu still and hope it will get accepted by Athom. If they decline it on the appstore I might make it public on github.

1 Like

This will solve your mp3 hosting problem when released: Homey Serves

Now on the appstore:


Thanks very much, and here are the first problems, cannot log in, “acces active refused” tried with WinSCP program on W10 PC:


after a while, the app stops, on the screen(smartphone)

error: not-found


FTP Server Offline again

hmm… strange. Would it be an option for you to try with FileZilla? At least I tested it with that tool. Just to see if it is a problem in combination with WinSCP.

I just tried with WinSCP. Funny enough I can login but the directory listening command WinSCP uses to get the file list does not seem to be supported in my ftp server endpoint.

Oh dear. I understand not a single word :sweat_smile:
Encryption is not supported, it should be disabled

how? where?

Works like a charm with FileZilla, cheers!

1 Like

works fine for me @.@

This is all settings I set to connect

Thanks, I think I got it, will test later more: