Tuya Zigbee wall dimmer 'apparaat reageert niet, zorg er voor dat deze van stroom is voorzien'


Recently Johan Bendz added my Zigbee Wall Dimmers to his Tuya Zigbee app (respect for what this guy means for the community!)

It seems to work fine, however often, when i want to switch it on/off i get:

Which means as much as: device is not responding, make sure it has power.

Where a couple of minutes earlier or later i have no issue.

So functionality works however often it reacts unreliable.

  • Everthing is up to date
  • Wall dimmers are always powered (230V)
  • Wall dimmers do have blue wire (connected)
  • devic network reset, done

Issue persists: ‘apparaat reageert niet, zorg er voor dat deze van stroom is voorzien’ (device is not responding, make sure it has power)

The error message is not specific enough as those devices are always powered :man_shrugging:.

Homey Developer tools states:

Is there anything more i can try to make these Zigbee devices work?

Hey @Jackass
How’s things going?

I’d like to ask you kindly to post in the appropriate app topic, Tuya Zigbee;
Links to that forum topic and other support links are present at the bottom of the app store app page. Thx!


All my chats have been deleted from the other forum?
Haha, i don’t understand it anymore. Nevertheless…

From Homey developer tools i did a ‘restart in recovery-mode’.
Then i need to reinstall homey once again via the app.
It will indeed install the firmware once again (v10.0.2).
At the end of that process, after it has installed the new firmware, Homey is trying to start up again.
From this point on the installation was far but smooth.
The mobile app flipped (stuck at waiting ring, and the app was flickering).
So had to reinstall the mobile app.
And everytime when i needed to connect the user it asked me to connect to HOMEY-XXXXXXX which i did already in previous steps so it won’t show up in the wifi settings, which brought me back to reinstall the firmware once again (i think this happend 3 times).

Very weird.

After trying logging in several times with my existing user (which didn’t work) i tried to create a new user.
Homey correctly tells me that this user already exists (as i was my familiar e-mail adres).
So i tried once more logging in with my existing account (not the ‘create new user’) and now that works.

Hopefully the ‘reinstall firmware’ is the solution for my Zigbee issues. :crossed_fingers:

I just tried to switch them on/off, and both are switchable. However a view in the Homey developer app doesn’t look very stable as it looks the same as before:

I don’t want to start the discussion again in which forum part this dhould be, but is this app related or is this homey related? Basically my first question; what can i do more to get this fixed :grimacing:

Thanks for your endless patience!
(cc @Jan_Peeters @DickO )

Ah, that is not personal, it was because of the ‘the big topic cleanup’ (over 2000 posts made it unusable); the device requests were moved to Github and all ‘irrelevant’ posts were either moved to a new topic, or deleted, by @Jamie .
No clue what the conditions were.
I can’t find Jamie’s explanation anymore :smile:


It’s really odd indeed, the process should be pretty straight forward.

I can’t tell if it is an app issue, or a Homey zigbee issue.
But after a firmware reload, you should wait for, like, 6 to 24 hrs for zigbee mesh to get stable, before you can say if something’s wrong

This can end up in fingerpointing between Athom and the app dev @johan_bendz

I get that, I don’t know either anymore :rofl: Sorry.

1 Like


I think Jackass might be referring to his yesterday’s posts…

1 Like

+/same situation here. I have migrated some 40+ units to another platform. The remaining ones are not critical for me (or my wife). Currently, I have 5units left on my Homey zigbee. They are mostly responding to commands but not very responsive, there is a lot of lag and latency.

This said, I can see the same ghost unit showing as in your image.
Don’t know what it is, but I do know it is not a zigbee unit connected to Homey.

edit : Addresses removed

That’s weird. You really have ghost units. On my end at least i know which units are the ghost units.
On your end it seems the ghost unit(s?) are extending your network.

Waiting time with respect to the network healing; most of the time it is build up immediately (the last image i posted will not be different tommorrow).

It’s really stupide why this seems not tot be ‘fixable’. Can’t give my head a rest this way… :weary:

Studying your image; 1 must be your ghost.

Owwww I see, didn’t see that. But that’s weird man…
So, the big topic cleanup seems to be an ongoing process :woozy_face:

Also to @Jackass : I think you should inform with @DirkG or other moderators about the why?
While he doesn’t mention both of you specifically, probably someone else flagged those posts (see the screenshot), and you should get an explanation someday I expect.

I honestly don’t get it anymore (where one is supposed to post a question).

1 Like

those aren’t ghost devices, that just means it doesn’t know the used route(s) (yet). pretty known issue on the older Homey Pro’s when just starting with Zigbee, it will fix itself in time.

Don’t want to spend my time on that (anymore). I’ll stick to the topic. Thanks :+1:t2:.

1 Like

Hi Casede, so the question mark is NOT representing a device? Why are there other devices behind the question mark notes then? Seems like some sort of route.

And when the route is not know yet; how is it possible the device is switchable?

1 = homey, the number behind the question mark is the device itself as it is “the end” of the route, even if there is no route it will still be the end.

Homey is just weird at the start of showing the routes… has been that way for a looooong time, and the route isn’t very showing anyway as ZigBee is a mesh network, not just consisting of 1 possible route, probably why they removed it for Homey Pro (early 2023) as it only caused confusion and misinterpretation like is happening now.

The device itself is behind the question mark.

  • :see_no_evil: (you are correct)


But 1 actual route. To prevent message storms as messages are circling.
If you are interested, google “spanning tree”.

1 Like

Number 1 communicates to number 0.
Number 2 via an unknown node to number 0
Number 3 via an unknown node to number 0

Is this a ZigBee or Z-Wave overview?

That’s not what @Caseda is dating:
“the number behind the question mark is the device itself as it is “the end” of the route, even if there is no route it will still be the end.”


woops I meant Homey itself is 0 (too used to z-wave where Homey is Node ID 1), and if you look really close, then all device’s route are from Homey (0) to what number the device is.
0 → ? → 1, for device 1, so from Homey to device 1
0 → ? → 2, for device 2, so from Homey to device 2

1 Like