Tuya has officially joined the “Talks With Homey” program

I have the exact same req. Just submitted an issue with the requested info. Thanks y’all.

1 Like

Hey all!

Feel free to test the Tuya app by installing it from the Homey App Store: Tuya | Homey

If you find any issues, please report those on GitHub: GitHub - athombv/com.tuya: Tuya app for Homey

P.S. I’ve also added an ‘Other’ driver so you can send any Tuya code from a Flow. Hopefully this bridges the gap where some device type isn’t added to the app yet, but you’d still want to use it.

Thank you all for your patience! <3

8 Likes

Sorry Emile, but it’s impossible to login with v0.3.0 …
See Git issue 11

Workaround: CLI install v0.2.0 → logon → and then install v0.3.0


:partying_face: Can’t wait to try, but I can’t get to working examples the needed codes

Not impossible; I did not have any problem to login.

Classic, install app, restart app then it works.

Great stuff! Really happy with this!

Is Github also the place to add feedback like: “I am able to control the Action Battletron light in Homey now, but there is no brightness slider and as soon as I do something with the light, the brightness goes to 0%”?

Most likely, Rudi. Seems to be a bug.

1 Like

Roller blinds motort would be fine to support
Have 4 of them

Like this one
https://a.aliexpress.com/_EIUtQiR

For (still) unsupported devices, and if they’re paired to the TuyaSmart / SmartLife phone app, you can install them as “Other” Tuya device

and control them with an advanced virtual device and some flows.

Example for curtains/blinds/roller shutters

Adv. virtual device:
I created one with an Off/On control for Open/Close, and a slider control for position

Device settings:

Flows

2 Likes

I have a short question If I may.
I have a Garage Door with a wireless sensor zigbee device screaming to be used, but I cannot added to the Tuya App because I need a Zigbee gateway, is there a work around to get this going with Homey Pro?

You can try the Community Tuya Zigbee App in the Homey App Store for a direct connection over Zigbee :wink:

Thanks for the reply, but I have already done that and it doesn’t work, besides of also making contribution to GitHub and also supporting the author of the app with a small contribution, I had no luck at all.

Hi everyone, is there a way to get energy data from the socket plugs. I now can only control the on/off button

1 Like

Hi Peter,

thanks for the pointers. been trying to replicate and get close, but not complete. After adding the virtual device I started on the flows and got the following warning, when trying to set the tuya device flow:


Any idea what I am doing wrong/missing?

Is the code selection list empty, Patrick? Sometimes you can ‘wake’ it by entering a whitespace followed by a backspace.

What if you enter percent_control in the [code] field, and 50 in the [value] field. Does it work?

Here you can find the codes and valid values for all kinds of devices:
https://developer.tuya.com/en/docs/iot/standarddescription?id=K9i5ql6waswzq

When you’ve opened this webpage:
  • scroll all the way down, to this part:

  • for Curtain devices, click on the topic “Small Home Appliances”
  • under “Documentation”, click on “Curtain”
    Now you should see the codes + valid values / value ranges for devices of the curtain type:

Link:
https://developer.tuya.com/en/docs/iot/f?id=K9gf46o5mtfyc

This is brilliant to see.

When will smart switches / smart buttons / scene switches / scene controllers be added to the app, please?

Is it just a case of requesting through the github page?

it is indeed empty, and entering a space gives the same error. if I paste percent_control it still gives an error…

It was quite a hassle to get GitHub, Docker, Homey CLI and Tuya up and running but it worked. So I requested one new device (LSC panel heater), indicated that dimming is missing from the Action Battletron lights and some other bulbs were change white temperature all of a sudden.

Only thing I need to figure out is how to prevent that the Tuya app is uninstalled from my Homey Pro after closing the CLI

When you don’t need the CLI error log, you’d use
homey app install
instead of
homey app run

But it’s not necessary anymore, it’s available in the store https://homey.app/a/com.tuya/test

1 Like

Yes


I guess it works different when it’s a zigbee device → zigbee gateway → Tuya wifi device
I"d suggest to create an issue for it