Trouble with pairing Z-wave devices on Athom Homey Pro 2019

I’ve been having trouble with my Z-wave devices lately. It started with my HeatIt ZTMR-3 not responding for some months (power meter not updating, trying to change setting trough app generates error etc), I tried to remove one of my HeatIt devices hoping I could add it again and have it up and going. After removing it every Z-wave product stopped working. I tried adding the Z-wave thermostat again but had problems and after reading some posts I tried changing power supply and resetting Z-wave. I’ve also tried letting the Homey be without power for 10 minutes without any luck. The only Z-wave products I’ve had success with adding is a Fibaro sensors and a Aeotec Multisensor 7. The rest of my Z-wave equipment is not working (fibaro dimmers 2, switches and a some heatit equipment). I can only manage to get to the first check mark when adding before it times out or I get an error message. Any ideas on what I can do?

I’ve tried to setup up the homey as a new one by doing factory resetting, but now I have trouble with the wifi. It seems that when it connects to my 2.4ghz network my router looses internet (I still get connection to the internet with my 5ghz connection). Any ideas why this happens?