Transmit_complete_no_ack

I try to add my third “Eurotronic Spirit Zwave Plus” Thermostat in Homey. The first two, installed a year ago, works fine, but this one is more difficult. Following the Inc instructions, Homey accepts the device, and show it. But it does not react to what comes from the Thermostat, and if I try to change anything in the app, I get the very cryptic message: “TRANSMIT_COMPLETE_NO_ACK” white text on red, for about 3 seconds. I tried to make a factory reset on the thermostat, but same result :frowning: What can I do?

No ack(nowledgement) means it didn’t respond to a command, probably connection issues. Try to add a range extender / router like a smart z-wave socket in between Homey and the Thermostat.
Also Homey seems to have a fairly short z-wave range, so better place the socket near Homey (within 3m.).
Here you can view your z-wave mesh network, might come in handy:
https://tools.developer.homey.app/tools/zwave

Also, if you DO have a router nearby, it sometimes takes Z-wave devices a while to “get aquainted” i.e. find the best route. If there’s a router/routing device nearby that’s working fine, sometimes this issue will resolve itself within one or two days (usually sooner, in my experience).

Although I have one lightbulb here that seems to periodically lose connection without clear cause, I’ve had to reset it three or four times in the last year or so. Other than that it works fine, so ehm… Yeah, some devices just seem a bit iffy.

Thank you VERY much for your reply :slight_smile: whether it gives results or not, it is nice, that someone cares about a problem. I logged on to the developer tool as you suggested, and as expected, it shows 100% loss. The amazing thing is, that when I on the Homey app on my iPhone changed the name of the device, it also changed on the developer tool. I guess, that it is because the app use wifi to connect to Homey, and as my PC (with developer tool running) is on the same network. And that means that the problem IS z-wave. And as I also tried to physically move the Homey to a place close to the device, it worked. That means, that I HAVE to buy a range extender (shame on you Homey developer), and can you possibly advice me on what kind of extender I need?

1 Like

YW!

I can’t advice you on a product, I only know any Homey compatible mains powered z-wave device, or devices which can be connected to 5V (usb), are acting like routers, and they extend your mesh.

They indeed both connect to Homey via your wifi

Thank you again for your help and support. In my home, I have two thermostats (Z-wave) in the same room as my Homey. The third thermostat, that gave me the problem, is in a room app 8-10 meters away.
So, I figured that I would have to buy an extender. But, instead of that, I moved the not-working thermostat to a room between the two others, now only 3-4 meter from one of the other thermostats, and now it work :slight_smile: :slight_smile: thanks to you. So instead of investing in an extender, I can now buy an extra thermostat, now only 5 meters away from the nearest z-wave modul.
Another question (maybe I have to put it in another line?) is a Nedis Smart PIR Motion Sensor (ZBSM10WT). When I add it to Homey, (via the Tuya Zigbee app), it connects, but says (my translation): Could not find a Homey-app for this unit. It has been added as “Unknown Zigbee-unit”. Meaning that I cannot use it for anything. I am not sure I chose the right app, as the icon is different. What do I do wrong?

1 Like

Try the Tuya zigbee test version of the app https://homey.app/a/com.tuya.zigbee/test/
It has support for many newly added devices, but (hence the name ‘test’) it’s possible not everything works 100%.

How to discover if your device is supported:
You can find the needed Manufacturer ID at ‘advanced settings’ of the device.
Then you can search for that ID at the official Tuya Zigbee app topic
There’s also info about how to request support for a not supported Tuya Zigbee device.

Hi again, and thanks again for good help :slight_smile:
I downloaded the suggested Tuya Zigbee Test version, and when I tried to connect, it said: “Experimental”
so I think it is the right one. When I tried to pair it, it showed an icon looking exactly as the device, and it also connected and the app for controlling it appeared on my iphone :slight_smile:
But, when I touched the app, it seemed to work, but after a few seconds, it just gave a message, white text on red background on top of the screen: UNSUP_GENERAL_COMMAND, and then there appeared a red triangel on the app with an exclamation point.
Next I found the "Manafacturer ID in Advanced settings (RH3040), and when I checked “Tuya Zigbee app topic” I found that it IS supported: * * TUYATEC-bd5faf9p / RH3040 (Nedis) (Test version only)
… and then, what do I do?

Hi Tommy,

Only thing you can do is add a reply to the

And explain (or copy/paste) your findings.
By the way it is exactly the same issue which is reported already in that topic:

1 Like