The sad IR - infrared misery

Dont you think if it isa easy fix, they would fixed it already :roll_eyes:

If this is gonna be another “Call each other names” topic then this topic will be closed.
Let’s be nice to each other, there is so much trouble in the world to worry about!
Off-topic posts will be deleted without further notice and that includes reactions to this post.
If u like this post just hit the little heart icon below this post. If u don’t like this post please send me, or any other moderator, a PM.


Well, that part IS working as expected for all TV’s that have their own app. Nothing lied about that.

The complaint here is about the recording function, which imho is something completely different.

But hey, just shoot me for liking Homey instead of constantly (b)(f)laming Athom…

Didnt work for me. Only one of many attempts executed on Samsung TV. But not a deal, this is not a feature I bought Homey for.

Updating with the following reply I got from Athom.

I’m happy to hear that it’s made it’s way up their priority list. If they are gather devices for testing I’d assume they even have a potential fix in place. Then again the claimed they were “working hard on it” 6 months ago so I’m not ready to call it a win just yet.

Let’s see how it plays out.

Typically IR uses Philips rc5 code, so if a device uses this coding then it be easy to intercept. If it uses proprietary code it’s a whole other story and by just copying this raw signal there is a risk that other IR signals get picked up with it. So everytime you turn on TV for example your airco would be set to -20 degrees or it messes up IR traffic on other IR data sending equipment. Hopefully you get the idea how hard it is to get it right. Simple fix? I disagree.

I solved the IR problem with an external IR sender. Broadlink rm3 mini. A little hassle to get that thing working but now I can turn on or off my IR devices in my flows.
Very annoying because I bought homey while thinking that IR would be a usefull thing… :confused:
Athom has also confirmed to me that they are working on getting homey up and running with IR again. (If it ever used to work with earlier versions) Guess we’ll see…

We are in November and still nothing solved on this ?

Of course not having a tab for energy is way more useful :smiley:

In the new beta release they moved copy IR to experimental. It is getting worse and worse. Maybe the should sell it as experimental as well.

Or to experiments?

1 Like

On this way Athom is removing ir from Homey

maybe they think that they have solved the issue and they would lik us to try it before releasing it.
Thats why they have moved it to experimental?

Or to experiments.

1 Like

Yesterday (first time for a long time) homey failed to shut down my tv and decoder. I did not updated to V3. Both are IR.

RE: Thats why they have moved it to experimental?

Maybe. I just tested it on the latest version and still the same. You go through the motions of recording the signal, and clicking on test does nothing. Saved it anyway. Also tried to record it using and it seems to capture a signal. if you copy it and paste it into the emulator, clicking emulate does nothing either. Checked the leds around the ring and six light up. Tried it 1,2,4 meters away and still does not work. But Homey is still good.

I recorded signals for my stereo way back in V1-firmware and sending those signals still works in V3-firmware. I just hope I don’t have to reset my Homey cause I’ll lose that functionality. Perhaps we can all ask Athom to support or ?

They put infrared in Experiments
[Experiments] Moved ‘Copy Infrared’ to Experiments

so the next homey (pro) will be without IR as well XD
just like they did with speech and NFC in the previous ones haha

So i gues your better of buying an logitech harmony or Broadlink.

This is only for copying IR signals, the device’s that are in their database and all IR apps are still there, even without enabling the experiments :wink:

but its about learning now.