Hi, i can´t Login in my Synology.
The Button save Settings do Nothing.

Some ideas??


Fill in all the fields. If I remember correctly, by default fields seem filled but you have to enter your own.

Hi, I tested all 4 fields with my data. Also with the admin and with a user account. It does not work

Hi, it works fine here.

Sorry for this question, but have you got Surveillance Station installed on your Synology :grinning:?

Perhaps try rebooting the NAS.

Same problem here. Homey software is up to date (beta channel) and the NAS also.

Had it working on a previous version of the Synology Surveillance Station app.
When you enter wrong data the window dissapears however if the data is correct, nothing happens.

I am using the latest Surveillance Station 8.1.5-5513.
Once I enter the correct details, the window disappears and all comes good.
It works perfect here.

I have now reset my synology and freshly installed. But it does not work.

@Tristan_Braun I would check one more thing. (beside the correct NAS IP address, password, etc… :wink:)

Into your NAS log in and under “CONTROL PANEL --> SECURITY” then the tab called “Account” open “Allow/Block List” then under tab called “Block List” check if your Homey IP address is listed. If yes, then select it and “Remove”.
If not under the “Block List” then I am out of ideas, for now…

I’m running also in to this problem, filled al the fields with valid data (checked this by logging in onto my surveillance station succesfully) but Homey doesn’t save the data.

Is there anyone who ran into this problem and was able to solve this?


Unfortunately, I have the same problem.

The SS with Homey has been working for ages. This morning I got an e-mail from my Syno that an IP was blocked; turned out to be the Homey IP!

I have changed passwords of the NAS so I thought that the problem was a new password I set.

As I have had some issues with 1 cam, I thought a fresh start would be best. I deleted all cam’s in Homey and deleted the Synology App too.
I re-installed the Homey Syno App and filled in the credentials…nothing happens…

Tried with the previous working account. Tried as ADMIN + credentials,. Made a brand new account and tried that. Nothing works.

So, seems that if it is working it keeps working. If you try with a new install, it brakes something and doesn’t work anymore.

Nothing on the block list. The ‘allowed’ IP range covers all my devices.

Setting HOME MODE via http GET still works. So, communication from Homey to the Syno works.

Could be useful for other Homey + SS users. I while back I wrote a tutorial on the old forum on how to set Home Mode via Homey. Check it out: click
Other that I wrote, it is not needed to have the SS App running on Homey

1 Like

That’s bad. Thanks for sharing your experience.

I’m having the same problem here when trying to add Synology nas to homey: I fill in all the details but nothing happens when i hit the save button

  • Homey v1.5.12
  • Synology NAS DS218+
  • Surveillance Station: 8.2.2-5766

  • Checked all settings in Surveillance station/DMS: not on blocked list, correct user with all permissions, not 2 factor authentication
  • Instead of IP address tried with DDNS: no result

I looked at you tutorial on the old forum to try to use HTTP get to activate an action rule for start recording on a camera. I don’t seem to get it working, did you ever try something like that?


No, I haven’t tried that myself. However, I presume it is the same idea, albeit with a different action. In my case I set the HOME MODE to turn on or off. In your case you want to set a camera to start recording.

I can’t experiment or try this myself; I can’t get the App on Homey to log in on my syno… :frowning:

Any new infos about this topic?

Good question, I would like to see the app get an update such that I can actually use it. Which means the ability to log into Synology from Homey…

i got it working :slight_smile:
–> Created a new user with admin rights. I’ve no idea why the normal admin account doesn’t work, but now its fine and working.

That is strange. I did the same, but that didn’t work for me.
Will try again now!

It has been working here perfectly for at least a few months already.

From the app store page:

To be able to use this app, you need to supply the app with the IP of the Synology NAS, as well as the username and password of an admin.

  1. Make sure to add a user that doesn’t require 2 factor authentication.
  2. Add the user to the ‘administrators’ group, because of the required permissions.
  3. Under ‘applications’, allow the user to access the Surveillance Station

Has everyone with problems tried this?