Switchbot - paired curtains not always functioning properly

I have installed two Switchbot Curtain-2 devices and paired/synchronized them in the Switchbot app. And added them as 1 paired device to Homey (BLE).
After synchronization, they function properly for a while. But then, all of a sudden, one of the two curtains does not open in the morning, or only opens partially. And once that happens, it does not work properly anymore and I have to re-synchronize them in the Switchbot app.

Anyone else recognizes this behavior?

Maybe this helps (unless it caused it): Firmware 7.2.1: [BLE] Minor improvements to maintaining connections with devices

Sounds like an on-the-edge-of-the-range issue. @ my place BLE devices have a range of max. 4 - 4.5 m.
Here you can view the signal strength of your BLE devices Homey Developer Tools

And keep in mind WiFi and zigbee operate in the same frequency range

Thanks for the suggestions. Range should not be an issue, Homey is within 2m of the curtains.
When looking at the dev tools, which value represents the signal strength? RSSI?

Will look into the 7.2.1 version tomorrow, looks like that could have effect.

RSSI stands for Receiver Signal Strength Indicator, alltough in the case of a robot finger I suppose it could also be Repetitive Switchbot Strain Injury. :stuck_out_tongue_winking_eye:


That can be declared as “within range” :wink:


It might help if they’d added the unit at that dev page, dBm :grin:
In the device settings, it’s shown (at the Beacon app it is)

Switchbot has the rssi information on device settings too.

And I’m using Switchbot a couple of weeks now, not recognizing your issues, fortunately.

This is in my settings:

@Martijn_Hoogenbosch do you have two curtains synchronized as one?

Nope didn’t even know that was possible :joy:

I have updated Homey to 7.2.1 now, hopefully that will do the trick. If not, I will kill the synchronization and just add them as 2 separate curtains to see if that helps.

I haven’t noticed the issue but as the curtains are out of range of my Homey I use one of my ESP32 modules to relay the signal.
Also I haven’t synchronised the two so I can control them independently. That way when the sun shines in the window I can stop it shinning in our eyes without cutting out all the light.

In the beginning I also synchronized 2 curtains as one. But every now and then I had to calibrate again. This was also happening without Homey. So it looks like a problem in Switchbot. I have heavy curtains, don’t know it that was the problem.

Since I deleted the synchronization and use them as separate curtains it works much much better.

Thanks Sjoerd, that sounds like the same issue I am experiencing.
Now you have separated them, do you let Homey open and close them at the same time? Or one after another?

The open/close command of both curtains are in the same flow. But switchbot starts the curtains one by one. So there is a delay of 0,5 second I think.

Same problem here. My curtains are not functioning anymore. I have two switchbots moving two curtains on one window.

I’ve reinstalled even the switchbot app (to check someting was wrong there) the app on homey, now I cannot connect to the bots anymore!

After I installed the latest Homey version (with a BLE fix), I did not get the issue again. But as others say they also got the issue by just using the Switchbot app, I believe it is not a Homey issue so I ungrouped the curtains yesterday and added them both separate to Homey. In the end, it does not matter as you still open and close them with 1 flow.

I had some trouble adding them again to Homey, but after a few tries Homey did detect them. I opened the curtains to make sure the bots were not too close to each other to (maybe) interfere with each others signal.

To connect them to the Switchbot app you need to press the button on the device if I remember correctly.