Somfy Valve no commands available

I have the Tahoma box and now I have purchased a Somfy Smart Valve.
I already have Velux IO windows connected to the Tahoma and they work perfect in Homey, also with the longer delay for polling the Tahoma cloud service.

In Homey I’m able to import the new valve from Tahoma and also able to see temperature and mode.
However, when trying to change the Derogation mode from Home to “sudden drop mode” I get “Failed to send Command”. It works with “Night” and “At Home”.

The main problem is actually in the the flows.
I can create a flow initiated by the Valve: Temp. becomes greater… etc. All god :slight_smile:
But, I can’t set anything under “Then”. Here I can only find my Velux Windows, but not the Valve from Tahoma. Is this by design it’s not possible to set anything? I can still click on the valve under devices and change some settings.

What I’m trying to accomplish is to close the valve when the window is open all day.
It could be either moving to manual mode when the window opens and turn down the temp or simple a “shut valve off” command, if possible.
Quite often I can have Windows/Doors open for all day when working from home and the 3 Degree Drop in the Valve will not catch this. Especially going back to “home” during the evening.

Long story short, I really would like manage the Valve from Homey, but it seems like I can only read valves state.

And Yes, I’ve tried to search the forum with no luck :slight_smile:

Any ideas?

Can you send the Device log using the More > Apps > Somfy Tahoma and Connexoon > Configure App > Device Log. First tap on Get Log and then tap on Send Log.
Also could you enable the Information log, then operate the value using the Somfy app and then send the information log.
Finally let me know the name of the valve.

Hi Adrian,

Thanks for reply. I just send the logs a requested.
Also i did send the info log, operated to: Night Mode (OK) to Manuel (Error) and back to Home (OK) and send that as well.

The Valve is called:
Somfy Thermostatic Valve io
Link: Somfy Shop UK | Somfy Thermostatic Radiator Valve - The right temperature in every room.

One thing is that I have set the Update interval to 500 Sec. due to lockouts from Somfy cloud service.

Thanks :slight_smile:

I have the logs. I will look into it this evening if I get time but I also have an outstanding request from another user on my SmartThings app that I have to look at first.

With the current Tahoma app you can set the polling interval as low as 30 seconds and that has been sanctioned by Somfy. When I took over the app I made some big changes to the way it operated by polling for events rather than a full refresh of the data and that massively reduces the network traffic on their servers.

Thanks a lot Adrian.
I know you have worked hard on the app - it’s really appreciated.

But, no rush tonight, remember there is a Homey keynote :wink:

I have had a quick look and I can see one issue which is the max and min values I have defined are different to the ones specified in the device log. that is why you can see one of the errors:
"target_temperature OutOfRangeError: 8 is smaller than 22 (out_of_range)",
Your valve is set to 8 but the limits I have are 12 to 25.

However I am not sure about the mode setting issue. I have found in the past that Somfy sometimes use different value to the ones documented, e.g. for the siren it shows partial1 and partial2 but it actually uses zone1 and zone1.

So that I can see what Somfy uses , could you enable the logging in my app, then open the Somfy app and operate the valve form their interface. My app will then sniff the commands they send along with the parameters and add them to the log. Then when you send the log I cab see what they use.

It seems strange, I’m only using the std. values - I’ve not changed it to 8 :slight_smile:
BTW I can see your app reports current temp is 21 but Tahoma says 22,2.

I’ve enabled State Log and changed from Home to night etc. in Tahoma app. Strangely enough I got an error in Tahoma when try to set it to manual mode. After some time I tried again with no issues. It seems like it fails when you try to send multiple actions to the valve within 10 minutes (Home > Night > Manual) as the valve only wakes up every 10 minutes.
Secondly, I did try to set different temps in Tahoma and on the valve (in Manual mode) to see if they were sent correctly both ways (delay was approx. 5-7 minutes). It worked fine.

The State Log in your app displays nothing, even though it’s enabled.
I’ve also send the information and device log to you,


I have published a new test version (2.1.74) that should fix the out of range error.
I’m not sure if that is the only issue though so give it a try and let me know.

I got the new Information log but I think you controlled the value using the Homey app?

If that was the case and you still have problems could you control the device (changed modes, etc) with the official Somfy app while my logging is enabled and then send the log to me.

Thanks Adrian,

I only controlled the Valve via Tahoma app to generate the log for you.

Pardon my stupid question, but where and how do I install your 2.1.74 test version?
I only see the production version 2.1.71.


You just add test to the end of the app URL in the store.

Thanks, I just installed .74, but unfortunately still the same errors.
It doesn’t seem to read correct values from Tahoma e.g. says 22 in homey, but 24.2 in Tahoma
Also I have nothing for the Valve in “then” section when creating flows.
Only VELUX is present here.


…I also send the log files :slightly_smiling_face:

Hmm, the logs are strange as they are showing commands being sent from Homey and not the Somfy app.
I have published another test version that has some extra logging in to try and track down why.

Also, it might be useful to remove the valve from Homey and add it again with the new version.

Ups, Sorry my bad, I only operated it from Homey this time.

Now running .75
I have removed the valve and added it again. Log enabled.
From Tahoma I have changed the modes a few times.
Again, notice it fails if I try to send a new command without the previous command being received by the Valve, due to the “up” to 10 min delay.
After this I have sent you the log files (information log was empty)

Thanks :slight_smile:

Strange that the information log is empty.

I purchased a value from Amazon today so should be with me on Sunday.

I have just had a though, In the information log page is the Log Enabled tick blue?
Homey’s format is a grey tick for disabled and a blue tick for enabled. When the tick is grey the log only captures errors and when it is blue it captures everything.

I received the valve and I’m making progress so should have an update soon.

Sounds really good, Adrian. I appreciate your efforts :slight_smile:

OK, there is a new test version in the store.

I recommend that you set the polling interval in the Homey app to 30 seconds to ensure that Homey stays in sync with the valve as best it can.
As you mentioned there is also the delay waiting for the valve to wake up. I have set the device warning to indicate the command is queued and that will be cleared when the valve wakes up and accepts the command and Homey has then polled for the next status update (hence setting the polling to 30 seconds).
Also the sensor capabilities will update at that point.

I was hoping to be able to set the Window Open mode from homey so a Homey contact sensor could be used to trigger it, but it seems that is only an internal state of the valve. So the next best thing is to change to Frost Protection mode when Homey detects an open window and then set it back to Auto or At Home mode when it is closed.

Let me know how you get on or if you think of anything else.

I just tried it out.
Seems to work much better :slight_smile:
The update interval is now set to 30 sec.
I’ve created a basic test flow, so when I open the window Homey sends a “Frost Protection” to the valve and back to “Home”, when I close the window. Really nice :slight_smile:
Initialy I tried just to use the “by date”, but nothing happened. Changing to “Next Mode” worked. It takes up to 10 minutes - I guess there is no way we can get around this, and It’s properly the same with other brands.
However, after a few tests I keep getting “Command queued for device wake up” in Homey.
Still after 40 mins. Now I tried to change mode from Tahoma and still after it reports the command received by valve, I still the error in Homey.
I have send you the log files.

I didn’t try, but isn’t it possible to change to “manual mode” and set the temp to 0 degrees?
Frost Protection is still ok, but if we have -10 outside the valve will still open up a lot …on the other hand, I’ll properly not have the window open all day when we have -10 :upside_down_face:

BTW - the reporting of current temp now also works :slight_smile:

Thanks for the great contribution so far :slight_smile: