Skybell Hd Sync issue

Hi all, I’m wondering if you can help me. I have a Skybell Hd I follow all the installation steps I got my green/red lights flashing but with the skybell app for android after set my phone airplane mode and select skybell network , select your 2.4ghz wifi and after type the 2.4wifi password and click on the green button nothing happens looks like the app doesn’t works but I’m able to switch at advanced mode but with the same result. I already tried with a different cellphone, tablet and the same result. I tried to do hard reset waiting until yellow light and try waiting just until blue light and the same result. I called skybell support and the only answer was return the device because maybe this device has an old firmware. My question is: is there any other free app that I can use with skybell? My skybell is not from or any other company just Honeywell’s. Or if somebody knows how can I use the advanced tab with subnet mask ip etc.

red/green flashing means the device is charging. Wait 20 minutes and try again, wifi is yellow when syncing to network, after that it turns to color you picked in the app.