Satel Integra alarm

Hello there,

Thanks so much for this great plugin!
When exposing the Integra device (Switch since 1.0.0) to Homekit ( it now shows as a switch.

Is there a way to show it there as ‘Security System’? :slight_smile:
I remember someone wrote something about that for another plugin but cannot remember how…

Maybe if the driver would be capability homealarm_state (instead of onoff) that would work. But homealarm_state has 3 states: armed, disarmed and partially armed. I only plan to support two states (on/off).

I don’t have Homekit either, so there is no way I can test easily.

Homeykit support was written for Heimdall, It indeed uses the homestate_alarm capability. It also needed an additional capability to let the device in Homekit show the alarm state, for that I created the alarm_heimdall capability.

@DaneedeKruyff will Heimdall also support Integra? :slight_smile:

@mbnn How would you envision that?

Heimdall is ment to turn your Homey into (simple) alarm system, not integrate with real alarm systems like a Satel Integra. Such systems are not generic and every system would require it’s own Homey app to control it from Homey.

True… Ok.

Hi all,

Its me again.
Yesterday i see a article about homey that v2.0 is availeble as experimental!
ok i did it! :rofl:

but the integra app doesn’t works anymore…
now i am sad! :disappointed_relieved:
this is one of the important apps i have and i was zo lucky it was made.

i add a screen hot the. ip adres and code is changed for the screen shot.
what do i do wrong?
i can’t put the guardx key anywere.

are there more users already to Homey V2.0 and got this app working?

Hi Zuur,

I don’t run experimental, so I cannot test it.

I received a crash report from someone running 2.0.0-rc.2 today.
The error indicates that the usercode was not entered, while the function received a null value.

There is no field for a GuardX key.
This app connects directly to the ETHM-1 module and uses the usercode to perform actions like arm/disarm.

User code was entered. In a flow i can see it sends. (The check at the flow card)
Tomorrow i will try it again.

still nothing. got more issues with homey 2.0. i go to try downgrade the system.

Downgrade it back to 1.5.3.v and now everything is working again. Athom have to fix a lot in v2.0

Hi , did test the app with Homey v2.0.0-rc.2 but unfortunately this is not working anymore.
Did run the app in development athom cli and below is some lines from the output.
Maybe this helps to fix the problem ?

─────────────── Logging stdout & stderr ───────────────

2018-12-12 00:13:54 [log] [integraAlarm] org.myalarm.integra running…
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] Initialize device
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] * Name: Integra Alarm
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] * Driver: satelIntegra
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] * Class: homealarm
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] * Available: true
2018-12-12 00:13:54 [log] [ManagerDrivers] [satelIntegra] [0] * Capabilities: [ ‘onoff’ ]
2018-12-12 00:13:55 [log] [ManagerDrivers] [satelIntegra] [0] * State: { onoff: null }
2018-12-12 00:13:55 [log] [ManagerDrivers] [satelIntegra] [0] * Settings: { alarmaddr: ‘’,
alarmport: 7094,
alarmcode: ****
alarmpart: ‘1’,
alarmpoll: 5000,
alarmtype: ‘?’,
alarmvers: ‘?’,
alarmlang: ‘?’ }
2018-12-12 00:14:23 [log] [ManagerDrivers] [satelIntegra] [0] STATE CHANGE DETECTED to: true
2018-12-12 00:14:23 [log] [ManagerDrivers] [satelIntegra] [0] HomeAlarm state changed to: armed ( true )
str = str.toString(); // force to be string

TypeError: Cannot read property ‘toString’ of undefined
at stringToHexBytes (/drivers/satelIntegra/device.js:38:15)
at integraAlarmDevice.armAction (/drivers/satelIntegra/device.js:490:26)
at integraAlarmDevice.getCommand_arm (/drivers/satelIntegra/device.js:503:21)
at registerCapabilityListener (/drivers/satelIntegra/device.js:294:42)
at integraAlarmDevice.__onCapability (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/Device.js:1:1934)
at emitTwo (events.js:126:13)
at integraAlarmDevice.emit (events.js:214:7)
at integraAlarmDriver.__onCapability (/opt/homey-client/system/manager/ManagerApps/bootstrap/sdk/v2/lib/Driver.js:1:1511)
at emitTwo (events.js:126:13)
at integraAlarmDriver.emit (events.js:214:7)

— INFO: org.myalarm.integra has been killed —


It looks like with RC4 of beta 2.0 the Satel app works again :slight_smile:

Hi @mbnn, that would be great. Had not found that out yet, while looking into creating an updated version to get it working on v2.

Can you check if modifying the settings (Devices => Alarm => Settings => Advanced Settings) works for you.
When I tap the IP address for example I get a white screen and the Homey app on my phone crashes, without any log message.

That menu works fine now with RC4, shows IP, port, usercode and other stuff :slight_smile:

Can you edit them? I cannot, it won’t save the settings.
I experienced something similar with the app.

No I cannot edit them. Thank god they were already in since 1.5 :stuck_out_tongue:

Hmm, it seems that “saving settings” is really slow (Or I’m expecting too much)…
So it seems the app might be working again. I’ll test some more.

Hi, i am about to buy HOMEY and i need to integrate it with Satel integra 64 or 128. What i can read here it is possible, but if i use motion sensors BOSCH ISC-BPR2-WP12, can i use them to make other flows in HOMEY?
Or for flows or automations have to use other sensors? The same question is for window sensors. I am buying new windows and they will already build in sensors like this

, and i can add them to satel, but can i read theis status in HOMEY? Regards

From what I read about the Bosch sensors is that they only work with Satel alarms (@RobbShop). So it seems you cannot use them outside of Satel…
The Satel integration only allows you to turn on/off the alarm.

For the window sensors it will depend what protocol they support. Protocols supported by Homey could potentially allow you to use them… But they may require a Homey-App to “read” them.

1 Like