[App][Pro] Satel Integra alarmsystem integration

Satel Integra alarmsystem integration


  • Partitions alarm state & Control (armed/disarmed)
  • Partitions alarms
  • Door/Window sensors state
  • Motion sensors state
  • Fire/Smoke sensors state
  • Output state & control *1
  • Temperature (wireless) sensors (per device setting)

*1 : Not all outputfunctions can be control thru homey, e.g : remotecontrol(dutch: afstandbediening is tested and works, but burglary(dutch : inbraak) doesn’t
The usercode used in homey needs the correct rights(23) in alarmpanel!

Flow triggers, actions & conditions for all features

Supported alarmsystems equipped with ETHM-1(PLUS) module:

  • Intergra 24
  • Intergra 32
  • Intergra 64
  • Integra 64 PLUS
  • Integra 128
  • Integra 128-WRL (SIM300 & LEON)
  • Integra 256 PLUS

Check your setting with the DLOADX for the ETHM-1 module.
Make sure that the system has a fixed IP-Adress
Only 1 connection to the alarmpanel is possible.

As soon the app is install go to the app settings.
Fill in the ipaddress, port, usercode in and hit the savebutton.

After saving hit the “read alarmpanel” button, if everthing is configured the right way, alarmtype will be display and in the background all partitions, zones and output will be read from the alarmsystem.


As soon the popup is displayed you can add your devices.
As per capability(motion, contact or fire) you can choose which zone from alarmpanel can be added as an device.

Donation is appreciated Donate


Great news, thanks! I’m currently on Fibaro HC and this was the only thing keeping me from migrating to Homey. I had already started to develop an app for this myself, but progress was slow due to a lack of time. Hope your app will be approved soon, thanks again!

After long waiting…
Should be live now…

If using the old app, please remove the devices and deinstall the app first before installing this app

Mmmm, im getting the error : Null is not an object (evaluating ‘alarmtype.match’)

Ip Port and user code should be ok. if i change anything there i get error usercode incorrect.

I have a Intergra 24

HI Marco, are you sure there a no other apps ( like openhab or domoticz or the old app) connected to the satel on port 7094(default).

And these options are set in the DLOADX software?image

Please send me a diagnosticlog and the ID by pm

Yes i’m sure there is no other system connected at that moment.
Tomorrow when im on the site i will do a debug . Thx in advance.

And thx for making the app

I’ve got the same result here. I ran a packet capture and there’s no packets from Homey to the alarm.

Another question: would you be willing to publish / opensource the code / app?

@edwink, @MarcoRuiter let me check if i can reproduce this. I think i know where this goes wrong. if i can reproduce this then the fix is there asap.

@EdwinK, see link https://github.com/mickelluiten/com.satelintegra

1 Like

@EdwinK, @MarcoRuiter , think i found the problem.
Please use testversion 2.1.0 https://homey.app/a/com.satelintegra/test/

Make sure to hit the “Save changes” button after entering IP and port number!
After that hit the “Read alarmpanel” button.

If still not working please send me:

  • Homey fw version
  • Alarmtype (24, 32,) and fw version of the alarm and ethm module
  • screenshot of the setting from the Integra Satel App in Homey
  • if possible screenshot of the ETHM module setting in DLOADX
  • after 5 min, create diagnosticlog and send the ID… (…more, Apps, , hit the wheel in the right corner, Create Diagnostic Report)


Running from cli it throws me the error the libs are missing from the /opt dir
Its also missing on github and running homey app build doest auto download them .

Lets first check if the app is working at your site, For thiis you don’t have to run it from CLI
Just install the test version thru homey store., see my previous post.

Did the 2.1 test first before running cli . Doesn’t work at my sat 24

Oke …tot bad …send me the requested information…

Without that i can’t look for a solution.
Because is runs fine on my Integra 32 system

Hi, is there also an option to make the ETHM-1 Plus module work with Homey?

Did you already used the “old” app https://homey.app/nl-nl/app/org.myalarm.integra/Integra-alarm/ ? If YES then the new one will work…

Lets try…

yes, the old app doesn’t work either…

The ethm-1 plus module is connected to integra panel not a versa panel?
Does DLOADX works over ethernet?

To run it from CLI you need to add some modules.
On a windows machine :

  • Download code from github and unzipped it a folder e.g. c:\temp\com.satelintegra-master or clone it with git.
  • Open a CMD and goto folder cd \Temp\com.satelintegra-master
  • run command npm install homey
  • run command homey app build.

When done run command homey app run, code should be running from CLI

you can set extra debugging on in the app.js file.
Change const debugEnabled = false; to const debugEnabled = true;
Thiis shows also the raw i/o to/from satelpanel.

I have a Integra 32 panal with the latest firmare (also on the ETHM1-Plus).
I have also a connection with the panel