Satel Integra alarm

At home I have a Satel Integra Alarm with the ETHM-1 module to control it via Ethernet connection. So it can be handled by Homey as well :slight_smile:
Though there seems to be no App for it yet. I’ve tried to take a stab at it and I have put my code on GitHub.
It needs to be installed via the developer node.
I’m struggling to make it into a Homey-like app with nice icons and devices, but got Arm and Disarm working. First thing to do now is to make it regularly read the status of the alarm (if someone enabled it via the control panel - outside of Homey).

Please try it out if you see value in it and happily take the code and improve on it to make it a fully functional app.

Ideas/suggestions/explanations on how to implement this are also appreciated.

1 Like

Hi Dirk,

Thanks a lot for your effort to develop this app.
Glad to see that my Satel could be integrated into my Homey.

I do have a Satel Integra 32, with the ETHM-1 module installed.
Unfortunately I’m not able to get it working via your app.
What settings need to be set? Default port 7094 seems ok, but what do you mean by type and security code?
A code that is able to arm and disarm?

Never mind, got it working!
(Wrong port configured in the ETHM-1 module)

Would be great to have the status available, including the alarm notification.

Hi DirkdeDraak,

I’m not able to get the app working.
I have define the IP and Port number.
The port number is the default 7094, but the textbox Type is empty after saving the configuration.
The security code is the code I use to arm the Alarm.

When I look into your code I think the Type must be 1, I have a Integra 32 central.

2018-10-10 20:27:36 [log] [integraAlarm] undefined
2018-10-10 20:27:36 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:27:36 [log] [integraAlarm] Connection to closed.
2018-10-10 20:27:36 [log] [integraAlarm]

Port number

English Menu:
Service mode > Structure > Hardware > LCD Keypads > Settings > ETHM-1 > Port (Integr.): 7094

Dutch Menu:
Service mode > Structuur > Hardware > Bediendelen > Instellingen > ETHM-1 > Poort (Integr.): 7094

Is this the correct port number?
And why is the textbox Type empty after saving the configuration and reloading the page?


I apparently got one time a short connection on port 7091

2018-10-10 20:51:04 [log] [integraAlarm] org.myalarm.integra running...
2018-10-10 20:51:04 [log] [integraAlarm] Alarm accessible at: @ 7091
2018-10-10 20:51:06 [log] [integraAlarm] Connected to
2018-10-10 20:51:06 [log] [integraAlarm] Received data from alarm...
2018-10-10 20:51:06 [log] [integraAlarm] - incorrect answer
2018-10-10 20:51:06 [log] [integraAlarm] - payload: 69,E1,AB,6B,4C,AA,BD,4A,2D,3F
2018-10-10 20:51:06 [log] [integraAlarm] - command: 69
2018-10-10 20:51:06 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:06 [log] [integraAlarm]
2018-10-10 20:51:09 [log] [integraAlarm] *** Monitor alarm status: 0
2018-10-10 20:51:09 [log] [integraAlarm] undefined
2018-10-10 20:51:10 [log] [integraAlarm] Connected to
2018-10-10 20:51:10 [log] [integraAlarm] Received data from alarm...
2018-10-10 20:51:10 [log] [integraAlarm] - incorrect answer
2018-10-10 20:51:10 [log] [integraAlarm] - payload: 0F,23,44,F6,BF,F8,AE,7E,4B,83
2018-10-10 20:51:10 [log] [integraAlarm] - command: 0F
2018-10-10 20:51:10 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:10 [log] [integraAlarm]
2018-10-10 20:51:15 [log] [integraAlarm] *** Monitor alarm status: 1
2018-10-10 20:51:15 [log] [integraAlarm] undefined
2018-10-10 20:51:15 [log] [integraAlarm] Connected to
2018-10-10 20:51:15 [log] [integraAlarm] Received data from alarm...
2018-10-10 20:51:15 [log] [integraAlarm] - incorrect answer
2018-10-10 20:51:15 [log] [integraAlarm] - payload: A5,77,A6,75,57,7D,CA,D1,B5,5D
2018-10-10 20:51:15 [log] [integraAlarm] - command: A5
2018-10-10 20:51:15 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:15 [log] [integraAlarm]
2018-10-10 20:51:20 [log] [integraAlarm] *** Monitor alarm status: 2
2018-10-10 20:51:20 [log] [integraAlarm] undefined
2018-10-10 20:51:20 [log] [integraAlarm] Error: Error: connect ECONNREFUSED 172.16240.253:7091
2018-10-10 20:51:20 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:20 [log] [integraAlarm]
2018-10-10 20:51:25 [log] [integraAlarm] *** Monitor alarm status: 3
2018-10-10 20:51:25 [log] [integraAlarm] undefined
2018-10-10 20:51:25 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:51:25 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:25 [log] [integraAlarm]
2018-10-10 20:51:30 [log] [integraAlarm] *** Monitor alarm status: 4
2018-10-10 20:51:30 [log] [integraAlarm] undefined
2018-10-10 20:51:30 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:51:30 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:30 [log] [integraAlarm]
2018-10-10 20:51:35 [log] [integraAlarm] *** Monitor alarm status: 5
2018-10-10 20:51:35 [log] [integraAlarm] undefined
2018-10-10 20:51:35 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:51:35 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:35 [log] [integraAlarm]
2018-10-10 20:51:37 [log] [integraAlarm] Arm alarm
2018-10-10 20:51:37 [log] [integraAlarm] - Arguments =[object Object]
2018-10-10 20:51:37 [log] [integraAlarm] - State =[object Object]
2018-10-10 20:51:37 [log] [integraAlarm] Execute command Arm2 with delay (0x80)
2018-10-10 20:51:37 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:51:37 [log] [integraAlarm] Connection to closed.
2018-10-10 20:51:37 [log] [integraAlarm]
2018-10-10 20:51:40 [log] [integraAlarm] *** Monitor alarm status: 6
2018-10-10 20:51:40 [log] [integraAlarm] undefined
2018-10-10 20:51:40 [log] [integraAlarm] Error: Error: connect ECONNREFUSED
2018-10-10 20:51:40 [log] [integraAlarm] Connection to closed.

After this action I got no responses anymore, not even after a restart or a port change from 7091 to 7094 and back to 7091.

Great to see someone has taken the time to develop a Satel Integra Alarm for Homey :slight_smile: Thank you!
I will test this out soon, but will this also be available in the Homey app store soon? :slight_smile:

So uhm, how do you now arm or disarm exactly? Cause i can throw the then flow card but what should be the if?

There’s definitely something wrong with that app. In Homey, in settings it shows - The app is running in debug mode. When I type the type of the Integra in settings, after saving it the entry disappears.

I know Domoticz has brilliant app that integrates with Satel Integra. Does anyone know if it’s possible to control it via Homey by connecting through Domoticz?

@rafi: I’ve not released it as an app that you can download (yet). It can only be run in debug mode.
The type field was merely there, while I wanted the code to report the type of Integra Alarm it had detected by itself at first connection attempt. I’m having difficulties trying to read a set value and displaying it in the settings sections.

@mbnn: While there is not yet a way to detect alarm state changes from within the code, you are bound by events that will tell you there is no one home anymore or that a person is coming home. You use those to trigger arm/disarm commands.

Ok I hope you can get a button in or something to arm/disarm and get it on the appstore :slight_smile: Thanks!

I’ve created a beta app (version 0.0.1) and it’s available in the App store:

Note that once you have entered (altered) the IP address, or the arm/disarm code, you have to restart the App to activate the changes.

It should recognize your Integra alarm if it was able to connect and display that in the settings page.

When i go to that page i get: You’ve found a blind spot!

The page you tried to visit was not found

Hi @mbnn, I published it as a beta to the App Store. It is pending review for public availability from Athom. A bit of patience…
Other option: download the code from GitHub and run “athom app install”. That makes it persistent as well.

No worries, sorry didnt know I had to wait :slight_smile: Ill wait for it.
Will you also expose the Arm/Disarm (when available) to Homekit? :slight_smile:

Bumped version to 0.0.9.
Updated the code to have more Flowcards implemented (trigger, action and status).
Pending review from Athom to show up in the App store (as beta).

If you want to use the code before that, download it from GitHub, and run “athom app install”.

I’m looking to see if I can “pair” as a device and have a nice icon… Though for now you can use a Virtual Device if you want.

Thanks :slight_smile: Hopefully it will be approved soon! :slight_smile:

Approved and available as beta version 0.0.9

ok! i am realy happy with this app! spot it today in the app store and installed it to my homey.

at the beta app from homey it crashes. at the desktop pc i can configure it. at the start of the app i got 3 blank pop ups. klicked 3 times ok and punt the ip adres and code for homey in the app.

it works like a charme! wauw what a nice app!

the 3 flows i made for now in a few minutes

1.Flow “Sleep” / Command i go to sleep / everything off / alarm Armed.
2.If flow "sleep"is running check if alarm is armed / send push massage “alarm s armed”.
3.If its after sunset and the alarm is getting disarmed put the lights on.

developper Realy thanks! you made my day!

1 Like

@zuur, thank you for the feedback. I’ll look into those 3 blank screens.

Glad it works for someone else as well :slight_smile:

1 Like

Version 1.0.0 is now available.


  • Can now be used added as a Device with on/off toggle
  • Keeps track of the status of the alarm
  • Settings to be made per Device
  • Polling interval adjustable
  • Partition list to arm adjustable
  • Trigger FlowCard for Arm/Disarm available
  • Status FlowCard for Armed/Disarmed available
  • Action FlowCard to Arm/Disarm available
  • Languages supported: NL, EN

Advice: uninstall the 0.9 beta and cleanly install 1.0.0.