Room activity always "Active"

Hello folks. I have a Homey Pro, and I recently added a Hue motion sensor to the Hue bridge. This gets added easily enough via the Anthom Hue app.

Once I added the device, the room is always “Active”. This means flows that use activity do not work as expected.

With trial and error, I noticed that adding the motion sensor into a new zone within the room works. The activity of the new zone is updated correctly to “last active x mins ago”. However the room’s activity status remains “Active”.

Dpes anyone have an explanation on why this happens? Better yet, how do I debug this?

I have the same issue. Made a support ticket and got an answer that they are aware of the situation. They closed the ticket for now with the remark I had to wait for a solution to become available.

So actually there is no workaround like restarting the Homey Hue app or restarting of Homey?

So, I did some digging around and it turns out that the issue was another device (in my case a Bosch washing machine) that was the causing activity to stay “Active”.

The washing machine seems to have an option “Activate zone on contact alarm”. And one of the contact alarms is “Door Open”. Which is in theory all good and well, but in practice since the washing machine door is opened for the laundry to be taken out is then turned off (likely with the door left open to dry), it ends up with the contact alarm never being turned off even if the door is shut (since power is off at this point). At least not until the washing machine is turned on again.

In my case, I “fixed” the issue by first manually triggering the contact alarm on event followed by a contact alarm off event and then disabling the “Activate zone on contact alarm” for the washing machine.

This is “expected behaviour” I guess? But feels like this could use some improvements to handle edge cases like the device going offline etc. The zone activity triggered flows all get affected by this, sometimes unexpectedly.

Maybe one or more of the improvements can be useful?

  • A configuration to set a timeout on the specific contact alarms. Ideally with the ability to auto reset activity.
  • Ability to filter contact alarms that trigger zone activity.
  • Ability to write a flow or programmatically set activity to inactive/active manually.

@Kringloper could your issue have been caused by something similar?

@DirkG restarting the app/homey did not clear the status either unfortunately in my case, sine the alarm was already on.

@null, unfortunately not. I have a zone which is active without any devices in it. I made a new room and moved alle devices to that room and therefore the issue is solved. But the zone is still active and no possibility found to make it inactive.

The setting to exclude a device from room activity was checked before submitting the support call.

But glad you’re issue is solved. I just wait for a fix and untill than one of my zones is just misreporting the active state.

I am guessing you already tried recreating the zone?

For me, I had to re- enable the status alarm for the device that created the alarm and then force an event that set activity to inactive before disabling the option.

Sounds like in your case it’s different or the device has been deleted or moved. Hope you get a fix soon.