Ring image grabber problem

OK, put in a 1sec delay here also, let’s see what it does :slight_smile:

Here it does not work either. I wil try the delay too.

Tested with the delay also, but I never get a recent picture. No matter how big or small I set the delay. And I get the same picture for triggers that are minutes apart. Seems like the picture is updated once every 20 minutes of something like that.

The sec delay works for me. Still not very happy with the way it works in iOS, but atleast it works. I just don’t get when it should present the photo. I see the notification in my device with! photo but very small. When I click on it, it opens the Homey app but then it almost never pops up. Sometimes it pops up when i restart the app, or when i switch tabs… Is this known behavior?

I think ring only updates the picture on an event like motion detection, button pressed or someone opening the live viewer. Maybe you are trying to retrieve a picture without waiting for one of these events? Do you trigger on ring motion, or on something else?

[Off topic] I suggest ditching Homey notification system and using Pushover: Pushover Notifications
Way more flexible and user friendly.

Nice overview, keeps a history!, click on a message shows additional information, clicking on an image shows it fullscreen.

1 Like

Not on my end, I have triggers for both motion and ringer alarms, but still the same picture. I am going to put a clock in view so I can see how often a new picture is taken :grin:


Which ring do you have? Maybe different rings behave different. I have the pro.

It’s not a PRO of a II; it’s the Ring Video Doorbell with EAN code 0852239005024. Anyone with that model having a working setup?

I’m using a pro too

@Le_Cactus how is your Ring powered? A Ring Pro uses a continuous power source, it seems battery operated Rings behave different.

I use a powered Ring V2.
Same problems. No new image, or at least no visitor in the picture.

Hi guys. Great work with the app! You are the true HA-heroes :slight_smile:
I have tried with Ring 2 (with wired power) and experience same problem with no new image.

Question for those with pro: how long does it usually take to load the live view in the ring app? Instantly of more than 2 seconds? Perhaps the behaviour is different this way? Sometimes it takes my doorbell a few secs to start the feed. Don’t know if snapshots are different.

I appreciate your efforts and hope it continues!

Opening live video on the ring pro can definitely take some time. 2 to 6 seconds I guess.

Hi @Gruijter I do not see the

Then… snapshot option

I do not see any ring cameras showing in the ‘Then…’ part of the flow

Can anyone help?

I’ve tried to revoke my authorisations and reapply

You need to install the beta version of the app

I’m on 2.1.2 beta app from the athom App Store

Is this the one you mean?

Yes that’s the right one. Which device are you using?

2.1.2 is correct. And you did add the ring as device also?

Hi this is what I have did