Rename flow - flow no longer starting from other flow


When a rename a flow, this flow is no longer started from another flow .Is there something I am doing wrong?

Or does Athom link flows by Name? I hope it’s linked with a GUID or something, so that when you change the name its’ still linked.

1 Like

How did you rename it? From the web editor, it doesn’t matter if I rename a flow, it still works when called from another flow.

In the Android app.

Example, Flow 1:
When --> This flow has started
Then --> Start a flow (item = Flow 2)

Flow 2:
When --> This flow has started
Then --> SimpleLog - Add to Log

Open Flow 1 , Test flow, then I get a new log in SimpleLog

Then I rename Flow 2 to Flow ABCD.

Open Flow 1, under ‘Then’ it still shows ‘Start Flow 2’
It;s no longer called Flow 2. Then we I test Flow 1, there is no new log.

@robertklep When you rename a flow, does the original flow show the new name?

No, it keeps showing the old name. I just tried on iOS, and it keeps on working when I rename the second flow.

Are you using the experimental v5 firmware? I’m still on v4 so perhaps it’s related to that.

No, I’m also still on v4.
I’ll try again once I’m on v5.
If it doesn’t work then, I’ll create a Support ticket.

@robertklep thanks for your time!

One thing you can try (to rule out it’s an issue with the Android app) is to use the web editor to see if the problem persists.

2016 (and it also mentions activating/deactivating while we’re talking about starting) :stuck_out_tongue: And like I said: I can’t reproduce the issue.

Flow works for me in flow dot homey dot app. Name does not change tho.
Think we did not have start a flow back in 2016?

I don’t know if the post was specific to activate/deactivate or not, I don’t go back (with Homey) that long :stuck_out_tongue:

I reported the ‘renaming not updating references’ problem 2 years ago. But I don’t see the problem of it not running the renamed flow either.

Tried renaming a flow via the webinterface, it doesn’t rename the corresponding START FLOW cards. Although the flow process is still working, it’s very confusing.

1 Like

I agree, hopefully this will be fixed