[Bug] Flow renaming isn’t consistent

When flows are renamed it doesn’t appear to update the names of the cards where the flows are being used in other flows.

I do don’t know if this is an iPhone app but, or an underlying issue. I presume the later.

  • Create a flow: called A
  • Create a flow: called B which has “Then: start flow A”
  • Rename flow A to flow C
  • Observe flow B still references flow A

References to “flow A” should be update to “flow C”

I guess this is Mobile App independent, had been on Android as wel and I don’t know if it is fixed. But I Guess not ;-(
Let’s see if it is also in the WebApp,

Checked: Yes, it is :wink:
So I Think it is an Homey Core Issue …

is reported several times like:

and more.

I’ve raised it as a support bug:

Thanks for reaching out! Your request (115379) has been received and is being reviewed by our support staff.

I’ll update the bug to reference the threads you’ve found.


It’s a pretty serious one. Renaming a flow should never be allowed to break anything.

Did you check if it actually breaks the flow? Because for me it doesn’t, all it does is not show the correct name anymore.


No, it doesn’t break the flow
it still uses the UID but caches the Called Flow name in the calling Flow.

The original Github Ticket was #330 from Johan Kusters :wink: ~ 10 mrt 2016 FW 0.8.22

[homey] Flow keeps its old name in flow action after rename (#330)

To be sure also tested this now in Homey Pro (Early 2023), have seen thing reported that I had tested on an Classic Homey that worked… but indeed was broken on the New Homey.

Mine is a Homey Pro.

Glad to know that the flows aren’t actually broken. Not sure why they would want to cache the names. The rate of name lookups surely aren’t enough to out weigh the cache inconsistency.

But is it a 2023?
That vs Homey (cloud) vs the Homey (Pro) (Early 2016 -2019)
Can have different results.

But as I run probably newer FW and Mobile App…
Don’t expect it in the next version fixed

Yes. Just bought new. (Confirmed app says early 2023)

Strangely, if you delete a flow, then isn’t deleted from the calling flow. The caller still thinks that it exists.

I would expect the flow to be marked broken,
And that saving wouldn’t be possible until you chang to an existing tlow.

But i can’t say if i have tested it before, and there has changed a lot since 2016.

It’s not marked broken, there’s no indication that the flow you’re trying to call doesn’t exist anymore. Only when you test the flow will a red triangle show up (but only during that session, if you reload the page there’s again no indication that the flow is broken; might be different on the mobile app, haven’t checked there).

1 Like